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For additional help topics, please refer to the TestGen® Help menu. 

 

Also, any hyperlinks within this guide will lead to a detailed explanation in the TestGen® Help tool.  

http://www.tamarack-software.com/webhelp/webhelp764t/tg7help.htm
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What is TestGen®? 
 

TestGen® is a complete, state-of-the-art test generator software package that allows instructors to easily 

create and administer tests on paper, electronically, or online. They can select test items from publisher-

supplied test banks included with TestGen® for rapid test creation or create their own questions from scratch. 

Questions can include stylized text, symbols, graphics, and equations that are inserted directly into questions 

using built-in mathematical templates. TestGen®'s random generator provides the option to display different 

text or calculated number values each time questions are used. With both quick-and-simple test creation and 

flexible and robust editing tools, TestGen® is a complete test generator system for today's educators. 

 

How to Access TestGen® 
 

1. Enter your Connect course. 
2. Locate the Library tab.  

 
 
 
 

3. Click on Instructor Resources. 
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1. Click on Test Bank. 

 
 

2. To get started with TestGen®, you must first install the software. (Select based on PC or Mac.) 
 

 

3. Open the file.  
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4. Click Run. 

 

5. Once downloaded, 
TestGen® will be 
available from your 
program menu. 
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6. Next, return to Instructor Resources. Click on Test Bank files to download the text-specific test bank 
files.

 
 

7. Lastly, open the TestGen® software via the program menu. The test bank will appear on the left side of 
the screen.
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Features and Navigation 
 

TestGen® has many useful features, which include: 

o List titles of frequently used test banks in the Test bank Library 

o View test bank and test questions on-screen 

o Add questions to tests using drag-and-drop or point-and-click transfer 

o Build quick tests with the TestGen® Wizard 

o Choose from a variety of question types: multiple-choice, bimodal, short-answer, true/false, matching, 
essay, and vocabulary 

o Sort test questions with a built-in SmartSort or a customized order 

o Add and modify test and test bank questions on-screen 

o Print up to twenty-five forms of a single test 

o Set up a filter to show only the test bank questions that meet your specified criteria 

o Recalculate variables in questions 

o View descriptor information for each question 

o Use symbol palettes and templates to insert math notation 

o Insert graphics on tests and in test banks 

o Create Cartesian, polar, and number line graphs for mathematics using a built-in graphing tool 

o Use a built-in spell checker 

o Export tests as text (.txt, .rtf), Acrobat (.pdf), or web (.html) files; as interactive HTML practice tests; or 
as files that are compatible with various course management systems such as Blackboard® 6.x-9.x, 
WebCT CE 6.x and WebCT VISTA, Desire2Learn®, Sakai®, and Moodle® 1.9.x-2.x. 

  

TestGen® 7.6 for Microsoft® Windows™ has the following minimum system requirements: 
o Windows 8, Windows 7, XP, or Vista operating system 
o 128 MB of RAM (random access memory) 
o 16 MB of hard disk space (varies depending on the test bank size). 

TestGen® 7.6 for the Macintosh® computer has the following minimum system requirements: 
o Macintosh OS X v.10.5-10.8 
o 128 MB of RAM (random access memory) 
o 16 MB of hard disk space (varies depending on the test bank size). 

  

 

http://www.tamarack-software.com/webhelp/webhelp764t/TBLib/tbopen.htm
http://www.tamarack-software.com/webhelp/webhelp764t/ChooseQuest/wizard.htm
http://www.tamarack-software.com/webhelp/webhelp764t/WorkwithQues/sort.htm
http://www.tamarack-software.com/webhelp/webhelp764t/ChooseQuest/tbfilter.htm
http://www.tamarack-software.com/webhelp/webhelp764t/MathEdit/regen.htm
http://www.tamarack-software.com/webhelp/webhelp764t/MenusTbars/express.htm
http://www.tamarack-software.com/webhelp/webhelp764t/MathEdit/graphs.htm
http://www.tamarack-software.com/webhelp/webhelp764t/TGTools/spell.htm
http://www.tamarack-software.com/webhelp/webhelp764t/PrintExport/pdf.htm
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The TestGen® menu bar, located at the top of the TestGen® application window, is the place to look for all the 
controls you need to work in TestGen®. Many of the options listed on the menus display keyboard shortcuts 
you can use instead of making selections from the menus. Three toolbars, which you can display below the 
TestGen® menu bar, contain icons for functions that are frequently used when working with tests and test 
banks. 

 

 

 

 
File Menu 
The File menu includes options to open, close, save, and create test banks and tests. It also includes standard 
page setup and print options, the option to add test bank titles to the Test bank Library, and options to export 
tests to a variety of different formats. The "Exit" option closes the TestGen® application. 
 
Edit Menu 
The Edit menu includes standard editing options for Undo/Redo, Cut, Copy, Paste, Insert, Replace, and Delete, 
and Select All. You will also find "Find and Replace" on the Edit menu. 
 
View Menu 
The options on the View menu allow you to show or hide to provide additional tools and information or 
reduce screen clutter, as needed: 

o the Standard toolbar, Text Formatting toolbar, or Equation Editing toolbar, 

o the Test bank Library and Resource Library, 

o rulers used for test and test bank editing, 

o summary information for tests and test banks, 

o a toggle to view either question IDs or question text in test banks and tests, 

o a toggle to view either variable names or variable values in questions that contain user-defined or 
programmed variables, 

o invisible characters, such as tabs and spaces in text edit fields, 

o question properties when editing test banks, 

o the test bank setup dialog for new test banks. 

Insert Menu 
The options on the Insert menu let you insert questions and components of questions onto tests or into test 
banks: 

o questions and additional answer choices, 

o tables, pictures (graphics), graphs, international characters, and randomized variables. 

In addition, you can use the Insert menu to insert page breaks on tests and new section headings in test banks 
open for editing. 
 

http://www.tamarack-software.com/webhelp/webhelp764t/TGTools/shortcuts.htm
http://www.tamarack-software.com/webhelp/webhelp764t/TBLib/manlib.htm
http://www.tamarack-software.com/webhelp/webhelp764t/TGTools/find.htm
http://www.tamarack-software.com/webhelp/webhelp764t/MenusTbars/command.htm
http://www.tamarack-software.com/webhelp/webhelp764t/MenusTbars/format.htm
http://www.tamarack-software.com/webhelp/webhelp764t/MenusTbars/express.htm
http://www.tamarack-software.com/webhelp/webhelp764t/TBLib/showlib.htm
http://www.tamarack-software.com/webhelp/webhelp764t/ResourceLib/qtemp.htm
http://www.tamarack-software.com/webhelp/webhelp764t/EditTB/ruler.htm
http://www.tamarack-software.com/webhelp/webhelp764t/ChooseQuest/tstinfo.htm
http://www.tamarack-software.com/webhelp/webhelp764t/TBLib/tbinfo.htm
http://www.tamarack-software.com/webhelp/webhelp764t/TBLib/swview.htm
http://www.tamarack-software.com/webhelp/webhelp764t/MathEdit/variable.htm
http://www.tamarack-software.com/webhelp/webhelp764t/EditTests/modifyq.htm
http://www.tamarack-software.com/webhelp/webhelp764t/EditTB/propedit.htm
http://www.tamarack-software.com/webhelp/webhelp764t/AdvEdit/newtb.htm
http://www.tamarack-software.com/webhelp/webhelp764t/ResourceLib/qtemp.htm
http://www.tamarack-software.com/webhelp/webhelp764t/AdvEdit/tables.htm
http://www.tamarack-software.com/webhelp/webhelp764t/EditTests/graphics.htm
http://www.tamarack-software.com/webhelp/webhelp764t/MathEdit/graphs.htm
http://www.tamarack-software.com/webhelp/webhelp764t/EditTests/foreign.htm
http://www.tamarack-software.com/webhelp/webhelp764t/MathEdit/variable.htm
http://www.tamarack-software.com/webhelp/webhelp764t/AdjLayout/pgbreak.htm
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Question Menu 
The Question menu contains an assortment of functions related to working with questions on tests: 

o sort, scramble, pin/unpin, lock/unlock number values, assign point values; 

o calculate new values for randomized numbers 

o change the question type, mark the correct answer, or change the answer blank style. 

 
Tools Menu 
The options on the Tools menu assist in the preparation of tests and test banks: 

o spell check for tests and test banks, 

o header-footer editor for test pages and test banks, 

o macro editor to set up frequently used text or expressions to insert in test items, 

o graphics library and transparent graphics to manage pictures (graphics), 

o global style replacement to universally change fonts, size, and styles in tests and test banks, 

o filter test bank content to view only questions that meet specified criteria, 

o evaluated answer editor to define acceptable forms of the correct answer for short answer and 
bimodal questions (in short answer form) on web tests, 

o preferences for the TestGen® application, tests, and test banks, 

o change password or reset TestGen® to the default settings. 

 

Window Menu 

Each time you open a test or test bank, it opens in its own TestGen® editing window. The Window menu 
contains the Arrange option, which resizes all of the open windows and positions them so that they cascade 
down from the upper left corner of the screen. 

The Window menu also lists all the open and active windows so you can click on any of the window titles in 
the list to bring the desired window to the front of other open windows. 

When more than one test or test bank editing window is active, if you close one of the test or test bank editing 
windows, other windows remain open. When you close the last open test or test bank editing window, 
TestGen® keeps running and the Startup pane shows at the right side of the screen. 

 

Help Menu 

The Help menu provides a link to TestGen®'s built-in Help, which is an online user's guide that includes full 
instructions for using all of TestGen®'s functions. There is also an option to check for the availability of 
program updates. 

  

http://www.tamarack-software.com/webhelp/webhelp764t/WorkwithQues/sort.htm
http://www.tamarack-software.com/webhelp/webhelp764t/WorkwithQues/scramble.htm
http://www.tamarack-software.com/webhelp/webhelp764t/WorkwithQues/pin.htm
http://www.tamarack-software.com/webhelp/webhelp764t/WorkwithQues/lock.htm
http://www.tamarack-software.com/webhelp/webhelp764t/WorkwithQues/points.htm
http://www.tamarack-software.com/webhelp/webhelp764t/MathEdit/regen.htm
http://www.tamarack-software.com/webhelp/webhelp764t/EditTests/changeqt.htm
http://www.tamarack-software.com/webhelp/webhelp764t/EditTB/editsa.htm
http://www.tamarack-software.com/webhelp/webhelp764t/TGTools/spell.htm
http://www.tamarack-software.com/webhelp/webhelp764t/AdjLayout/pghdr.htm
http://www.tamarack-software.com/webhelp/webhelp764t/AdvEdit/macro.htm
http://www.tamarack-software.com/webhelp/webhelp764t/AdvEdit/graphlib.htm
http://www.tamarack-software.com/webhelp/webhelp764t/AdvEdit/graphlib.htm#Transparent
http://www.tamarack-software.com/webhelp/webhelp764t/AdvEdit/gsr.htm
http://www.tamarack-software.com/webhelp/webhelp764t/ChooseQuest/tbfilter.htm
http://www.tamarack-software.com/webhelp/webhelp764t/MathEdit/eaedit.htm
http://www.tamarack-software.com/webhelp/webhelp764t/TGTools/prefs.htm
http://www.tamarack-software.com/webhelp/webhelp764t/GetStarted/pwd.htm
http://www.tamarack-software.com/webhelp/webhelp764t/TGTools/reset.htm
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The Standard toolbar contains icons that are shortcuts for many of the frequently used functions found on the 
TestGen® menus —File, Navigate, View, Question, and Tools. If the Standard toolbar is not visible, select 
Toolbars > Standard from the View menu. 

 

 1 New - Start a new test or test bank by making a selection on the Startup pane 

Open - Open a test or test bank file 

Save - Save the test or test bank that is in the active editing window 

Print - Print the test or test bank that is in the active editing window 

2 Previous - Display the page or screen that precedes the current page of questions in a test or test 
bank 

Next - Display the page or screen that follows the current page of questions in a test or test bank 

Jump - Go to the start of a test page you specify by number 

Top - Display the first page or screen of questions in a test or test bank 

Bottom - Display the last page or screen of questions in a test or test bank 

3 Test Information (or Test bank Information) - Display a summary of the types and numbers of 
questions on the current test or in the selected test bank 

Calculate New Values - Display a new set of randomly generated number values for all variables in 
the selected question(s) 

Lock Number Values for Question - Keep the same number values that are currently displayed for all 
variable numbers even if numbers in other items are recalculated 

Mark or Unmark as Correct Answer - Indicate the currently selected answer choice as the correct 
answer for a multiple choice or true/false question (can also be used to remove the correct answer 
mark) 

Pin or Unpin Question/Answer Position - Lock the selected question or answer choice in place so it 
retains its absolute position even if the order of other questions or answer choices are scramble 

4 Scramble - Randomly change the order of questions and/or answer choices on tests 

Sort - Arrange the questions on a test according to the preferences set by the instructor 

Assign Point Value - Assign the number of points for the selected question(s) to be used to calculate 
the total score for a web test 

Answer Key - Access the answer key test options. 

http://www.tamarack-software.com/webhelp/webhelp764t/MenusTbars/tgmenu.htm
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5 Show or Hide Library - Display or close the Test bank Library at the left side of the TestGen® window 

Toggle Bimodal Questions - Change the display of the selected bimodal question(s) from multiple 
choice to short answer format or from short answer to multiple choice format. Also changes the 
form of Vocabulary questions so that the question (term) and answer (definition) are reversed on a 
test. 

  

The Text Formatting toolbar contains icons that are shortcuts for frequently used editing functions and tools, 
some of which are not found on the TestGen® menus. If the Text Formatting toolbar is not visible at the top of 
the TestGen® window, select Toolbars > Text Formatting from the View menu. 

 

1 Cut - Delete the selected item(s) but keep a copy in memory 

Copy - Leave the selected item(s) as is and keep a copy in memory 

Paste - Place whatever was copied or cut into memory at the location of the cursor 

Delete - Remove the selected item(s) and do not keep a copy in memory 

2 Find and Replace - Locate specified text in all or part of a test or test bank with the option to replace 
it with other text 

Spell Check - Start the spell check tool for the selected test or portion of a test bank 

3 Font - Select a font to apply to the selected text 

Font Size - Select a font size to apply to the selected text 

Bold, Italic, Underline - Apply bold, italic, or underlining to the selected text 

Styles - Apply plain, bold, italic, underlining, or other styles to the selected text by choosing them 
from a list 

Text Color - Apply a standard or custom color to the selected text 

4 Align left - Position the selected paragraph, picture, graph, or table at the left edge of the edit area 

Align center - Position the selected paragraph, picture, graph, or table horizontally in the center of 
the edit area 

Align right - Position the selected paragraph, picture, graph, or table at the right edge of the edit area 

Justify - Insert space as needed in each line of the selected paragraph(s) so that the text is even with 
the left and right margins of the text area 
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The Equation Editing toolbar at the top of the TestGen® application contains tools to insert symbols not found 
on the keyboard, math equations, and pre-formatted tables. If the Equation Editing toolbar is not visible, 
select "Toolbars > Equation Editing" from the View menu. 

Symbol Palettes 

Each of the first nine icons on the Equation Editing toolbar opens a palette of symbols that you can insert at 
the current location of the cursor while you are typing or editing. 

 

1 Operations - mathematical operations, composition, abstract algebra 

2 Relations - equality, approximate inequality, inequalities 

3 Sets and Logic - sets, proofs, logic 

4 Geometry - geometric figures and symbols 

5 Arrows, Lines and Bars - directional arrows and line segments 

6 Greek Uppercase Letters - capital Greek alphabet 

7 Greek Lowercase Letters - lowercase Greek alphabet 

8 Script Letters - symbols for number sets 

9 Miscellaneous Symbols - infinity, degree symbol, currency, checkmark, imaginary "i" 

Math Templates 

The seven template icons on the Equation Editing toolbar each display a palette of mathematical or scientific 
expression templates that you can insert at the cursor location. The templates contain slots, or fields, for you 
to enter numbers or text, and the expressions change size dynamically as you enter numbers or text in any of 
the fields. 

 

1 Fractions, mixed numbers, superscripts, subscripts, grouping box 

2 Radicals, long division, synthetic division, sinking funds, annuities 

3 Over and under bars, braces, rays, lines, arcs 

4 Hat, tilde, cross-out, primes 



 
 

13 | P a g e  
 

5 Integrals, summation, co-product 

6 Parentheses, vertical bars, double bars, braces, brackets 

7 Determinants, matrices, pre-formatted charts and tables 

Click a template to insert it at the cursor location, and fill in the cells with text or numbers as desired. 

More details on using templates are in the "Math-Related Editing" section. 

 

  

http://www.tamarack-software.com/webhelp/webhelp764t/MathEdit/symbadv.htm
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Creating a Test 

You can start a new paper test in any of the following ways: 

o click the Paper Test button on the Startup pane, 

o select New Test from the File menu, or 

o click the TestGen® Wizard button on the Startup pane. 

When you create a new test, choosing a paper test implies that the test will be printed and distributed on 
paper, but a paper test can also be exported to an RTF file, a PDF file, or a formatted HTML file. 

Features of a Paper Test 

Paper tests can include all question types, and you can choose questions by any of the methods described in 
the topic "Choosing Questions from a Test bank". After selecting the questions you want, modify the content 
as needed, and adjust the test layout. Then save and print the test. 

Below are a few of the options available for paper tests: 

o can use the TestGen® Wizard to choose questions randomly 

o can include a variety of question types: multiple-choice, short answer, bimodal, true/false, matching, 
essay, and vocabulary 

o can customize the test header, page headers and footers 

o can insert page breaks 

o can insert "notes" between questions 

o can customize question type headers 

o can see test pages and answer key on-screen before printing 

o can "pin" questions to prevent scrambling 

o can sort questions 

o can print multiple forms of a test by shuffling question and/or answer choice order 

o can export the test to RTF, PDF, or HTML formatted files 
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Saving a New Test 

Each time you start a new TestGen® 
test, it is temporarily named "Untitled" 
followed by a number—"Untitled1.tst" 
for example. The test name appears at 
the top of the test window 

 

 

 

Click Save Test As from the File menu to open the file 
dialog and give the test a name if it has not previously been 
saved to disk.  

 

 

 

Opening an Existing Test 

The easiest way to open an existing test is to find its 
name in the Recent Tests list on the Startup pane. 

Click any of the Recent Tests to open it in the editing 
window. 

If you don't see the name of the test you want in the 
Recent Tests list, select "Open" from the File menu. In 
the file dialog, locate the name of the test you want to 
open and click Open. You can identify a TestGen® test 
file by its icon, which looks like a piece of paper with a 
pencil next to it, and its filename extension, which is 
.tst. 

 

Note: TestGen® saves and looks for tests in a Tests folder inside the TestGen® folder, which is 
located in your system-approved user Documents folder. You can change the location where tests 
are stored by selecting "Preferences" from the Setup menu and clicking the File Locations tab. 

 

http://www.tamarack-software.com/webhelp/webhelp764t/TGTools/prefs.htm
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This section gives a quick overview of the basic steps for making a paper test. All the procedures and options 
are described in more detail in other sections of TestGen® Help. Use the links in the paragraphs below or the 
Help table of contents to get more information. 

 

1.  Start the TestGen® program 

If you followed the typical installation, you can start the TestGen® application 
from the shortcut on your desktop or from the Windows Start menu or from 
the TestGen® folder on your Macintosh hard disk.  

 

 

 

2.  Open a Test bank 

If you followed the typical installation, one or more test banks are listed in 
the Test bank Library at the left side of the screen. If the Test bank Library is 
empty, select "Add Test bank to Library" from the File menu and locate and a 
TestGen® test bank file, which usually is named with the abbreviation for a 

textbook and has a .BOK 
extension (e.g., psych.BOK, 
chem.BOK, or alg.BOK). 

In the Test bank Library, click 
the plus (+) sign next to the test 
bank you want to use to display 
its chapter titles. Click the plus 
(+) sign next to the chapter you 
want to use to display its 
subsections or questions. If 
there are subsections, click the 
plus (+) sign next to a subsection 
title to display its questions. 

  

http://www.tamarack-software.com/webhelp/webhelp764t/MenusTbars/workarea.htm
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3.  Choose a Test Type 

The right side of the TestGen® program window shows a Startup pane from which you can select the type of 
test you want. For this demonstration, click the button next to Paper Test. A test editing window will open on 
the right side of the screen. 
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4. Choose and Transfer Questions to the Test 

There are many ways to transfer questions from a test bank to a test. You can use drag-and-drop to move a 
question from the test bank to a test, but you may also want to try the methods described below for choosing 
and transferring questions: 

 

"Add Selected Item(s)" Button 

With questions displayed in the Test Bank Library, click once on a question that you want to put on your test. 
Its background changes color to show that it is selected. 

Now click the Add Selected Item(s) button at the bottom of the test bank window. A copy of the question 
appears as the first question on your test. 

Transfer Multiple Items 

To select more than one question at a time in the test bank, hold down the [Ctrl] key when you click the 
mouse to select a question. Continue to hold down the [Ctrl] key to click on and select additional questions. 

To make continuous selections, hold down the [Shift] key as you click the first and last question in a series. 

With multiple questions selected, click the Add Selected Item(s) button to transfer the questions to the test. 
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Transfer Multiple Copies of a Question 

If a test bank question has variable text or numbers, you can transfer multiple copies of the question to a test. 
First select a question that contains variables (the variant status indicator shows an inverted, black triangle 
next to the question and the number of variations is greater than 1). Then click the Choose Multiple... button 
at the bottom of the Test bank Library. Enter a number and click the Add to Test button. Multiple copies of the 
question you selected are transferred to the test, each with different numbers or text, depending on the 
assigned variables. 

If you select more than one question containing variables and click the Choose Multiple... button, you get 
multiple copies of all the selected questions when you enter a number and click the Add to Test button. 

 

 

Transfer Questions Randomly 

To have the computer choose questions randomly, select a chapter or section title in the Test bank 
Library. Then click the Choose Multiple... button. Enter the number of questions you want to transfer 
and click the Add to Test button. The number of questions you chose are randomly selected from 
those available for the section you selected. 

You can also select more than one title or heading and choose multiple questions. The number you 
enter after clicking the Choose Multiple... button determines the number of questions that are 
randomly chosen from each title or heading you have selected. 

http://www.tamarack-software.com/webhelp/webhelp764t/TBLib/tbddopt.htm
http://www.tamarack-software.com/webhelp/webhelp764t/TBLib/tbddopt.htm
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5.  Add Your Own Questions 

To add a question of your own to the test, click 
the Resource Library tab on the left side of the 
screen. Click the plus (+) sign next to Question 
Templates to see the list of question types. 
Select the question type you want to put on the 
test and drag it onto the test. In the test editing 
window, click in the question field and type your 
question, replacing any default text that might 
appear. For a multiple-choice question, click and 
type in each of the answer choices. Select the 
correct answer choice by clicking just to the left of the answer choice letter so the background of the answer 
choice changes color. Click the checkmark (Mark/Unmark as correct answer) on the Standard toolbar to mark 
the choice as the correct answer.  

Other question types can be added and edited in a similar manner. 

6.  Modify Test Header and Layout 

Double-click the test heading at the top of the test window to open the Header and Footer Editor where you 
can modify or add text. When you are done, click the Save button, and then close the Header and Footer 
Editor. Your new header appears at the top of the test. 

 

7. Save the Test 

There are many other ways to modify your test, and these are explained in the Help sections Adjusting Test 
Page Layout, Working with Questions, and Editing Test Content.  When you are finished with the test, select 
Save from the File menu. Give the test a name and click Save to save the test. 

 

8.  Print the Test 

To print the test, 
select Print from 
the File menu and 
enter "1" for the 
number of versions. 
Be sure Print 
Answer Key is 
checked before you 
click OK. When the 
print dialog appears, 
set the print or page 
range to All and 
click OK. 

 

http://www.tamarack-software.com/webhelp/webhelp764t/MenusTbars/workarea.htm
http://www.tamarack-software.com/webhelp/webhelp764t/ResourceLib/qtemp.htm
http://www.tamarack-software.com/webhelp/webhelp764t/ResourceLib/qtemp.htm
http://www.tamarack-software.com/webhelp/webhelp764t/EditTests/addnewq.htm
http://www.tamarack-software.com/webhelp/webhelp764t/EditTests/modifyq.htm
http://www.tamarack-software.com/webhelp/webhelp764t/AdjLayout/pghdr.htm
http://www.tamarack-software.com/webhelp/webhelp764t/tg7help.htm
http://www.tamarack-software.com/webhelp/webhelp764t/tg7help.htm
http://www.tamarack-software.com/webhelp/webhelp764t/PrintExport/tstprint.htm
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Use the TestGen® Wizard when you want to make a quick quiz by choosing questions randomly from one or 
more chapters or pick questions quickly from an abbreviated question list. To start the TestGen® Wizard, 
select a test bank in the Test Bank Library, then click the TestGen® Wizard icon on the Startup pane. Enter a 
name for your test and then click OK to proceed to the next step. 

 

Picking Chapters or Sections 

After you name the test, select the chapters or sections you want to use for the test. 

 

After you choose chapters or sections for your test, you choose whether to pick questions randomly or from a 
list. 
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Choosing Randomly 

To can choose questions randomly 
by question type, chapter/section, 
topic, objective, or other 
categories that appear on the 
drop-down list. The items available 
on the list vary by test bank, since 
not all categories are used in all 
test banks. 

 

Type numbers in the right-hand 
column to indicate how many of 
each type you want from the 
number of questions available. 
Click OK to continue to the test 
summary. 

 

 

 

Choosing from a List 

If you choose to select questions 
from a list instead of randomly, 
you work from a scrolling list of 
questions from the selected 
chapters or sections. Along with 
the question type, you see the 
question type, the question ID, 
and the first portion of the 
question. 

Select questions by holding down 
the [Shift] key (to make 
consecutive selections) or the 
[Ctrl] key (to make scattered 
selections) and clicking each item 
you want to put on the test. Click 
OK to continue to the test 
summary. 

  

Note: Matching items are not included in random selections. Also, the scrambled order produced by a 
random selection might not be suitable for test bank questions that rely on a fixed order. 
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The test summary window shows the 
test name, chapters or sections 
selected, selection method, and total 
number of questions selected. Click 
Finish to build the test. The TestGen® 
Wizard window closes and the test 
window opens with your selected 
questions. In the test window, you can 
modify the test as needed by editing or 
adding questions, rearranging 
questions, or changing the test layout. 
Finish by saving and/or printing the 
test. 

To see a summary of a test's contents, 
click anywhere on an open test to 
make it the active window and then 
select Summary Information from the 
View menu or click the Test 
Information icon on the Standard toolbar. A dialog opens, showing the total number of questions on the test. 

Use the drop-down menu to change the display and show details for the number of questions per question 
type, topic or other descriptor (when available), or static vs. algorithmic. 

You can apply a filter to a test bank to locate questions that meet your criteria. For example, you might want 
to view only multiple-choice questions or only those questions that have a difficulty level of 2. 

Please note the following rules for 
applying a filter to a test bank: 

o You can specify a filter for one 
test bank at a time. 

o Each test bank can have its own 
filter. 

o A filter is for the current session 
only—when you quit the 
TestGen® application and return 
later, the full test bank is 
displayed. 

To apply a filter, first select a test 
bank in the Test bank Library. Then 
select "Filter Test bank Content" 
from the Tools menu to display the Test bank Search Criteria dialog. 
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Setting up the Filter Criteria 

In the Test bank Search Criteria dialog, change the settings for any category in the first column by choosing 
from the drop-down menus in columns two and three. The combination of all the settings defines the set of 
questions you will see when you click the radio button for Show Only Questions That Meet Criteria Above 
and click OK. The program searches the test bank for questions that meet the specified criteria and displays a 
message to let you know how many questions were found. 

 

 

Locating Found Questions (Question View) 

When you filter a test bank that is in Question view, only those questions that meet your criteria are 
displayed. Located questions do not renumber, so the display could show, for example, items numbered 1, 3, 
6, 7, and 10, if those are the only questions that meet the filter criteria. A dimmed chapter or section heading 
indicates that none of the questions in the entire chapter or section meet the criteria. 

Locating Found Questions (ID View) 

When you filter a test bank that is in ID view, the IDs for the questions that meet your criteria are displayed in 
the normal color, while other IDs are a dimmed. Once you locate a question or group of questions that meet 
the criteria, you can switch to Question view to see the question content. 

The headings for chapters and sections that contain questions that meet the criteria remain the normal color, 
and you can use the plus (+) and minus (-) signs to expand and close up these sections to locate the questions. 
A dimmed chapter or section heading indicates that none of the questions in the entire chapter or section 
meet the criteria. 

Show All Questions 

To display all the test bank questions again after applying a filter, select Filter Test bank Content from the 
Tools menu. In the Test bank Search Criteria dialog, click the radio button for Show All Questions and then 
click OK. 

 

Note: Since not all categories apply to all test banks, the drop-down menus for some of the 
categories may be inactive for the test bank you have selected. 

 

http://www.tamarack-software.com/webhelp/webhelp764t/TBLib/swview.htm
http://www.tamarack-software.com/webhelp/webhelp764t/TBLib/swview.htm
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It is easy to make changes to questions and answers on TestGen® tests that you create simply by clicking and 
typing on the test page. Some parts of tests have separate editing windows, and some items are for display 
only. 

Note: For security purposes, some pre-made tests have locked questions that cannot be edited. Refer to the 
section on Deleting Questions from Tests for more information. 

Areas with Direct Editing 

For the tests you create, you can edit any of the following items by clicking directly on them to put a cursor in 
the editing field: 

o questions 

o answers (short answer, essay, matching, and vocabulary questions) 

o answer choices (multiple choice and bimodal questions) 

o instructions, notes, comments, explanations 

Clicking on an editable field activates the field 
by placing a flashing cursor in it, and a light gray 
border appears around the question, answer, 
answer choice, or instruction. Edit or type new 
text as desired. A multiple-choice example is 
shown here. 

 

You can also modify questions and answers for short answer, essay and vocabulary questions directly on the 
test page, but you may need to display the answer field, which by default is turned off on the test page. To 
display the answer field on a test page, select Preferences > Test Options from the Tools menu and click the 
Descriptors tab. Check the box for Correct Answer and click OK. 

 

If you need to see characters such as paragraph marks, tabs, and spaces, in the text editing fields, select 
Invisible Characters from the View menu. 

Test items that contain variables highlight the variables with a colored background when you click in any 
question or answer field that contains them. 

 

http://www.tamarack-software.com/webhelp/webhelp764t/EditTests/deleteq.htm#Locked_Questions
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Be careful when editing near these highlighted variables, since deleting one can affect the calculations in other 
parts of the question or answer(s) in the test item, causing it to become incorrect or invalid. 

In addition to editing text, you can 

o add, edit, or remove math expressions and symbols, 

o insert, replace, or remove graphics, 

o add, edit, or remove tables. 

 

In addition to using questions transferred from a test bank, you can add your own questions to tests by either 
of these methods: 

o Drag one of the question templates from the Resource Library onto your test. More details about 
question templates are in the section Using Resource Library Templates. 

o Select a question on your test (its background changes color), and then select Question from the Insert 
menu. Choose a question type from the submenu to insert the new question template below the 
selected question on your test. 

Entering Questions 

Question types include: multiple-choice, true/false, short answer, essay, vocabulary, bimodal, and matching. 
When you insert a question template onto your test, click in the question field to type your question and 
replace any placeholder text that appears. The question field expands as you type. Use the Text Formatting 
and Equation Editing toolbars as needed to enter questions. 

Entering Answers 

The method for indicating the correct answer for a question varies by question type: 

Multiple Choice 

Fill in the four answer choices by clicking in each field and typing. You can add additional answer choices for 
multiple-choice and bimodal questions by dragging a Blank Answer Choice from the Resource Library into the 
answer choice list for a question. Rearrange the order of choices, if necessary, by dragging and dropping. If 
you need to delete an answer choice, select it so its background changes color, and then press the Delete key. 

To mark an answer choice as the correct answer, select the answer choice so its background changes color. 
Then right-click the answer choice and select Mark/Unmark as Correct from the pop-up menu. You can also 
choose Mark or Unmark as Correct Answer from the Question menu. 

Short Answer, Essay, and Vocabulary 

To fill in the answer for the question, the Answer field needs to be showing below the question. If it is not, 
select Preferences > Test Options from the Tools menu and click the Descriptors tab. Check the box next to 
Correct Answer and click OK. Below the question, click just to the right of the word "Answer:" to place the 
cursor and begin typing. The answer field expands as you type. 

  

http://www.tamarack-software.com/webhelp/webhelp764t/MenusTbars/express.htm
http://www.tamarack-software.com/webhelp/webhelp764t/AdvEdit/graphlib.htm
http://www.tamarack-software.com/webhelp/webhelp764t/AdvEdit/tables.htm
http://www.tamarack-software.com/webhelp/webhelp764t/ResourceLib/qtemp.htm
http://www.tamarack-software.com/webhelp/webhelp764t/MenusTbars/format.htm
http://www.tamarack-software.com/webhelp/webhelp764t/MenusTbars/express.htm
http://www.tamarack-software.com/webhelp/webhelp764t/ResourceLib/qtemp.htm
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Answer Blanks for Short Answers 

When you want a short answer question to have longer or multiple answer lines for students to answer 
lettered parts of the question, select Change Answer Blank from the Question menu. A dialog opens 
for you to select the answer blank width and the number of answer blanks. If you want the answer 
blanks to be labeled with lowercase letters: a., b., and so on, check the box next to Show Labels. 

 

 

 

True/False 

To mark True or False as the correct answer for the question, the answer choices need to be showing below 
the question. If they are not, select Preferences > Test Options from the Tools menu and click the Descriptors 
tab. Check the box next to Correct Answer and click OK. Below the true/false question, select either True or 
False so its background changes color. Then right-click the answer choice and select Mark/Unmark as Correct 
from the pop-up menu. You can also choose Mark or Unmark as Correct Answer from the Question menu. 

Bimodal 

Bimodal questions look like multiple-choice questions in the Resource Library, but they can also function as 
short answer questions if the answer choices are hidden. You control whether bimodal questions are 
displayed as multiple-choice or as short answer by setting a preference on the Questions tab of the Test 
Options dialog. 

If your preference is to display bimodal questions as multiple choice, then fill in the question and answer 
choices on the test as you would for a multiple choice question, as described above. If the preference is set to 
show bimodal questions as short answer questions, then fill in the question and answer as you would for a 
short answer question as described above. 

Matching 

Matching items include a numbered question field and a lettered answer field for you to complete. Groups of 
matching questions on tests are dynamic, meaning that as you add matching items to a matching group, the 
answer choices in column 2, the right-hand column, automatically and randomly rearrange themselves so that, 
in most cases, correct answers are not directly across from the questions they match. 

Location of Answer Choices 

For the first matching question you add to a matching group, the answer is directly across from the 
question. Answer choices 
rearrange themselves with 
each new matching item you 
add to the group. As you add 
additional matching questions 
to the same group, the 
matching choice for question 
4, for example, might appear 
in position B. Fill in the 
question and the matching 
answer in the vacant positions. 

Note: The option to show answer blanks must be selected on the Questions tab of the Test 
Options dialog in order for answer blanks to appear on the test. 

 

http://www.tamarack-software.com/webhelp/webhelp764t/AdjLayout/qdopt.htm
http://www.tamarack-software.com/webhelp/webhelp764t/AdjLayout/qdopt.htm
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For additional help topics, please refer to the TestGen® Help menu. 

Also, any hyperlinks within this guide will lead to a detailed explanation in the TestGen® Help tool. 

 

 

http://www.tamarack-software.com/webhelp/webhelp764t/tg7help.htm

