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 Uses of Multimedia 19

 Many commercial organisations are exploring the Internet and intranet as a delivery channel for mul-
timedia information and services, and are offering multimedia services on the World Wide Web (WWW). 
Electronic commerce (called  e-commerce) via multimedia information systems on the Internet has become 
a reality. For example, see Amazon.com (www.amazon.com). Apple computer’s virtual music store iTunes 
has already become a phenomenon due to iPods, its MP3 music player. 
 Future multimedia technologies include many innovative systems. For example, technologies like 
interactive television in which the television will become a two-way communication device by adding 
a ‘set-top-box’. This will allow the telecaster to build direct links to clients. Potential customers can be 
contacted by via a TV, which will, in fact, be a computer. The possibilities are fascinating.

2.4 APPLICATION EXAMPLES

The real impact of multimedia is achieved when the application goes beyond textual display and ef-
fectively integrates sound, animation and graphics. For example, animation can clearly demonstrate the 
workings of the human heart and circulatory system. Similarly, sound gives the user an opportunity to 
hear the musical works of famous composers. In these examples, animation and sound surpass the ca-
pabilities of the written word.
 A wide variety of applications are constantly being developed, utilising the evolving multimedia tech-
nologies. To give you an idea about the diversity, Fig. 2.1 lists some of the important applications under 
eight major  elds. However, by no means is the list exhaustive. Similarly, it is impossible to describe 
all types of application within the limited space of a book. Therefore, we will brie  y describe a few 
important classes of multimedia applications in this section.

 Fig. 2.1 Map of multimedia applications

Each chapter begins with learning objectives and 
an overview.  
Objectives provide a concise statement of 
expected learning outcomes. Overview gives 
a brief summary of the concepts discussed and 
their relevance.

DEFINE

To support concept building, each chapter 
has been neatly divided into sections and 
sub-sections so that the subject matter 
is studied in a logical progression of ideas 
and concepts.
Concept building is strengthened by 
describing Applications and elaborating 
Principles and Methods.

ELABORATE

8
CHAPTER

DIGITAL AUDIO

After reading this chapter and completing the learning activities for it, 
you should be able to:

 Describe advantages of representing sound in digital form.
 Elaborate the process of producing digital audio.
 Describe the principle of psychoacoustics and its applications.
 Describe different formats of audio fi les.
 Demonstrate and describe the basic audio recording and editing process.

8.1 OVERVIEW

In the previous three chapters of this book (Chapters 5, 6 and 7) we discussed text, pictures and graphics. 
These are the media for two of our principal channels of communication in the visual mode. Although, 
text and graphics are the predominant modes of human-computer communication, the media through 
which human—human communication started was audio. Drawings and pictures were the main vehicles 
of human communication before written languages. But even earlier, it was sound through which we 
started to communicate naturally. Sound is an auditory impression produced by sensations perceived 
by our ears. We are constantly immersed in the world of sound in the form of speech, music and other 
naturally produced sounds (including noise). 
 It is obvious, therefore, why audio is an important component of multimedia. It is a crucial element 
for the entertainment industry. Sounds are used to enhance multimedia games through background music 
and sound effects. Sounds can be combined with other multimedia components to create moods, enhance 
understanding, and reinforce concepts. The scopes of digital audio applications are many. Some major 
application areas are: computer generated sound, sound storage and processing, digital communications, 
answering service, speech synthesis, speech recognition, computerised call centre, and presentation of 
data as sound. If nothing else, sound can enable programs to have a more user friendly interface, with 
the ability to have a person talk to the user helping them to use a program. Basically, the study of digital 
audio involves the processes of generation, propagation, ampli  cation and transformation, all of which 
lead to the understanding of information (Fig. 8.1). This chapter will provide the foundation concepts 
and theoretical background for the representation, storage and processing of digital audio for use in 
multimedia applications.

OBJECTIVES
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4.5.4 Discrete Cosine Transform 
The Discrete Cosine Transform (DCT) is a key mathematical transformation method for powerful graphics and image compression. Therefore, it is discussed in detail here. DCT falls in the class of mathematical operations that include well-known  Fourier transform and  Fast Fourier transform (FFT). The basic op-eration performed by such mathematical functions is to transform the data into a frequency domain. For example, when we take a set of samples from an incoming audio signal we end up with a representation of the signal in the time domain. This is also called the process of digitising the audio. This gives a col-lection of data representing the input signal at each point of time. The FFT transforms this set of sample points into a set of frequency values that describes exactly the same signal. Thus it becomes a frequency domain representation of the signal. 

 The discrete cosine transform (DCT) represents an image as a sum of sinusoids of varying magni-tudes and frequencies. For a typical image, most of the visually signi  cant information about the image is concentrated in just a few coef  cients of the DCT. For this reason, the DCT is often used in image compression applications for example, in the international standard image and video compression schemes known as JPEG and MPEG (Joint Photographic Experts Group and Motion Picture Expert Group – the names of the ISO working group that developed the standard.). The DCT formula is given below.
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where Amn is the brightness of the pixel at position [m,n]. The result is Bpq is the DCT coef  cient in row p and column q of the DCT matrix (usually 8  8). The values Bpq are called the DCT coef  cients of Amn.
 Applying DCT to a whole image is computationally expensive even with today’s powerful proces-sors. Therefore, an image is divided into 8  8 pixel blocks and the pixel values are coded by the DCT method. To explain this, consider an enlargement of an 8  8 area of a grey scale frame as shown in Fig. 4.6a. The brightness values of the 64 pixels are shown in the matrix Fig. 4.6b. The normal way is to determine the brightness of each of the 64 pixels and to scale them to some limits. The DCT is designed to work on pixel values ranging from -128 to 127, the original block is “leveled off” by subtracting 128 from each entry. This requires 64 bytes of storage. By applying DCT on this block, the resulting array becomes as shown in Fig. 4.6c. They represent the amplitudes of the two-dimensional spatial frequency components of the 64-pixel blocks, and are referred to as DCT coef- cients. 

 After DCT almost all values beco l
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Since the 2D DCT can be computed by applying 1D transforms separately to the rows and then the 
columns, we can say that the 2D DCT is separable in the two dimensions. We can use the following
equation to get the basis matrix:

C = k *cos ((2m + 1) np / 2N)where 

k = ( / )1 N (1/N) if n = 0
k = ( / )2 N  otherwise

m, n = 0, 1,  2, . . . (N − 1).Thus, a two dimensional DCT is defi ned as:  Y = C*X*CWhere X is an N N image block (represent the pixels of a given image, Amn), Y contains the computed 
N N DCT coeffi cients (represent the frequency domain coeffi cients, Bpq), C is an N N matrix and 
C  is the transpose of matrix C. Here, matrix X is fi rst multiplied on the left by the basis matrix C. This 
transforms the rows. The columns are then transformed by multiplying on the right by the transpose of the 
C. This block matrix now consists of N2 DCT coeffi cients. The top-left coeffi cient correlates to the low 
frequencies of the original image block. As we move away from this in all directions, the DCT coeffi cients 
correlate to higher and higher frequencies of the image block. It is important to note that the human eye 

 Fig. 4.7 Each 8  8 pixel block is correlated with 64 DCT basis functions. The result from each correla-
tion produces an output coefficient.

is most sensitive to low frequencies, and results from the quantization step will refl ect this fact
 A set of basis functions for a known input array i (8 8i l



Adequate features are provided to contextualise concept building and help in understanding by 
experimentation. These include: implementations, worked examples, exploration and step-by-step 
instructions. Total 45 worked examples of implementations are provided in the book. 
Step-by-step instructions are provided to guide the students in developing experimental applications. 
Latest technologies, trends and research directions are also provided in appropriate sections.

EXTEND
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 7. Select frame 12 of the “Text Graphics” layer and press F6. Remember that this creates a keyframe 

as a copy of the last keyframe. Next, select Insert>Timeline>Creat motion tween. The frames on 

the “Text Graphics” layer should now become blue.

 8. Place the playhead on the last frame of the timeline (frame 12, a keyframe). With the Selection tool, 

click and hold the “Text Graphics” instance and drag it on top of the circle instance. See Fig. 10.6 

for a screenshot of the resulting action.

 Fig. 10.6 Screenshot of Flash development work space with objects in layers and tween animation applied 

as described in step 8 above

 9. Run the playhead by pressing Enter key, and watch the two objects converge with one another as 

the playhead runs through the timeline.

 10. Now, make a modi  cation to the instance of the “Text Graphics” instance in the  rst frame to dem-

onstrate tweening transparency. Click on the  rst frame of the “Text Graphics” layer. Click on the 

text instance in that frame. Next, open the Properties panel if not already opened. Select Alpha in 

the Color property dropdown box and set its value to 10%. Run the playhead again and see how 

the alpha property is tweened to produce a fade in effect as it moves to converge with the circle. 

However, the .swf movie continuously runs in a loop and keeps repeating the scene. We want to 

stop this continuous looping. For this purpose we have to include some command (ActionScript)

to control the playback.

 11. ActionScript can be placed in frames in the timeline. When the playhead reaches a frame with 

ActionScript, Flash implements the commands in those frames. To add ActionScript, we must 

place add a layer to hold the ActionScript. Insert a new layer by selecting Insert>Timeline>Layer. 

Though it does not make any difference visually, it is conventional to place the layer containing 

ActionScript on top. Drag it as the top layer, if it has not already.

 12. Name the layer “actions”. Select the last frame of the actions layer and press F6 to create a new 

keyframe. Select Window>Actions and type in, “stop();”. Compile the document to a .swf by 
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 The characteristics of LCD display are small size with high resolution, low power consumption com-

pared to CRT and an ability to show static images for longer time without burn-in. This makes them 

suitable for handheld outdoor applications and for personal computers, mobile phones, calculators, etc. 

LCD technologies have freed the personal computer from the desktop. It allowed the development of 

head-mounted displays bringing in wearable computer technology. LCD displays are commonplace today 

in many portable devices for its low power and robust display. For home entertainment systems LCD’s fall 

short in screen size, colour accuracy, contrast, peak brightness performance and motion clarity. However, 

these are improving. Today LCD displays are available at sizes as large as 37 inches and 42 inches with 

viewing angles of about 40 o to 70 o.OLED
In nature, there are many examples of luminescence effects. The most well-known is the  re  y which can 

switch its light on and off.

 First scienti  c report on the Electro luminance in organic materials appeared in 1953. However, effort in 

using the property for display began only in 1987 when it was discovered that conjugated polymers such as 

Poly p-phenylen-vinylen (PPV) are suitable for use as organic light emitting diodes (OLED). Some natural 

polymers have semiconductor properties and thus are suitable for the transport of electrical charges. Such 

conjugated polymers can be manufactured arti  cially and exactly speci  ed. 

 Organic light emitting diode (OLED) technology uses organic substances that emit red, green, blue or 

white light. Each pixel illuminates like a light bulb and they can be turned on and off as fast as any light 

bulb. Their independent action produces clear full-motion videos that are easy to see at a viewing angle of 

165°. Unlike traditional LCDs, OLEDs are self-luminous. Thus they do not require backlighting, diffusers 

or polarisers. This produces a thinner (200 nanometers), compact and  exible display. Their low power 

consumption and minimum interference with electronic devices is a positive advantage.

 Essentially, the OLED consists of two charged electrodes sandwiched on top of an organic light emitting 

material. A conductive, transparent anode material such as indium-tin-oxide (ITO) is  rst deposited on a 

transparent substrate. Next, the organic layers are added. Lastly, a re  ective metal cathode of magnesium-

silver alloy or lithium-aluminium completes the structure. When voltage is applied, energy passes from 

the negatively charged cathode layer to the anode layer. This stimulates organic material between the two, 

which emits light visible through an outermost layer of glass. Doping or enhancing organic material helps 

control the brightness and colour of light. OLEDs exhibit contrast ratios and brightness levels comparable 

to CRT display technologies.

 Because of their small size and relatively high ef  ciency, OLEDs are ideally suited for use in  at-panel 

displays. They have almost instantaneous update speed. Several companies have recently demonstrated 

highly  exible display panels fabricated on plastic substrates. Displays can be produced by printing onto 

a  exible plastic in the same way as using an ink jet printer. This makes its manufacturing simple, allow-

ing very cheap mass production. Moreover, it gives displays that can be rolled-on. Such  exible low-cost 

displays will open avenues for new innovative multimedia applications and products, from displays that 

roll up to ones that are woven onto clothing.

3.4.3 PDPPlasma display panel monitors are fi xed pixel type displays. The operating principle of PDP is based on 

the utilisation of light emission when phosphor is activated by ultraviolet light from gas-emission. Each 

plasma display consists of a matrix of millions of hollow cells fi lled with neon and xenon gases that are 

sandwiched by two parallel sheets of glass. When electricity is passed through the cells, electrons are 



A review, at the end of each chapter, gives the 
essence of the topics covered and will be helpful 
for a quick summary.
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Ample illustrations (123 figures and 28 
tables) are used in the book to explain the 
complex concepts, functional relationships, 
and provide sketches for algorithmic models. 
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between adjacent pictures. These are shown in Fig. 9.5(ii). Illusion of motion is created by this small 
difference between the frames, coupled with our persistence of vision. Figure 9.5(ii) shows that it is pos-
sible to create the second and third frame simply by transmitting the differences. The second frame can 
be constructed from the  rst frame by adding only the extra objects. Similarly, the third frame can also 
be constructed from the  rst frame. In both cases, the data load for the subsequent frames in Fig. 9.5(i) 
is greatly reduced.
 At the cost of higher complexity, the result of applying MPEG video compression is that the amount 
of data transmitted across the network is less than that of Motion JPEG. This is illustrated in Fig. 9.4(ii) 
where only information about the differences in the second and third frames is transmitted along with 
the key frame data.
 MPEG is in fact far more complex than that indicated above. Parameters such as prediction of motion 
in a scene and identifying objects are additional techniques or tools used within MPEG. Also, differ-
ent applications can make use of different tools, for example: a real-time surveillance application or an 
animated movie. 

 Fig. 9.5 Simple illustration of MPEG compression. (i) If shown in quick succession the sequence of 
three images will produce animation of boiling water in a beaker. (ii) Same image information 
transferred by the ‘I’ frame (key frame) and the difference information between ‘I’ and the next 
frames (B frames). Intra frame redundancies are removed

 Fig. 4.4 LZW compression explained diagrammatically

 Originally, the size of the string AAABAABBB is 9  8 bits (size of ASCII) = 72 bits. 
 For the compressed string, if we de  ne the code size as 4 bits, the size of the compressed string 0 2 
1 3 1 1 will be 6  4 bits = 24 bits. Thus with this simple method, we can achieve a compression ratio 
of 3:1.
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 Fig. 4.10 Block Diagram of a Hybrid Compression Scheme

4.6 REVIEW

In this chapter we covered some of the basic techniques of data compression that are relevant for multi-
media. First, we examined the issue of ‘why compression is required’. Then we moved on to understand 
the fundamentals of compression and the possible approaches. There are two broad classes of data com-
pression techniques—lossless and lossy compression. Within each class various methods are available. 
In order to understand the basis of compression we examined some of the techniques and their examples. 
These include lossless—Run length encoding, dictionary based LZW compression, variable length based 
Huffman and Arithmetic Coding; lossy—DCT, Wavelet and DWT transformation. The importance of 
using hybrid compression techniques for remote sensing, medical image processing and integration has 
also been brie  y mentioned.
 The subject of data compression is huge and extremely interesting. By no way we could have discussed 
all of them within the con  nes of this book. Nevertheless, after reading this chapter you will gain a fairly 
good foundation. With the appreciation of the broader framework of multimedia data compression, we 
are now ready to discuss the various multimedia components in the subsequent chapters.

REVIEW QUESTIONS

 1. Why data compression is needed for multimedia components like video and audio, images and 
texts?

compression techniques including DCT and DWT transforms, for different partitions as well as at dif-
ferent levels of encoding and decoding can be incorporated.



Each chapter contains a set of problems to practice in laboratory, totalling to 37 tutorial assign-
ments in the book. These will complement learning through hands-on lab experiments and problem 
solving.
Solution to the tutorials requires not only application of the material covered in the book but also 
enables the student to strive towards good comprehension of the subject matter. Answers, steps or 
hints have been provided for all the problem sets as appropriate.

EXPERIMENT
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Current Information on Wavelet techniques are available at: http://www.wavelet.org/

TUTORIAL ASSIGNMENTS

 Assignment 4.1: Information analysis
 Assignment 4.2: Run length encoding
 Assignment 4.3: LZW encoding
 Assignment 4.4: Arithmetic encoding
 Assignment 4.5: DCT Matrix

Assignment 4.1 Information Analysis
Task Calculate entropy of an information source
Theoretical Background See Chapter 1 and Chapter 4, Section 4.3

MATLAB Code:
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function modifyCircleInstance(event:Event):void{
if (!(myCircleInstance.alpha > max_val)){
myCircleInstance.alpha += increment_interval ;
}else{
myCircleInstance.alpha = original_val;
}
}
this.addEventListener(Event.ENTER_FRAME, modifyCircleInstance);

10.7.3 ActionScript for a Drag and Drop Application

ActionScript provides more than just movement and animation. Interaction is also programmable with 
ActionScript. Let us see how this can be done.
 In the previous example, we applied ActionScript by putting it in the timeline. However, to manage 
code complexity, it can be handy to create ActionScript classes outside of the main application timeline, 
and link objects to these ActionScript classes. In this manner, behaviour can be linked to any object that 
de  nes itself as belonging to the behaviours of its Base class (Flash 9 and above). This is useful if you 
would like to de  ne a behaviour that you would like multiple objects to be able to invoke. In the next 
example, we will create a drag and drop example, which will contain objects that will lock themselves 
to the circle instance on the stage, if they are dragged and dropped on it.
 1. Open the  le “BasicShape”, if it is not already opened. Select File>Save as, and rename the  le 

“DragDrop”. 
 2. Now, we will create an ActionScript Class  le to de  ne the behaviours of all objects that uses the 

class as their Base Class. Select Flash>New. Select the New Document you want to create as an 
ActionScript File. Select File>Save, and save it under the  lename “DragDropLatcher” in the same 
directory as the main current application “DragDrop”.

 3. Enter the following ActionScript codes:
package { 
import flash.display.*; 
import flash.events.*; 

public class DragDropLatcher extends MovieClip 
{
 public var testObj:DisplayObject;  
 public function DragDropLatcher( ) 
 { 

 } 
 public function instantiate(displayObj:DisplayObject){ 
  testObj = displayObj; 
  this.addEventListener(MouseEvent.MOUSE_DOWN, dragMe); 
  this.stage.addEventListener(MouseEvent.MOUSE_UP, dropMe); 
 } 
 public function dragMe(event:Event) 
 { 
  this.startDrag(); 
 } 
 public function dropMe(event:Event) 
 { 
  this.stopDrag(); 
  if (this.hitTestObject(testObj)){ 
   this.x = testObj.x + (testObj.width-this.width)/2; 
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Assignment 6.3 Working on Image Files

Task Open a 24 bit bitmap  le and display it. Change the colour map to gray and display it.
Objective To appreciate colour map and gray scale images.
Notes

 Indexed Colour: M×N array with values that index NC×3 colour map array containing the RGB val-
ues. MxN uint8 can represent up to 256 colours from a colour map array of dimension 256×3. M×N
uint16 array can represent up to 65,536 colours from a colour map array of dimension 65,536×3. 
Eight bit gray images are represented by 256 different intensities ranging from zero to 255.

 In the MATLAB program a colour image matrix is changed to average image by adding the pixel 
value of colour planes and then dividing it by the number of colour planes.

MATLAB Code

 Gray scale image from the original colour image



To evaluate learning, each chapter contains Review Questions for the students to respond and refl ect. 
More than 170 review questions in the text are included to hone the problem-solving skills.
In addition, each chapter contains a set of Objective Questions, totalling to 128 multiple choice 
questions in the book. This enables the user to obtain clear comprehension of the subject matter. 

EVALUATE

At the end of each chapter, a comprehensive list of references is provided to support further 
studies.
Relevant web addresses of different multimedia tools and useful websites are also provided. 

REFERENCES

REVIEW QUESTIONS

 1. Have you ever wondered about the Content-Type tag in HTML document? What is the purpose of 
the declarations highlighted in the tags?
<meta http-equiv=”Content-Type” content=”text/html; charset=ISO-8859-1”>
<meta http-equiv=”Content-Type” content=”text/html; charset=UTF-8”>

 2. An email from a friend in Italy appeared on screen like this:  & 
. What could be the reason for such display? 

 3. What is a PDF  le and what are some advantages and disadvantages of using PDF  les for web 
applications?

 4. What are the three main categories of fonts?
 5. Describe ISO646 and ISO8859 and elaborate how these character codes differ from ASCII.
 6. What was the need for de  ning the Unifying Character Codes? How does UCS differ from 

ISO10646?
 7. What do you understand by hypertext and hypermedia? Elaborate with an example for each.
 8. How does text encoding differ from text mark-up?
 9. What are the advantages of digital text? Which compression method will you use for compressing 

a digital text  le?
 10. Describe what is meant by digital library and ebook. Explain their advantages. Also discuss the 

problems they pose and approach to their solution.

MULTIPLE CHOICE QUESTIONS

 1. Indicate which of the following statements are TRUE or FALSE:
 (i) Compression is necessary for Audio data only.
 (ii) No compression is necessary for Textual data.
 (iii) Telephone quality audio demands less storage space compared to CD quality stereo audio.
 (iv) Minimum number of bits required to encode English alphabets is Five.
 (v) Lossy compression is not suitable for still images.
 (vi) RLE fails if repetitions are very few.
 2. Fill in the blanks for the following statements:
 (i) For  icker-free video display, frame rate should be in the range of  frames/sec.
 (ii) Transform method of compression follows  compression  technique.
 (iii) Arithmetic coding adopts  encoding.
 (iv) PDF  les follow  type compression.
 (v) JPEG makes use of  transform.

Select the correct response to the following statements:
 3. For remote communication of an X-Ray image
 (a) Apply Lossless compression technique.
 (b) Apply Lossy compression technique.
 (c) Apply Hybrid compression technique.
 (d) Don’t apply any compression.
 4. For LZW compression, most popular Code size is
 (a) 8-bits
 (b) 10-bits
 (c) 12-bits
 (d) 16-bits

REFERENCES

Graphic Programs

Adobe Illustrator: http://www.adobe.com/prodindex/illustrator/
Macromedia FreeHand: http://www.macromedia.com/software/freehand/
CorelDRAW: http://www.corel.com/products/graphicsandpublishing/draw8/main.htm
Paint Shop Pro: http://www.jasc.com/psp5.html
3D Studio: http://www.ktx.com/3dsmaxr2/
Adobe PhotoShop: http://www.adobe.com/prodindex/photoshop/demodnld.html
GIMP Image Manipulation Program available under GNU liscence http://www.gimp.org
Graphic viewer/converter: LView: a freeware for Windows: http://palmia.org/html/lview.htm.

TUTORIAL ASSIGNMENTS

Assignment 6.1 Pixel inspection of an image
Assignment 6.2 Anatomy of an image
Assignment 6.3 Working on image  les
Assignment 6.4 Inversing an image (creating image negative)
Assignment 6.5 Enlarging an image
Assignment 6.6 JPEG compression steps
Assignment 6.7 Digital watermark

Assignment 6.1 Pixel Inspection of an Image

 Objective To examine an image closely for details.
 Theoretical Background See Section 6.5.
 MATLAB Codes
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