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Pre-Test/Post-Test
Chapter 1

Fill in the Blank:
1. A database is a collection of related _____. 

2. A _____ is the primary object in a database for collecting and storing data. 

3. The _____ bar provides convenient access to commonly used storage locations.

4. A _____ is a question you ask of your database. 

5. Data stored in a table object appears in rows and columns called a _____. 

6. When viewing data, the _____ key sequence moves the cursor to the last record and the last field. 

7. Drag the borderline of a cell's field _____ area to resize its column width.  

8. The _____ key toggles the in-cell Edit mode when editing table data in Datasheet.  

9. To reverse only the last action performed, press the _____ key sequence to perform an Undo. 

10. Any cell containing a/an _____ field is incremented automatically by Access when a new record is entered into the table. 

Multiple Choice:

11. An individual entry in a table is called a:

a. datasheet

b. dynaset

c. field

d. record

12. Which item displays a database’s object?

a. Database window

b. Menu bar

c. Status bar

d. Places bar

13. How many categories of available database objects does the Objects bar organize?

a. five

b. six

c. seven

d. eight

14. The intersection of a row and column in a datasheet is known as:

a. cell

b. field

c. dynaset

d. macro

15. Which keystroke in a datasheet will move you to the first field in a record?

a. End 

b. Ctrl+Up arrow

c. Home

d. none of the above

16. The Record Selector Area contains:

a. field names

b. row selector buttons

c. data values

d. row selector checkboxes

17. Clicking the Print Preview button when viewing a datasheet will show you:

a. how a report based upon the current datasheet will look when printed

b. how a form based upon the current datasheet will look when printed

c. how the current datasheet will look when printed

d. none of the above

18. When an insertion point is positioned in a datasheet’s cell, pressing which button will remove the character to the right of the insertion point?

a. Backspace

b. Delete

c. Ctrl+X

d. Ctrl+Delete

19. A triangle in a row’s selector area tells you that:

a. the record needs to be saved

b. the record is marked for deletion

c. the record is the active record in the datasheet

d. none of the above

20. Instead of choosing the Undo command from the menu, you can undo changes in the current field (of a datasheet) by pressing which key once?

a. Esc

b. Home

c. Alt

d. F6

True / False:

21. A form generally displays one record at a time.  

22. Macros store objects that are used to publish information to the Internet from your database. 

23. The PgDn keystroke in a datasheet will move the cursor down one line (record).  

24. A subdatasheet is used to browse hierarchical and related data for a particular record.  

25. Double-clicking on the borderline between two field header areas will resize the column on the left to its best-fit width.  

26. You can change the page setup to landscape orientation (from portrait) to print more datasheet columns on a page.  

27. If you are editing data in a datasheet and start typing while data is selected, what you type is appended to the selected text.  

28. When editing data in a cell within a datasheet, there is no change to the row’s selector button.  

29. When selecting an entire datasheet cell for editing, the mouse pointer is properly positioned when it changes to a cross.  

30. Access offers a multiple undo capability when editing in a Datasheet.
Pre-Test/Post-Test Answer Key

Fill in the blanks:

1. information (1.1:AC 2)

2. table (1.1:AC 2)

3. Places (1.1.2:AC 5)

4. query (1.1.4:AC 12)

5. datasheet (1.2:AC 15)

6. Ctrl+End (1.2.1:AC 15)

7. header (1.2.2:AC 19)

8. F2 (1.3.1:AC 25)

9. Ctrl+Z (1.3.2:AC 28)

10. AutoNumber (1.3.3:AC 29)

Multiple Choice:

11. D (1.1:AC 2)

12. A (1.1.3:AC 7)

13. C (1.1.4:AC 10)

14. A (1.2:AC 15)

15. C (1.2.1:AC 15)

16. B (1.2.2:AC 19)

17. C (1.2.3:AC 21)

18. B (1.3.1:AC 25)

19. C (1.3.1:AC 25)

20. A (1.3.2:AC 28)

True / False:

21. T(1.1.4:AC 10)

22. F (1.1.4:AC 10)

23. F (1.2.1:AC 15)

24. T (1.2.1:AC 15)

25. T (1.2.2:AC 19)

26. T (1.2.3:AC 21)

27. F (1.3.1:AC 25)

28. F (1.3.1:AC 25)

29. T (1.3.1:AC 25)

30. F (1.3.2:AC 28)

Pre-Test/Post-Test
Chapter 2

Fill in the blanks:

31. One rule of thumb for designing databases is to place _____ percent of your effort into designing a database properly in order to spend the rest of your time maintaining it.

32. Tables can be related to each other by using a _____ field.

33. To create a new database via a menu, choose the _____ menu item from the File menu.

34. When creating a database for you, Access can create a _____, which makes the application’s features easier to access.

35. Access provides the Table Wizard to help you create a table’s _____.

36. A Field _____ pane is used to display and set a field’s characteristics.

37. There are _____ different datatypes in Access, as listed in the textbook.

38. The data type that can store up to 255 characters is known as _____.

39. An _____ data type automatically increments sequentially as each new record is added to a table.

40. Access provides a special tool called the _____ that allows you to preview and print various design characteristics of your database objects.

Multiple Choice:

41. Access can lead you step-by-step in generating a new database using which feature?

a. Database Datasheet

b. Database Dynaset

c. Database Wizard

d. Database AutoGenerate

42. The text mentions which of the following as a source for additional database templates?
a. Microsoft.com

b. Templates.com

c. Other students

d. AdvantageSeries.com (the text’s web site)

43. Each table in your database should contain information about:

a. a single topic

b. a single subject

c. none of the above

d. both a and b

44. The Table Wizard dialog window presents tables of which of the following types?

a. personal

b. internet

c. business

d. all of the above

e. only a and b

f. only a and c 

45. A Field Grid pane is used to:

a. add a field to a table

b. delete a field from a table

c. rename a field in a table

d. all of the above

e. only a and b above

46.  The maximum size of a memo data type is:

a. 255 characters

b. 1,024 characters

c. 65,525 characters

d. 75,000 characters

47. Which type of field uniquely identifies every record in a table?

a. primary key

b. secondary key

c. null value

d. none of the above

48. By defining indices, you can speed up the search operations for:

a. running queries

b. generating reports

c. displaying forms

d. both a and b

e. a, b and c

49. To define an index for a selected field, you edit the field’s characteristics in which of the following?

a. Field Design pane

b. Field Grid pane

c. Field Properties pane

d. Field Indexing pane

50. To delete a field in a table, use the table’s Design View, right-click on the field’s row selector and choose which item from the menu that appears?

a. Remove this

b. Delete Rows

c. Hide Row

d. Cut Row

True / False:

51. Unlike other Microsoft Office 2003 applications, such as Word and Excel, Access allows you to work with only one database at a time.

52. A database wizard will not allow you to select the fields for collecting and storing information, which will be included in a new database.

53. The database wizard contains nine different styles used for screen displays.

54. The Table Wizard permits a user to select fields from existing tables.

55. You can create a new database simply by typing information into a blank datasheet.

56. In order to use the Field Grid and Field Properties pane, you must edit a table in Design View.

57. A OLE data type is used for storing objects, graphics, or other binary data.

58. A memo data type is best used for storing hyperlink addresses (URLs).

59. An index is a special mechanism for dynamically organizing and ordering the data stored in a table.

60. When printing a table’s definition, you can suppress the display of the table’s relationships.

Pre-Test/Post-Test Answer Key

Fill in the blanks:

1. 90 (2.1.1:AC 50)

2. common (2.1.1:AC 50)

3. New (2.1.1:AC 50)

4. switchboard (2.1.3:AC 53)

5. structure (2.2.1:AC 59)

6. Properties (2.3.1:AC 64)

7. 10 (2.3.1:AC 64)

8. text (2.3.1:AC 64)

9. AutoNumber (2.3.2:AC 68)

10. Documenter (2.4.3:AC 76)

Multiple Choice:

11. C (2.1.3:AC 53)

12. A (2.1.3:AC 52)

13. D (2.2:AC 59)

14. F (2.2.1:AC 59)

15. D (2.3.1:AC 64)

16. C (2.3.1:AC 64)

17. A (2.3.2:AC 68)

18. D (2.3.3:AC 69)

19. C (2.3.3:AC 69)

20. B (2.4.1:AC 71)

True / False:

21. T (2.1.2:AC 51)

22. F (2.1.3:AC 53)

23. F (2.1.3:AC 53)

24. T (2.2.1:AC 59)

25. T (2.2.2:AC 62)

26. T (2.3.1:AC 64)

27. T (2.3.1:AC 64)

28. F (2.3.1:AC 64)

29. T (2.3.3:AC 69)

30. T (2.4.3:AC 76)

Pre-Test/Post-Test

Chapter 3

Fill in the blanks:

61. To apply font characteristics to a datasheet, choose the Font menu item from the _____ menu.

62. To apply special visual effects to a datasheet's appearance, choose the _____ menu item from the Format menu.
63. The best way to reorder the fields in a datasheet is to _____ their column headings to their new position.

64. When moving fields in a datasheet, the new position of the field column is indicated by a bold _____ _____.

65. Information is _____ data.

66. Wildcard characters are useful in defining search criteria for filters and _____.

67. To check the spelling of the entries in a datasheet, click the _____ button on the toolbar.

68. A _____ is a technique that limits the display of records in a table.

69. A _____ is a question that you ask of your database.

70. Results of a question to a database are displayed in a _____.

Multiple Choice:

71. Which of the following datasheet characteristics can you modify?

e. font typeface

f. font style

g. font size

h. font's text color

i. all of the above

j. none of the above

72. When clicking in a fields header area (in a datasheet), the mouse pointer becomes:

a. an asterisk

b. a filled rectangle

c. a downward pointing arrow

d. a filled circle

73. To display a field's hidden column in datasheet view, use which of the following dialog boxes?

a. Show Columns

b. Unhide Columns

c. Reveal Columns

d. either a or b

74. Which wildcard character takes the place of a single character?

a. #

b. *

c. $

d. ?

75. Which wildcard character takes the place of a single number?

a. #

b. ?

c. *

d. none of the above

76. Which wildcard character takes the place of a group of characters?

a. ?

b. *

c. #

d. $

77. Which text area of the Find and Replace dialog window holds the entered value of replacement text?

a. Replace With

b. Replacement

c. Replace

d. none of the above

78. Which of the following is not an Access filter for tables?

a. Filter For Input

b. Filter By Selection

c. Filter Including Selection

d. Filter Excluding Selection

79. Which of the following supports the setting of multiple filter criteria?

a. Filter For Input

b. Filter By Selection

c. Filter Excluding Selection

d. Filter Including Selection

e. Filter By Form

80. Which type of query is used to obtain data for display?

a. database

b. update

c. select

d. insert

True / False:

81. The Font dialog box contains a sample area, so that you can preview changes made to text.

82. You can enhance a datasheet's appearance by changing the appearance of the gridlines.

83. The only way to restrict the display of sensitive data in a datasheet is to remove any relevant fields from the datasheet.

84. Records can only be displayed in a datasheet in the order that they were entered.

85. You can search on partial words in Access using the Find command.

86. Access permits you to globally replace a value in the contents of an entire table.

87. There are four methods available to filter records in a table.

88. Filtering records in a table deletes them permanently.

89. The Query Wizard can be used to create complex queries from scratch.

90. The Query Design Grid displays the fields, criteria, and sort specifications for a query.

Pre-Test/Post-Test Answer Key

Fill in the blanks:

1. Format (3.1.1:AC 94)

2. Datasheet (3.1.1:AC 94)

3. drag (3.1.1:AC 94)

4. vertical gridline (3.1.2:AC 97)

5. processed (3.2:AC 104)

6. queries (3.2.3:AC 108)

7. Spelling (3.2.5:AC 111)

8. filter (3.3:AC 113)

9. query (3.4:AC 120)

10. dynaset (3.4.1:AC 121)

Multiple Choice:

11. E (3.1.1:AC 94)

12. C (3.1.2:AC 97)

13. B (3.1.3:AC 99)

14. D (3.2.3:AC 108)

15. A (3.2.3:AC 108)

16. B (3.2.3:AC 108)

17. A (3.2.4:AC 109)

18. C (3.3:AC 113)

19. E (3.3.3:AC 117)

20. C (3.4.1:AC 121)

True / False:

21. T (3.1.1:AC 94)

22. T (3.1.1:AC 94)

23. F (3.1.3:AC 99)

24. F (3.2.1:AC 104)

25. T (3.2.2:AC 106)

26. T (3.2.4:AC 109)

27. T (3.3:AC 113)

28. F (3.3.1:AC 113)

29. F (3.4.2:AC 123)

30. T (3.4.2:AC 123)

Pre-Test/Post-Test

Chapter 4 

Fill in the blanks:

91. The Access feature that is used to focus attention on a single record at a time is a _____.

92. An _____ Wizard provides the fastest and easiest way to create a new form.

93. The Record _____ Area on a form permits the user to create a new record.

94. When editing a field in a form, an icon with a _____ in it appears in the Record Selection Area.

95. A _____ provides a structured display format for presenting a table's data or a query's results.

96. The Report Wizard lets you select options from a series of _____ _____ when constructing a new report.

97. The _____ _____ button permits a user to view more than one page at a time in Print Preview mode.

98. You can export an Access table or Report in _____ format, the standardized language of the Web.

99. A report _____ is stored as a graphic metafile on a disk, containing a static image of each page of an Access report.

100. _____ a database reorganizes and packs the file more closely together.

Multiple Choice:

101. How many form wizards does Access provide access to in creating a new form?

a. 3

b. 4

c. 5

d. 6

102. Which type of form displays data from a record in a single column?

a. Tabular

b. Columnar

c. Datasheet

d. none of the above

103. Which of the following is not a layout available in the Form Wizard?

a. Columnar

b. Tabular

c. Pivot Form

d. Pivot Chart

e. Justified

104. How many types of AutoReport wizards does Access provide?

a. Two

b. Three

c. Four

d. Five

105. Which of the following summary calculations are available in creating an Access Report?

a. Sum

b. Min

c. Max

d. Avg

e. all of the above

106. Double-clicking a report object in the Database window opens the report in:

a. a datasheet

b. a Print Preview window

c. a default form window

d. none of the above

107. Which of the following is not a valid encoding for exported HTML files in Access?

a. Default

b. ANSII

c. Unicode

d. Unicode (UTF-8)

108. How many report wizards does Access provide in creating a new report?

a. two

b. three

c. four

d. five

109. Which key toggles Edit mode when a database object is selected?

a. F2

b. F4

c. F5

d. none of the above

110. Which of the following verifies the reliability of the database objects?

a. Compacting

b. Repairing

c. Converting

d. none of the above

True / False:

111. The New Object button allows a user to create a new Table.

112. The Tabular and Datasheet layouts are best used to display numerous records in a form at one time.

113. You can use the Ctrl+End keystroke to move to the last field of the current record in a form.

114. An Access form does not contain a record selection area.

115. A user can Print Preview a form in Access.

116. A columnar report is generally described as “a much nicer-looking report.”
117. Reports permit the grouping of data presented in them.

118. A query in Access can be print previewed.

119. The Label Wizard can only create labels for floppy diskettes.

120. The Label Wizard only permits the values of fields to appear on labels, not additional text (such as punctuation marks).

Pre-Test/Post-Test Answer Keys

Fill in the blanks:

1. form (4.1:AC 142)

2. AutoForm (4.1.1:AC 142)

3. Navigation (4.1.3:AC 149)

4. pencil (4.1.4:AC 151)

5. report (4.2:AC 154)

6. dialog boxes (4.2.2:AC 157)

7. Multiple Pages (4.2.3:AC 161)

8. HTML (4.2.4:AC 164)

9. snapshot (4.2.4:AC 164)

10. Compacting (4.4.2:AC 175)

Multiple Choice:

11. C (4.1.1:AC 142)

12. B (4.1.1:AC 142)

13. C (4.1.2:AC 146)

14. A (4.2.1:AC 155)

15. E (4.2.2:AC 157)

16. B (4.2.3:AC 161)

17. B (4.2.4:AC 164)

18. C (4.3.1:AC 168)

19. A (4.4.1:AC 172)

20. B (4.4.2:AC 175)

True / False:

21. T (4.1.1:AC 142)

22. T (4.1.2:AC 146)

23. F (4.1.3:AC 149)

24. F (4.1.3:AC 149)

25. T (4.1.4:AC 151)

26. F (4.2.1:AC 155)

27. T (4.2.2:AC 157)

28. T (4.2.3:AC 161)

29. F (4.3.1:AC 168)

30. F (4.3.1:AC 168)
Resource II:

Teaching Materials

Chapter 1: Working with Access

Overview

Chapter 1 introduces the concept of a database, starting the students along the path of working with the database to store related data.  Fundamental concepts are covered, including starting the Access database application, as well as opening, exploring, and closing an existing database.  Coverage is also given to basic manipulation of table datasheets, data navigation, and simple record management.

Teaching Tips and Strategy

Chapter 1 relies on the use of table datasheets to show the data stored in the database.  Consider explaining that while the datasheet is used to access, edit, and delete the data, the students are really manipulating data that is stored in tables and that the datasheet is merely a presentation of data from a table.


Another point to consider stressing is that while the datasheets presented at first are representations of data from a single table or query, the representations can grow (later chapters) to be more complex, drawing on data from multiple tables.  In other words, let them know that this is the tip of the iceberg in terms of database use.

Lecture Notes
Section 1.1 – Getting Started with Access

Section 1.1 guides the student through the basics of starting Access beginning from the Windows Start button.  The section continues with opening an existing database, familiarizing students with the basic interface components with which users will be working.  The section concludes by briefly introducing a table’s datasheet, the results of a query, a form, and a report.

Section 1.1.1 – Loading and Exiting Access
Concept:
Starting Access from the desktop screen
Method:
Click the Windows Start button and choose the Microsoft Access menu item from the Programs menu.

Notes:
None
Concept:
Exiting Access

Method:
Choose the Exit menu item from the File menu or click the Close button in the top-right hand corner of the Access application window.

Notes:
None
Section 1.1.2 – Opening a Database File at Startup
Concept:
Opening/launching an existing database in Access

Method:
Choose one of the following methods to display the Open dialog window, and then complete the directions that follow.
· Choose the Open menu item from the File menu

· Click the Open button on the toolbar

· Click the More files… link on the New File Task Pane
In the Open dialog window, use the Places bar or the Look in: drop down menu to select the location of the database file. Next, double-click on the desired database file from the file list area.

Notes:
Student data files are available by downloading them from the textbook’s web site: http://www.mhhe.com/cit/advantage2003.com
Section 1.1.3 – Touring Access
Concept:
Getting familiar with Access’ various interface components

Method:
The Access application window acts as a container for the Database window and for displaying database objects.  The most widely used interface components include the Windows icons (minimize, maximize, restore, close), Menu bar, Toolbar, and Status bar.


Access also provides right-click menus for quick access to common menu commands.

Notes:
The macro warning dialog box may display when you open up a database file.  The file should be safe if it is from McGraw-Hill’s download site.
Section 1.1.4 – Working in the Database Window
Concept:
Introduction to the Objects bar

Method:
The Objects bar organizes objects, which comprise the database into the following seven categories:
· Tables
· Queries
· Forms
· Reports
· Pages
· Macros

· Modules


Clicking one of the seven objects in the Objects bar will update the list area to comprise a list of those objects. For example, by clicking on the Reports button in the Objects bar, the list area will be updated to reflect the list of Reports in the current database.


The list area will also contain objects, which are shortcuts for creating new objects of that type. Thus, for our example, there will be a variety of shortcut objects to assist in creating new Report objects.

Notes:
None
Concept:
Accessing the view of a database object
Method:
After displaying a database object (via the Objects bar), double-click on the icon of the object in the list area to display a view of that object.  Each object holds different data in different ways.  For example, double-clicking on Queries will execute the query and return a datasheet (rows and columns of data that match the query).  Displaying a Table will show the datasheet of all data in the selected table.  Viewing a form will show the user-interface that a form generates, complete with data (if applicable). 

Notes:
None
Section 1.2 - Viewing and Printing Your Data
This section expands on the introduction of the datasheet from the previous section by detailing how to use the datasheet to examine the data it displays. Addition coverage is provided for adjusting datasheet column widths and using the Print Preview feature to print a datasheet.
Section 1.2.1 - Moving Around a Datasheet
Concept:
Moving the selection cursor around the cells of a datasheet

Method:
Once a table's datasheet is displayed, you can use any of the following keystrokes to move around the datasheet to examine the data contained within it.

· up or down arrow keys: move to previous or next record (row)

· left or right arrow keys: move to the previous or next field in the current row

· Ctrl+down arrow: moves to the bottom of a field's column

· Ctrl+up arrow: moves to the top of a field's column

· PgUp or PgDn: moves up or down one screen

· Home: moves to the first field in a record (the leftmost cell)

· End: moves to the last field in a record (the rightmost cell)

· Ctrl+Home: moves to the first field (leftmost cell) of the first record (row)

· Ctrl+End: moves to the last field (rightmost cell) of the last record (row)

You can use the First Record button and the Last Record button (located on the bottom of the datasheet's window) to move to the first or last record in the datasheet.

Notes:
You can also use the mouse to click and select a cell, row, or column of data. Additionally, you can use the mouse to drag the datasheet's horizontal and vertical scrollbars (if applicable). Using the mouse to navigate around the datasheet is easier than using the keystrokes.
Concept:
Showing cross-referenced data from another table (using subdatasheets)

Method:
Use the Expand button (located at the start of a record's row, if present) to view cross-referenced data from another table.
Notes:
The notion of cross-referenced (or joined data) may be too daunting for novice database students to grasp. Since this is the first chapter, it might be wise to avoid this discussion until the notion of tables of data is mastered.

Section 1.2.2 - Adjusting Column Widths and Row Heights
Concept:
Changing the default column width in a datasheet
Method:
Use one of the following methods to change the width of a column in a datasheet:

· Use the mouse to drag the column's right borderline to resize the width of the column. You must perform this operation from the columns header area.

· Use the mouse to select a cell in the column you wish to resize.  Next, choose the Column Width menu item from the Format menu. Enter the desired width in the Column Width text area and press the OK button. You can click the Best Fit button to have Access automatically resize the column to accommodate the widest piece of data.

Notes:
If you double-click on a column's right borderline, the column will be resized as in the Best Fit method described above.

Concept:
Changing the default row height in a datasheet

Method:
Use one of the following methods to change the height of a row in a datasheet:

· Use the mouse to drag the bottom border line in the record selection area (leftmost region of the row)

· Choose the Row Height menu item from the Format menu

Notes:
None
Section 1.2.3 - Previewing and Printing
Concept:
Previewing a datasheet prior to printing

Method:
When viewing a datasheet, click the Print Preview button on the toolbar. The datasheet will be displayed in a Print Preview window.

Notes:
You can navigate the pages of the print preview by using the navigation buttons on the bottom of the Print Preview window.  Click the mouse on the displayed pages to zoom in on the display, click the mouse again to zoom back out.

Concept:
Modifying the page setup prior to printing the datasheet

Method:
To modify the page settings of how the datasheet will be printed, use the Page Setup dialog window. To display the window, choose the Page Setup menu item from the File menu.

Notes:
There are many settings to modify in the Page Setup dialog window. The text describes only one at this point—changing the page layout from portrait to landscape mode.

Section 1.3 - Manipulating Table Data
Section 1.3 covers the use of the datasheet to add, edit, and delete the records contained within.  This is the first exposure the students get of editing data stored in a table and inserting new records in to the database.

Section 1.3.1 - Selecting and Editing Data
Concept:
Selecting a cell's contents

Method:
Position the mouse pointer over the top or left border of the cell in question. The mouse pointer will change to a four-pointed cross symbol. Click the left mouse button once. The entire contents should be selected. Clicking the mouse pointer inside the cell (or near the right edge of the cell) results in positioning the insertion point and not selecting the contents of the cell.

Notes:
None
Concept:
Editing a cell's data

Method:
If the contents of a cell are selected, typing will overwrite the contents of the selection. If the insertion point is visible, you can use the arrow and backspace keys to move the insertion point and delete the previous characters. Typing while the insertion point is visible will result in modifying the cell's contents. End the editing by pressing the Enter key.

Notes:
None
Section 1.3.2 - Using the Undo Command
Concept:
Undoing editing

Method:
Use the Undo button on the toolbar, type Ctrl+Z, or choose the Undo menu item from the Edit menu to reverse the last action performed.

Notes:
Unlike the other Microsoft Office applications, the Undo command cannot be performed multiple times. Only the last editing action can be undone. Note that you cannot undo a record deletion.
Section 1.3.3 - Adding Records
Concept:
Inserting a new record in a table

Method:
To insert a new record in a table, use any of the following techniques:

· choose the New Record menu item from the Insert menu

· click the New Record button on the toolbar

· click the New Record button in the navigational bar
Notes:
Creating a new record will position the insertion point in the first field of the record. Many fields can be edited directly however, some cannot. A field with the value of (AutoNumber) will contain an automatically generated index value, and this field cannot be edited by the user. The AutoNumber is generated by Access when the user first enters any data in any other field for the record.
Section 1.3.4 - Deleting Records
Concept:
Deleting all of the records in a datasheet

Method:
Click the Select All button (located in the upper-left corner of the records listing in a datasheet). All of the records in the datasheet will be highlighted (selected). Next, click the Delete Record button, press the Delete key or choose the Delete Record menu item from the Edit menu.

Notes:
None
Concept:
Deleting a single record from a datasheet

Method:
To select a single record from a datasheet, click the row selector button on the extreme left of the row in question.  When the mouse is positioned over the row selector button, the mouse pointer will change to a black horizontal right-pointing arrow. Once the record is selected, you can click the Delete Record button, press the Delete key, or choose the Delete Record menu item from the Edit menu. A confirmation window will appear asking you to verify the record's deletion.

Notes:
None
Chapter 2: Creating a Database
Overview

Chapter 2 begins to introduce database design to the students by showing how to create tables.  There are three basic methods for table creation covered by Chapter 2. Additionally, instruction is given for table modifications using the Design View.

Teaching Tips and Strategy

Chapter 2 introduces two important concepts: data types and keys/indexes. New students (particularly those without backgrounds in computer science) may struggle with the differences in data types. It is not uncommon for these students to think that the computer can simply store data, but many probably will have not considered the need to instruct the computer on what type of data can be legitimately stored in a field.

Additionally, primary keys and indexes are briefly introduced in this chapter as well. Consider showing examples of how the primary keys are used in tables to uniquely identify data, perhaps with a table or chart during a lecture. In addition, using indexes can greatly speed up search time in a table, thus a discussion of their use (and hazards for overuse) is also warranted.

Lecture Notes

Section 2.1 – Designing Your First Database
Section 2.1 gets the students thinking about designing a new database from scratch. The section details creating a new database file (the first step in creating a database), and then using the Database Wizard to create the framework of their database. The wizard walks them through the creation of an inventory control system and takes them through the wizard’s decision system leading to the production of a new database with a switchboard screen.

Section 2.1.1 - Planning a Database
Concept:
Designing a better database

Method:
Section 2.1.1 introduces five steps to designing a great database.  They include:

1. Determine your output requirements

2. Determine your input requirements

3. Determine your table structures

4. Determine your table relationships

5. Test your database application

Notes:
The idea of introducing these steps may be daunting to some instructors, but a discussion of these concepts may help novice students better understand the work behind database management.

Section 2.1.2 – Starting a New Database
Concept:
Creating a new database

Method:
To create a new database, choose the New menu item from the File menu or click the New button. Next (no matter which method you chose), click the Blank Database hyperlink from the New area in the New File Task Pane. Then, select the location where the new database will be stored from the Save In: drop-down and provide a filename for the database in the File name: text area. Finally, click the Create button to create the database file, which will hold the contents of the database.

Notes:
None
Section 2.1.3 - Employing the Database Wizard
Concept:
Using the Database Wizard to create the framework of a new database.

Method:
To create a new database and populate it with pre-configured tables, reports, queries and forms, create a new database with the Database Wizard. To use the wizard, click the New button or choose the New menu item from the File menu, and then click the General Templates hyperlink under the New from template area in the New File Task Pane.

Next, the Templates dialog window will appear, allowing the user to select which template the wizard will use to create the framework of the new database. Once a template has been selected, the user will need to provide the location and file name for the new database (see the method for Section 2.1.2 above).  

After a template has been chosen, the user can use it to determine which tables and fields will be created by the wizard. Following table and field selection, the appearance style for forms created by the database is specified. The wizard also prompts for the selection of the page layouts for reports, the title of the database, and for the inclusion of logos or graphics. When completed, the wizard will create the database with the specified selections. In the wizard's final step, the user can request that the database be started by checking the Yes, start the database check box. If the database is started, the Main Switchboard will be displayed. The Switchboard allows the user to edit or view the various components of the database.

Notes:
This section covers a lot of ground quickly. The wizard that is presented is complex and has many pieces and options where the students may get confused or even lost. Consider walking the students through the use of the wizard step-by-step.

Section 2.2 - Creating a Simple Table
Section 2.2 introduces the creation of the student’s first table. Rather than modifying the database created in Section 2.1, a new database is created and a new table inserted in to it. This is a key section for the student’s understanding of databases. At least one table is needed in the database before any other type of database object (report, form, and query) can be created.  Therefore, it is critical that a student understands the importance of the table mechanism. The section covers table creation through two approaches: using the Table Wizard and creating a table via a datasheet.

Section 2.2.1 - Creating a Table Using the Table Wizard
Create:
Using the Table Wizard to create a new table

Method:
In the Database window click the Tables button and then use one of the following methods to start the Table Wizard:

· double-click the Create table by using wizard item, or

· click the New button on the Database window toolbar and then double-click the Table Wizard item in the New Table dialog box.

The Table Wizard dialog window will then appear allowing the user to select from sample tables and fields for use. Users can select from business-related or personal-related sample tables and fields for use in the new table. Fields from a variety of tables can be copied into the new table, thus drawing from the provided samples. When you are done selecting fields, click the Next button to move to the next page of the wizard.

In the second page of the wizard, users provide the name of the table that is about to be created as well as deciding if Access or the user will pick the primary key.

Notes:
Again, as with other sections, there are a lot of options and procedures to move though.  Novice students are likely to be confused and not understand all of the terminology.  Primary keys are sometimes difficult to grasp for those new to databases.

Section 2.2.2 - Creating a Table in Datasheet View
Concept:
Using a Datasheet to create a new table

Method:
Rather than spelling out all of the fields (and field types) prior to entering data (as was done in Section 2.2.1), it is possible to enter data directly into a Datasheet and have Access attempt to create the fields based upon the data that was entered. To obtain a datasheet, from the Database window, double-click on the Tables button and then do one of the following:

· double-click the Create table by entering data link, or

· click the New button on the Database window toolbar and then double-click the Datasheet View item in the New Table dialog box. By doing either procedure, a blank Datasheet will appear. Enter field names by editing the field header areas (labeled Field1, Field2...). Entering data in white data rows (located below the header rows) permits population of the database with initial data. Click the Save button on the toolbar and provide a name for the new table in the Save As dialog box that appears.

Finally, click the OK button to save the table. While saving, Access will alert the user to the lack of a primary key (if one was not specified). In the announcement, the user can choose to permit Access to choose the primary key, or to defer the creation of the key until later.

Notes:
None
Section 2.3 - Using the Table Design View
Section 2.3 demonstrates table creation via a table’s Design View.  A summarization of basic data types is presented, as well as a discussion of the use and creation of primary keys and indices.

Section 2.3.1 - Creating a Table in Design View
Concept:
Using the Design View to create a new table

Method:
Select the Tables button in the Database window and then do one of the following:

· double-click the Create table in Design View link, or

· click the New button on the Datasheet window toolbar and then double-click Design View in the New Table dialog box.

By using the Design Window that appears, users can add, delete, and rename fields for the table's structure; set a field's data type; specify a field's properties or characteristics; and set the primary key for a table. The window is broken into two parts, the Field Grid pane and the Field Properties pane. The former is where fields are named and their data types are defined; the latter is where a selected field's characteristics are displayed for editing.

To create a field, provide a name for the new field in the Field Name column of a blank row in the Field Grid, and select a datatype in the corresponding Data Type column. Table 2.1 from the text details the 10 different Access datatypes that the user can choose from in creating a new field. The most common datatypes include text, number, date/time, Yes/No, currency, and AutoNumber (used to create primary keys).

Notes:
Field names cannot be longer than 64 characters and cannot contain special symbols or punctuation characters. It is also important for students to understand the use of the ten data types used within Access 2003: Text, Memo, Number, Date/Time, Currency, AutoNumber, Yes/No, OLE Object (such as a picture), Hyperlink, and Lookup Wizard.
Section 2.3.2 - Assigning a Primary Key
Concept:
Selecting a field to be a table's primary key

Method:
To select a field as the primary key, use the table's Design Window to view the list of fields for that table. Then, select the desired field by clicking the mouse on the field selector area (to the left of the field's name). Finally, click the Primary Key button on the Access toolbar, or choose the Primary Key menu item from the Edit menu.  A small key icon will appear in the field's selector area, designating it as the primary key for this table. Save the changes to the database by clicking the Save button on the toolbar.

Notes:
There is only one primary key per table in a database.

Section 2.3.3 - Defining and Removing Indexes
Concept:
Creating table indices using the Design view

Method:
In the table's Design Window, use the row selector to select a field to be an index. Next, select Yes from the Indexed drop-down menu in the Field Properties pane.

Notes:
Fields, which have the letters “ID” in their names, are automatically indexed by Access.

Concept:
Removing a table index using the Design view

Method:
To remove an index from a table’s field, click the Indexes button on the toolbar and then right-click on the desired field’s row selection button. Finally, choose the Delete Rows menu item from the menu that appears. Keep in mind that you are only deleting the index from the field! You are not deleting the field from the table. 

Notes:
An easier way to remove an index would be a follows. In the table's Design Window, use the row selected to select a field.  Next, select No from the Indexed drop-down menu in the Field Properties panel.

Section 2.4 - Modifying a Table
Section 2.4 covers the management (insertion, renaming, moving, and deletion) of fields in an existing database via the Design View of a table.  The section concludes with a discussion of the use of the database Documenter to detail the design of the database.

Section 2.4.1 - Inserting and Deleting Fields
Concept:
Inserting a new field into a table via the Design Window
Method:
To insert a new field into a table, double-click on a table name in the Database window to open the table’s Datasheet. Choose the Design View menu item from the View menu or click the View button on the toolbar and select the Design View item from the drop-down menu. Then, select an empty row in the Field Grid pane. Next, enter the field’s name, datatype, and an optional description.

Notes:
Be sure to save the changes to the table’s structure by clicking the Save button on the toolbar.

Concept:
Deleting a field from a table via the Design View
Method:
Open the Design Window of a table (follow the directions above to open the Design View). Next, use the row selector button to choose the field you wish to delete from the table.  Right-click in the row selector area and choose the Delete Rows menu item from the menu that appears. Prior to actual deletion, Access will display an alert confirmation dialog window asking you to verify the deletion. If you wish to remove the field, click the Yes button and the field will be removed from the table.

Notes:
Be sure to save the changes to the table’s structure by clicking the Save button on the toolbar.
Section 2.4.2 - Renaming and Moving Fields
Concept:
Renaming a field in a table

Method:
To rename a field in a table, open the table’s Design Window.  Then either double-click anywhere on the field’s name to select the entire value, or single click to place the insertion point in the field’s name. You can now use common editing procedures (backspace key, delete key, etc.) to change the name of the field.

Notes:
Be sure to save the changes to the table’s structure by clicking the Save button on the toolbar.

Concept:
Moving a field within its table

Method:
To move a field, open the table’s Design Window. Next, click the row selector’s button for the field you wish to move. Then, drag the row to the new location and release the mouse button.

Notes:
Be sure to save the changes to the table’s structure by clicking the Save button on the toolbar.

Section 2.4.3 - Printing a Table's Design Structure
Concept:
Using the Access Documenter to preview and print database object’s design characteristics.

Method:
To use the Access Documenter, choose the Analyze menu item from the Tools menu. Then, select the Documenter menu item from the Analyze menu. Select the Tables tab to show a listing of the tables in the current database. Click the checkbox for each table you wish to generate a report for, and then click to Options… button and the Print Table Definition dialog window.

Using the Print Table Definition dialog window, users can select reported information about table, field, and index characteristics by clicking on the respective checkboxes. Complete the selections by clicking on the OK button to return to the Documenter dialog window. Press the OK button in the Documenter window and an Object Definition report window will appear, detailing the characteristics selected. The report can be printed by clicking on the Print button on the toolbar.

Notes:
The Access Documenter may not be installed by default. Students attempting to access the Documenter may be notified that the Documenter wizard was not installed, but may be installed. Note that due to this situation, public laboratories may not have this capability by default.

Chapter 3: Organizing and Retrieving Data
Overview

Chapter 3 expands the students’ understanding of accessing data via a datasheet. The various sections cover the customization of the datasheet, sorting and finding data in the datasheet, and filtering the data displayed by the datasheet. The chapter concludes with the introduction of building simple queries through the wizard and design views.
Teaching Tips and Strategy

The coverage of queries can be tricky. Queries return dynasets, which really are filtered datasheets, so there may be some confusion over the terminology and differences between the two.

One additional point to consider is that while this chapter considers using datasheets to access the "raw" data, most database users will interact with forms and reports (which is the preferred method of data interaction). Consider cautioning the students of the potential perils of relying on datasheets for access to their data.

Lecture Notes
Section 3.1 - Customizing Datasheet View
This section provides additional direction on how to effectively use datasheets to view and present data stored in the database. The section covers the formatting of the datasheet for presentation, reordering of the fields shown by the datasheet, and hiding and unhiding datasheet fields (columns). Section 3.1 concludes with the introduction of freezing (and unfreezing) datasheet columns in order to more easily identify the records displayed.
Section 3.1.1 - Formatting a Datasheet
Concept:
Applying formatting characteristics to the text displayed in a datasheet

Method:
To modify the appearance of text displayed in a datasheet choose the Font menu item from the Format menu. The Font dialog box will appear, and allows users to change the font typeface, size, style, and color of text displayed in the datasheet. Once the modifications have been selected, click the OK button to set the changes to the datasheet. You will now see that all text displayed in the datasheet have the new font formatting properties applied.

Notes:
Be sure to save the changes to the datasheet by clicking the Save button on the toolbar.

Concept:
Formatting the appearance of the datasheet

Method:
To modify the appearance of the datasheet itself (background, gridlines, etc.) choose the Datasheet menu item from the Format menu. The Datasheet Formatting dialog window will open. Using this window, users can modify the appearance of each cell (flat, raised, or sunken appearance), toggle the display of both horizontal and vertical gridlines, modify the background and gridline colors, as well as change the line styles for the border and the gridlines.  Once the desired changes have been made, click the OK button to the datasheet.

Notes:
Be sure to save the changes to the datasheet by clicking the Save button on the toolbar.

Section 3.1.2 - Changing the Field Column Order
Concept:
Changing the field column order via the Datasheet

Method:
Open a table's Datasheet and use the mouse to drag each column to the desired order. You can move each field by dragging the field's name to the desired location.

Notes:
While dragging, a bold vertical gridline will follow the mouse and indicate where the field will be moved to, once the mouse is released. Multiple fields can be selected for dragging, by holding down the Shift key while selecting the fields.

Section 3.1.3 - Hiding and Unhiding Columns
Concept:
Hiding a column in a datasheet

Method:
To hide a column in a datasheet, select the field by clicking the mouse in the field's header area, and then choose the Hide Columns menu item from the Format menu. You can also hide a column by selecting it and right clicking the mouse and choosing the Hide Columns menu item from the menu that appears.

Notes:
None
Concept:
Unhiding a column in a datasheet

Method:
To unhide a column in a datasheet, choose the Unhide Columns menu item from the Format menu. The Unhide Columns dialog box will appear, allowing users to select which columns to unhide.  The Unhide Columns dialog box displays all of the fields of the datasheet, with those currently not hidden indicated with a selected check box. Hidden columns are indicated without a check in their check box. To unhide a column, simply click the mouse in the check box of a hidden column and press the Close button.

Notes:
None
Section 3.1.4 - Freezing and Unfreezing Columns
Concept:
Freezing a field's column in a datasheet

Method:
To freeze one or more columns in a datasheet, select the columns (as described above) and then choose the Freeze Columns menu item from the Format menu, or right-click the desired field's header area and choose the Freeze Columns menu item from the menu that appears.

Notes:
None
Concept:
Unfreezing all frozen columns in a datasheet

Method:
To unfreeze any frozen columns, choose the Unfreeze All Columns menu item from the Format menu.

Notes:
None
Section 3.2 - Sorting, Finding, and Maintaining Data
Section 3.2 discusses more advanced datasheet control by covering the sorting of the displayed records.  Searching and pattern matching are covered next, as a means for locating specific data within the datasheet.  Finally, the section concludes with instructions for performing find and replaces actions on the data in the datasheet and using the spelling checker on the same data.
Section 3.2.1 - Sorting Records in a Datasheet
Concept:
Sorting record data in a datasheet

Method:
Open the Datasheet for a given table and select the desired column (field) to sort the data.  Then, to sort the data in ascending order, click the Sort Ascending button on the toolbar.  To sort the data in descending order, click the Sort Descending button on the toolbar.  The datasheet will be updated to reflect the sorting criteria.

Notes:
You can also right-click in the field header area and choose either the Sort Ascending or the Sort Descending menu item from the menu that appears.

Section 3.2.2 - Performing a Simple Search
Concept:
Searching for a value in a selected field

Method:
To search for a given value in the rows of records in a datasheet, select a cell in the field column and click the Find button on the toolbar or choose the Find menu item from the Edit menu.  Then, from the Find and Replace dialog window that appears, enter the search text in the Find What: text area and click the Find Next button.  The cursor will be moved down the column to the first matching occurrence.

Notes:
Additional searches can be performed on the same value by pressing the Find Next button on the Find and Replace dialog window.  If no match is found, an alert is provided to the user.

Section 3.2.3 - Specifying Search Patterns
Concept:
Wildcard characters for use in searches

Method:
The following characters can be used during the search process discussed in Section 3.2.2:
? - matches any single character of any value

# - matches any single number of any value

* - matches one or more characters of any value

Notes:
None
Section 3.2.4 - Performing a Find and Replace
Concept:
Replacing values in an entire table using Find and Replace

Method:
To search for and replace values globally across an entire table, select a cell in the field column you wish to search. Then, choose the Replace menu item from the Edit menu to display the Find and Replace dialog window. Click the Replace tab and provide the search term in the Find What: text area and the replacement text in the Replace With: text area.

To search and replace one occurrence at a time, click the Replace button repeatedly. To automatically replace all occurrences of the search term, click the Replace All button.

Notes:
None
Section 3.2.5 - Spell-Checking a Datasheet
Concept:
Spell checking the entries in a table's datasheet

Method:
To spell check the values stored in a datasheet, click the Spelling button on the toolbar or choose the Spelling menu item from the Tools menu. If misspelled words are found by the spell-checking feature, a Spelling dialog window will appear showing the misspelled word in the Not In Dictionary: text area. Suggested replacement words are also shown in the dialog window.

To ignore the suggested changes, click the Ignore or Ignore All buttons.  To replace the misspelled word with one provided, select the replacement from the Suggestions: list and click the Change button.  If the red underlined word (indicating that it is misspelled) is not misspelled at all, and you wish to place it in a custom dictionary (so that it is not considered misspelled next time), click the Add button.

When the spelling check is complete, Access will display an announcement for the user.

Notes:
None
Section 3.3 - Using Filters
Section 3.3 covers three different techniques for applying filters to datasheets, thereby restricting the data displayed.  The three methods include filtering based on user-typed input, selection (highlighting) and by the use of a form.  The latter method is the most versatile, as the form permits multiple filtering criteria, the only technique that does so.
Section 3.3.1 - Filtering for Input
Concept:
Imposing a filter on a specified field

Method:
To impose a filter on a specified field in a table, open the table's Datasheet view.  Then, right-click on a cell in the desired field's column and choose the Filter For: menu item from the menu that appears.  In the text area located next to the Filter For: label, enter a term to filter on and press return.  Search terms can include text, numbers and the wildcard characters listed in Section 3.2.3.  Once the filtering term has been entered, the datasheet changes to display only those records, which match the criteria for the specified field.

Notes:
None
Concept:
Removing a filter

Method: 
To remove a filter that was imposed, click the Remove Filter button on the toolbar to toggle the filter.

Notes:
None
Section 3.3.2 - Filtering by Selection
Concept:
Applying a filter based on a selection

Method:
After selecting the text value to filter on, click the Filter By Selection button or choose the Filter menu item from the Records menu.  Then, choose the Filter By Selection menu item from the Filter menu.  Only those records, which match the filter for the specified field (based on the selection), will be displayed.  See if this filter is limited to the field of selection.

Notes:
None
Concept:
Applying a filter based on a selection to exclude records

Method:
You can also apply a filter on your data to show all records that do not contain the selected text.  To do this, select the text for the filter, then choose the Filter menu item from the Records menu, and then choose the Filter Excluding Selection menu item from the Filter menu.

Notes:
None
Section 3.3.3 - Filtering by Form
Concept:
Creating a filter based on multiple criteria via the use of a form

Method:
To create a more complex filter for your data, you can use multiple criteria.  To do so, use the Filter By Form dialog window to specify the filtering specifics.  To display the Filter By Form dialog window, click the Filter By Form button on the toolbar or choose the Filter menu item from the Records menu, then choose the Filter By Form menu item from the Filter menu.

In the dialog window, use the mouse to select the filtering criteria for any desired field.  Below each field name is a drop-down list of the unique values for that field from the datasheet.  Using this method, you can provide filtering criteria for one or more fields.  When you have completed populating the criteria, click the Apply Filter button on the toolbar to update the datasheet with the new filter.

Notes:
A filter created with the Filter By Form dialog window can be saved as an Access query by clicking on the Save As Query button on the toolbar and providing a name for the new query.

Section 3.4 - Creating a Simple Query
This section introduces query development and design briefly.  The Query Wizard is used to create an initial query.  The section concludes with a small amount of detail for modifying existing queries via the Design View (applying filtering/criteria).  
Section 3.4.1 - Creating a Query Using the Query Wizard
Concept:
Using the Query Wizard to create a new query

Method:
To start the query wizard, use the Database window and click the Queries button.  Then, double-click the Create query by using wizard icon or click the New button on the Database toolbar and double-click the Simple Query Wizard item in the New Query dialog box.

To build a query (based only on tables at this point), use the Tables/Queries pull-down list to select a single table.  Below the list appears a scrolling list of fields from the selected table.  You can select a field from the field list and move it to a selected field (to be part of the query) by clicking the Include button (>).  All of the fields can be selected for inclusion in the query by clicking the Include All (?) button.  It is permissible to select another table at this point to include some or all of its fields in the query.

Press the Next > button to name the query and click the Finish button to save and execute the query.  A dynaset window will appear, showing the results of the query.

Notes:
None
Section 3.4.2 - Displaying the Query Design Window
Concept:
Using the Query Design window to modify an existing query

Method:
There are two methods to showing a query's design window:
· When the dynaset's Datasheet window is still open, click the View, Design button on the toolbar.

· In the Database window, click the Queries button, select the query you wish to modify and then click the Design button on the toolbar.  You can also right-click on the query name and choose Design View.

Fields can be added to the query by using the mouse to double-click on a field's name in the Table pane (upper half of window).  Fields added to the query will be displayed in the Design Grid (lower half of the window).  Addition field criteria (wildcards and selection values) can be added to any field in the query by entering the selection criteria in the Criteria: text area in a field's column in the Design Grid.

Notes:
Be sure to save the updated query by clicking on the Save button on the toolbar after making changes.

Chapter 4: Presenting and Managing Data
Overview

Chapter 4 introduces the creation of simple forms and reports based upon one table or query.  Both methods employ the use of their respective Auto Wizards prior to the introduction of the regular wizard later.  The Auto Wizards (AutoForm and AutoReport) can be used to quickly create their simple respective objects. 

The chapter goes on to expand on reports by demonstrating the creation of mailing labels from a table of student names and address data.  The chapter closes with some simple database management skills (renaming objects, compressing the database files, and converting the database to another format).

Teaching Tips and Strategy

While the creation of forms and reports is easy to follow, the students may be most interested in the creation of the mailing labels.  It is not uncommon to see students overwhelmed by Access, and its powerful features for data management, since Access is tailored to a professional setting.  However, this section (4.3) is a practical use of a database, which they can adopt immediately for personal use.

Caution is advised when covering publishing HTML and XML documents (4.2.4).  Not all students understand how to make web content available (even should they have access to a web server that they can publish on).  Therefore, consider the audience and situation when covering this topic.  Although the section includes creation of an HTML or XML file, students may look for direction on publishing the file to a server so that it is available via a URL. 
If students have a general XML understanding, they may also begin to realize that publishing an XML file can make that data available to many types of web databases and other web devices (through UPnP). 
Lecture Notes
Section 4.1 Creating a Simple Form
Section 4.1 describes two ways to create a form to view/edit data associated with a table or query.  Use of both the AutoForm Wizard and Form Wizard are covered in demonstrating how to easily create an interface for accessing data.  Also covered in this section are instructions on how to navigate through data by using the form and how create, print, sort, and delete records via a form.

Section 4.1.1 - Creating a Form Using the AutoForm Wizard
Concept:
Creating a new columnar form

Method:
In the database window, select an Access table and then click the New Object button on the toolbar and choose the AutoForm item from the menu that appears.  This will start the AutoForm wizard and create a new form for the selected table.  The resulting form will be in columnar format.  That is, each row of the form will contain both a field label and the associated value for the field for the record displayed.  Columnar forms show only one record at a time.  To save the form, click the Save button on the toolbar and give the form a name.
Notes:
None
Concept:
Creating a new form (of any type) using the AutoForm wizard

Method:
The method above described how to create a columnar form.  To create a form of another type (tabular, datasheet, pivot table, pivot chart), from the database window, click the New button on the toolbar.  Then, in the New Form dialog window that appears, select a table or query from the drop-down list box (in the lower section of the window), and then double-click on one of the AutoForm wizards listed in the upper list area.

Notes:
None
Section 4.1.2 - Creating a Form Using the Form Wizard
Concept:
Creating a new form via the Form Wizard

Method:
In the Database window, click the Forms button to display the list of forms in the database.  Then, double-click the Create form by using wizard item, opening the Form Wizard dialog window.  Another method that will open the Form Wizard dialog window is to click the New button on the Database window toolbar, select a table or query from the drop-down list box, and then double-click on the Form Wizard item.

Once the wizard's window is open, select a table or query to base the form on, and then use the > and >> buttons to add fields from the selected table or query to the form.  When all desired fields have been added, click the Next > button.  Then, select the arrangement of the fields in the form and click the Next > button.  In the final series of steps, you select the formatting style of the form (press the Next > button), decide to display or further modify the form, and then press the Finish button.

Notes:
None
Section 4.1.3 - Navigating Data Using a Form
Concept:
Navigating between records of a form

Method:
Use the following keystrokes or buttons (located in the Record Navigation area) to navigate amongst the records of a form:
· Ctrl+Home (or the |< button) - moves to the first field of the first record

· PgUp (or the < button) - moves to the previous record

· PgDn (or the > button) - moves to the next record

· Ctrl+End (or the >| button) - moves to the last field of the last record

Notes:
None
Concept:
Moving amongst the fields on a form

Method:
When viewing data in a form, you can use the following keystrokes to move between the display areas for each field:
· Home - move to the top of a form

· End - move to the bottom of a form

· up arrow or Shift+Tab to move backward one field

· down arrow or Tab to move forward one field

Notes:
None
Section 4.1.4 - Working with a Form
Concept:
Important buttons and actions when using forms

Method:
Various features are enabled when working with forms, and are accessible via buttons on the toolbar.  These features include:

1. create a new record using the form—click the New Record button

2. removing the current record shown in the form—click the Delete Record button

3. sort the sequence of records shown by the form into ascending order—click the Sort Ascending button

4. sort the sequence of records shown by the form into descending order—click the Sort Descending button

5. print preview the form—click the Print Preview button

6. print the form—click the Print button

Notes:
None
Section 4.2 - Creating a Simple Report
Section 4.2 instructs students on creating reports based on a single table or query.  The AutoReport Wizard and Report Wizard are discussed during this process.  The Report Wizard is considerably more powerful, as it permits the grouping and sorting of the data the report is based on.  Print Previewing is covered as a method to validate the output prior to printing.  Finally, the section concludes with the notion of publishing HTML and XML documents, suitable for publishing over the web or exporting into another database.

Section 4.2.1 - Creating a Report Using the AutoReport Wizards
Concept:
Creating a columnar report using the AutoReport feature

Method:
To create a columnar report, select a table or query from the Database window.  Then, click the New Object: AutoReport button on the toolbar and the new report will be created.

Notes:
None.

Section 4.2.2 - Creating a Report Using the Report Wizard
Concept:
Creating a new report using the Report Wizard

Method:
To use the Report Wizard to create a new report, select the Reports button on the Database window and then follow one of the methods below to open the Report Wizard dialog window:
· double-click the Create report by using wizard item

· click the New button on the Database window toolbar, select a table or query to base the report on and double-click the Report Wizard item.
When the Report Wizard opens, select the fields that you wish to appear in the report and click the Next > button.  In the next page of the wizard, you can choose which field to group the data.  Select a grouping field by double-clicking on a field name in the list box and click the Next > button to move to the next page of the wizard.

The third page of the wizard allows for the definition of how the data is sorted (if at all).  Here, you can select the fields that are sorted by using the drop-down lists and in which direction (ascending or descending) they are sorted by clicking the Ascending/Descending buttons.  Use the Summary Options button to define summary calculations on the fields (sum, average, min, max) if applicable.  Click the Next > button to move to the next page of the wizard.

With the fourth page of the wizard, you can set the page layout and orientation characteristics for the report (including portrait and layout styles).  Clicking the Next > button moves you to the fifth page of the wizard, where you select the style of the report, modifying the look and feel of the presented report.  Finally, click the Next > button to move to the last page of the report, to provide the report a name and to decide if you want to open the report immediately in Print Preview mode.  Click the Finish button to save the new report.

Notes:
None
Section 4.2.3 - Previewing and Printing a Report
Concept:
Previewing a report

Method:
You can preview a report with Print Preview feature to see how it will appear when printed.  To do this, select a report from the Database window and then click the Print Preview button on the toolbar, or choose the Preview menu item from the File menu.

Notes:
You can view multiple pages at one time on the screen by clicking on the Multiple Pages button and choosing how many pages to display across and down on the screen at one time.
Concept:
Printing a report

Method:
To print a report, select the report in the Database window and then click the Print button on the toolbar, or choose the Print menu item from the File menu.

Notes:
None
Section 4.2.4 – Publishing HTML and XML Documents
Concept:
Saving a database object as an HTML or XML document
Method:
To save any database object (report, table, query, form) as a file suitable for publication on the web or for XML use such as exporting into another database, select the object in the Database window and then choose the Export menu item from the File menu.  In the File Name: text area provide a name for the file you are about to create.  You should then select HTML documents or XML in the Save as type drop-down list box. In choosing HTML, the HTML Output Options dialog window will appear, allowing you to select an HTML template as well as override the default encoding for the HTML file.  Press the OK button to complete the exporting process. In choosing XML, the Export XML dialog box opens, offering the primary choices of Data (XML), Schema of the Data (XSD), and/or Presentation of your Data (XSL).  You can select your requirements and click on the OK button, or create additional choices/options under the Options button.  The Data, Schema, and Presentation folders then allow additional choices.
Notes:
As a brief edition, just explaining the choices of publishing HTML or XML to the web should be sufficient.
Section 4.3 - Generating a Mailing Labels Report
This short section expands on report generation for a specific kind of report—mailing labels.  The example provided is based upon existing student data from sample input files, but can be used to motivate students to use Access in a personal setting.
Section 4.3.1 - Creating a Report Using the Label Wizard
Concept:
Creating labels using the Label Wizard

Method:
To create labels (mailing, diskette, shipping, etc.) with the Label Wizard, select the Reports button in the Objects bar.  Then, click the New button on the Database window toolbar to open the New Report dialog window.  Next, select the Label Wizard list item and use the drop-down list to choose the table or query that contains the label data.  Click the OK button to move to the second page of the wizard.


On the next page of the wizard, you can set various properties of the labels, including which manufacturer made the labels (which makes label set-up much easier).  Click the Next > button to move to the third page of the wizard.  Here, you set the font characteristics of the labels that are produced.  The final two pages of the wizard permit selection of the fields for inclusion on: the labels, the layout of the label, and the sorting of the labels.
Notes:
None
Section 4.4 - Managing Database Objects
The chapter concludes with simple database management skills including the renaming, copying, and deleting of existing database objects.  Additionally, coverage is given to compacting the database (to conserve disk space) and converting the database to a different format for ease of sharing the underlying objects with earlier versions of Access. 
Section 4.4.1 - Renaming, Copying, and Deleting Objects
Concept:
Renaming a database object

Method:
Right-click on the desired object in the Database window and choose the Rename menu item from the menu that appears.

Notes:
None
Concept:
Deleting a database object

Method:
Right-click on the desired object in the Database window and choose the Delete menu item from the menu that appears.  You can also click the Delete button on the database window toolbar.

Notes:
None
Concept:
Copy a database object

Method:
Right-click on the desired object in the Database window and click the Copy button on the database window toolbar, or choose the Copy menu item from the menu that appears.

Notes:
None
Concept:
Pasting a copied database object

Method:
Click the Paste button on the Access toolbar, or right-click and choose the Paste menu item from the menu that appears.  In the dialog window that appears, provide a name for the object that is about to be pasted back into the database.

Notes:
None
Section 4.4.2 - Compacting, Repairing, and Converting a Database
Concept:
Compacting and repairing a database

Method:
Open the database you wish to compact and repair.  Choose the Database Utilities menu item from the Access toolbar.  Next, choose the Compact and Repair Database menu item from the Database Utilities menu. 

Notes:
This operation is performed (usually) without any other input or dialog windows.  The status of the operation can be seen in the Status bar. 

Concept:
Converting the database

Method:
Open the database you wish to convert to a different format.  Choose the Database Utilities menu item from the Tools drop-down menu.  Next, choose the Convert Database menu item from the Database Utilities menu, and select the target database type you wish to convert.


The Convert Database Info dialog window will appear.  In this window you provide the name and location of the new database that is created (converted databases are saved as a new database).  Click the Save button to convert the database.  A warning dialog window will appear indicating what has transpired, and the limitations such a conversion will cause.  Click the OK button to dismiss the warning.
Notes:
None

Resource III:

Extra-Curricular Activities

Chapter 1: Extra-Curricular Activities
Activity 1 Open the student data file AC0100 (as you did in Section 1.1.3).  Open the Students table in a datasheet window.  Use the movement commands discussed in Section 1.2.1 and answer the following questions:

· Who is the last student in the table (first and last name)?

· What is the 10th student's major?

· What is the first student's phone number?

Activity 2 Open the Instructors table of the AC0100 student data file in a datasheet window.  Add a new record with your instructor's information.  Save the updated database to your system.
Activity 3 Open the Instructors table of the AC0100 student data file in a datasheet window.  Edit the data for the instructor Herman Melville.  Change his first name to Michael and change his office location to B102.  Save the updated database to your system and use the Windows Explorer to copy it to a floppy disk, and submit the floppy disk to your instructor.

Chapter 2: Extra-Curricular Activities

Activity 1 Design a new database that will hold your DVD collection information.  The database should only contain one table.  List your design of the table.  What fields are present in the table, and what are their datatypes?

Activity 2 Take the database design that you created in Activity 1 and create a new database called MyCollection.  Your database's table should be called MyDVDs.  Use the method described in Section 2.2.2 (creating a table in datasheet view) to create the table.  Be sure to provide a primary key for your table by creating an AutoNumber field.  Insert the data for at least 10 DVDs.

Activity 3 Use the Design View of the MyDVDs table to insert a Notes field.  This field will hold comments you have about each DVD.  Then, for each record in the table, edit the cell that contains the Notes, and comment on each DVD.  Perhaps, you wish to note other movies in which an actor has been.  Rank each DVD on a scale of 1 to 10.

Chapter 3: Extra-Curricular Activities

Activity 1 Create a formatted version of the MyDVDs datasheet suitable for printing.  Change the font style, size, and color of the record data.  Also change the color of the gridlines.  Print the result of your changes.

Activity 2 Next, change the order of the fields in the datasheet that you have just printed.  Assuming you have fields like the actor’s name, DVD title, optional footage, and the like, rearrange the fields and print the result.  Ensure that your rearrangement is distinct enough so that your instructor can grade your work by quickly looking at the two printouts.  (That is, do not just rearrange one field!)

Activity 3 Finally, hide the AutoNumber column from the printout and sort the data according to the DVD's title in ascending order.  Print the datasheet and submit it for grading.

Chapter 4: Extra-Curricular Activities
Activity 1 Use the Form Wizard feature to create an input/editing form for the MyDVDs table.  Do not include the AutoNumber field as part of the form. (You cannot edit that data anyway.)  The form that you create should be a columnar form that had the industrial style applied to it.  Save the form it the database as MyDVDForm.

Activity 2 Use the Report Wizard to create a grouped report about the MyDVDs table.  Group the DVDs by actor's name in the report.  (Hint: to see this in action when you preview/print the report, you may need to add additional data for another DVD with the same actor.)  The data in the report should be sorted by DVD title (descending).  Save this report in the database as MyDVDsReport.

Activity 3 Publish the report created in Activity 3 to the Internet.  If you cannot publish the report to the web, export the report as an HTML file named CDReport.

Resource IV:

Answers to End-of-Chapter Review Questions

Chapter 1: Answers to End-of-Chapter Review Questions

Short Answer

1. This open-ended question allows the student to suggest uses and applications for an Access database. Some typical responses include phone and address books, customer and supplier lists, inventory and product information, and other accounting-related data.

2. From the Glossary, the definitions are:

· Table: A database object used to collect and store data relating to a particular subject or topic.

· Record: An individual entry, or row, in a table. A record contains one or more fields.

· Field: A single piece, or column, of information in a record.

3. An object is a component of a database that you can create, select, and manipulate. The primary objects in Access include tables, queries, forms, reports, data access pages, macros, and modules.

4. Table objects are used to collect and store data.

5. Report objects display in Preview mode when opened.

6. The Database window is referred to as a control center because you can access all of the database objects from this one location. The Objects bar provides buttons that separate the objects into logical category groupings.

7. In a datasheet, you select the contents of a cell by clicking the cross mouse pointer on the top or left gridline of the cell. 

8. In a datasheet, you select all of the records by clicking on the Select All button ([image: image1.png]


) in the top left-hand corner of the Datasheet window.

9. To add a record, you move to the last row in a datasheet and then enter the desired information. You can also use the New Record buttons ([image: image2.jpg]


) to help position the cursor.

10. To delete a record, you select the record (its entire row) and then press [image: image3.png]|De|ete|



 or click the Delete Record button ([image: image4.jpg]123



).

True/False

	1.
	F
	6.
	T

	2.
	T
	7.
	T

	3.
	F
	8.
	T

	4.
	T
	9.
	F

	5.
	F
	10.
	T


Multiple-Choice

	1.
	A
	6.
	A

	2.
	C
	7.
	D

	3.
	A
	8.
	C

	4.
	D
	9.
	C

	5.
	B
	10.
	B


Chapter 2: Answers to End-of-Chapter Review Questions

Short Answer

1.
By default, Access ships with the following Database Wizard templates: Asset Tracking, Contact Management, Event Management, Expenses, Inventory Control, Ledger, Order Entry, Resource Scheduling, Service Call Management, and Time and Billing. The student need only list four templates.

2.
A switchboard is a special form created by the Database Wizard to act as the main menu for an application. 

3.
The five steps to designing a better database are:
( Determine your output requirements
( Determine your input requirements
( Determine your table structures
( Determine your table relationships
( Test your database application
4.
Three methods for creating a table in an Access database are:
( Using the Table Wizard
( Using Datasheet view
( Using Design view

5.
The two categories of Table Wizards include Personal and Business. 

6.
The data storage types are Text, Memo, Number, Date/Time, Currency, AutoNumber, Yes/No, OLE Object, Hyperlink, and Lookup Wizard.

7.
A Text field may contain up to 255 alphanumeric characters, while a Memo field may store up to 65,535 alphanumeric characters.

8.
A primary key must contain a unique value and determines the default sort order for displaying data. An index may or may not restrict duplicate entries and is used primarily to speed up search and sort operations.

9.
You insert a row in a table structure to add a new field. When you want to position a new field between two existing fields, you right-click the desired row's selector button and choose Insert Rows. You may then enter the field name, data type, and description.

10.
Changing a field's data type may result in your losing data if the types are not compatible. For example, changing a Text field into a Number field will result in most of the data being deleted.

True/False

	1.
	F
	6.
	F

	2.
	T
	7.
	T

	3.
	T
	8.
	F

	4.
	F
	9.
	T

	5.
	T
	10.
	T


Multiple-Choice

	1.
	A
	6.
	D

	2.
	C
	7.
	A

	3.
	D
	8.
	B

	4.
	B
	9.
	C

	5.
	D
	10.
	B


Chapter 3: Answers to End-of-Chapter Review Questions

Short Answer

1.
The three Cell Effect options for formatting a datasheet are:
( Flat
( Raised
( Sunken

2.
The Freeze Columns command prevents the selected column(s) from moving when you scroll the window sideways. You can use either the Format menu or the right-click menu from the field header area to choose the command.

3.
The two primary options for sorting a list are:
( Ascending ([image: image5.jpg]L



), which sorts data from 0 to 9 and A to Z
( Descending ([image: image6.jpg]


), which sorts data from Z to A and 9 to 0

4.
Wildcard characters are the question mark (?), which represents a single character, the number symbol (#), which represents a single number, and the asterisk (*), which represents a group of characters.

5.
Four methods for filtering records in a table include:
( Filter For Input
( Filter By Selection
( Filter Excluding Selection
( Filter By Form

6.
The Find command focuses on matching and locating a single record, while a filter displays a group of records. The Find command moves the cursor to a matched record in the midst of all the other records. A filter limits the display to only those records meeting the search criteria. Use filters when you need to focus in on a subset of records matching the search criteria.

7.
You type an entry into the Filter For Input text box that is accessed from a field’s right-click menu. You select an existing value in the datasheet and then apply the Filter By Selection command. 

8.
You apply a filter when you want to limit the display of records in a particular table. You create a query when you want to extract data from multiple tables or when you need to specify complex search criteria and sort parameters. A query also provides you with an independent and reusable database object. 

9.
When you use the Simple Query Wizard, you cannot specify search criteria or sort parameters.

10.
The Simple Query Wizard creates a select query. Other types of queries are action queries and parameter queries.

True/False

	1.
	T
	6.
	F

	2.
	F
	7.
	F

	3.
	T
	8.
	T

	4.
	T
	9.
	F

	5.
	F
	10.
	T


Multiple-Choice

	1.
	B
	6.
	C

	2.
	C
	7.
	A

	3.
	B
	8.
	B

	4.
	A
	9.
	A

	5.
	A
	10.
	C


Chapter 4: Answers to End-of-Chapter Review Questions

Short Answer

1. Forms are used to facilitate entering and editing data. Whereas datasheets display numerous records, forms allow you to focus on a single record at a time. Some uses of forms include data entry forms, switchboard forms, and custom dialog boxes.

2. The five types of AutoForm Wizards are Columnar, Tabular, Datasheet, PivotTable, and PivotChart. The Columnar AutoForm Wizard displays data from one record in a single column. The Tabular AutoForm Wizard displays data in a row and column table format. The Datasheet AutoForm Wizard prepares a form that closely resembles a datasheet. The PivotTable and PivotChart provide spreadsheet-like cross-tabulation analysis for your table data.

3. The form options listed in the New Form dialog box include Design View, Form Wizard, AutoForm: Columnar, AutoForm: Tabular, AutoForm: Datasheet, AutoForm: PivotTable, AutoForm: PivotChart, Chart Wizard, and PivotTable Wizard.

4. The columnar and justified form layouts are suited to viewing a single record at a time and work especially well for tables with few fields.

5. The tabular and datasheet form layouts are best used to display numerous records at a time.

6. Reports are used to present information and to provide hard copy printouts of a table’s data. Some examples of reports include invoices, mailing labels, address books, product catalogs, and inventory listings.

7. The two types of AutoReport Wizards are Columnar and Tabular. The Columnar AutoReport Wizard presents data down a single column. The Tabular AutoReport Wizard resembles a datasheet with field headings at the top of each column and record data appearing on each row.

8. The report options listed in the New Report dialog box include Design View, Report Wizard, AutoReport: Columnar, AutoReport: Tabular, Chart Wizard, and Label Wizard.

9. Regardless of its target destination, you more or less create a report object using the same method. Once finished, you can export the report as an HTML document and then upload the file to a Web server. 

10. You can remove an object in the Database window by choosing the Delete command from the object’s right-click menu. You can also select the object and then click the Delete ([image: image7.jpg]


) button in the Database window toolbar.

True/False

	1.
	T
	6.
	T

	2.
	F
	7.
	T

	3.
	T
	8.
	F

	4.
	F
	9.
	T

	5.
	F
	10.
	F


Multiple-Choice

	1.
	A
	6.
	C

	2.
	B
	7.
	B

	3.
	D
	8.
	D

	4.
	A
	9.
	A

	5.
	B
	10.
	C
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