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	Chapter 11

	Pre-Test / Post-Test Questions


Fill-in-the-blanks:

1. Stored sequences of keyboard actions and commands are also known as _____.

2. Word’s _____ _____ enables you to create the stored sequences from question 1 without knowing anything about VBA.

3. Word provides the ___ key as a panic button to interrupt or halt a macro’s execution before it finishes processing.

4. The _____ _____ _____ allows you to edit the stored sequences mentioned in question 1.

5. Word’s environment is very flexible and easily _____.

6. Upon installing Microsoft Word, the Menu bar and toolbars are set up in a _____ configuration.

7. In Word, you can create new _____ _____ that run stored sequences of instructions.

8. To place a command on the menu bar in Word, you _____ a command from the Commands list box in the Customize dialog box to the menu bar.

9. The Standard toolbar gives you single-click access to over _____ commands in Word.

10. Removing buttons you do not often use (from a toolbar) and replacing them with frequently used commands and features can improve your _____.

Multiple choice:

11. VBA stands for

a. Virtual Binary Assembly

b. Visual Basic from Applications

c. Visual Basic for Applications

d. none of the above

12. A macro can be associated with which of the following?

a. A toolbar button

b. A keyboard sequence

c. A mouse button 

d. Both A and B

e. A, B and C

13. Running a macro is said to be similar to:

a. Playing a tape

b. Playing a game

c. Writing a letter

d. None of the above

14. To display the Macros dialog box, you can use which keyboard shortcut?

a. Alt+F6

b. Alt+F7

c. Alt+F8

d. Alt+F9

15. What menu selection should you make to launch the Visual Basic Editor?

a. File, Macro, Macros

b. Edit, Macro, Macros

c. Insert, Macro, Macros

d. Tools, Macro, Macros

16. To display the Visual Basic Editor quickly, which keyboard shortcut can you type?

a. Alt+F9

b. Alt+F10

c. Alt+F11

d. Alt+F12

17. You can customize Word’s menus by:

a. adding commands

b. removing commands

c. arranging commands

d. all of the above

18. The Customize dialog box contains how many tabs?

a. 2

b. 3

c. 4

d. 5

19. To rename a command in a menu, open the Customize dialog box and do which of the following?

a. right-click on the menu item

b. double-click on the menu item

c. select the menu item and press F2

d. none of the above

20. Which tab of the Customize dialog box allows you to create a new toolbar?

a. Toolbars

b. Commands

c. Options

d. New

True / False:

21.  Many word processing tasks are not repetitive.

22.  Using a macro, you can execute a sequence of instructions by simply clicking a button, pressing a key combination, or selecting a name from a list box.

23. The Visual Basic Editor is a utility that lets you create, edit, and print macros.

24. You must record over a macro in order to change one or more steps.

25. You can modify existing interface elements in Word, such as the Menu bar.

26.  You cannot modify the existing menus in Word.

27.  Microsoft Office 2003 does not use personalized menus and toolbars.

28.  The Menu bar in Word is actually a toolbar.

29.  A toolbar can be floated in its own window, complete with a Title bar and Close button.

30. There are three docking areas for a toolbar in Word.

	Chapter 11

	Pre-Test / Post-Test Answer Key


Fill in the blanks

1. macros (11.1: WD 488)

2. Macro Recorder (11.1.1: WD 488)

3. ESC (11.1.2: WD 493)

4. Visual Basic Editor (11.2: WD 494)

5. customized (11.3: WD 501)

6. default (11.3: WD 501)

7. menu commands (11.3.1: WD 502)

8. drag (11.3.1: WD 502)

9. 20 (11.3.2: WD 506)

10. productivity (11.3.3: WD 508)

Multiple choice:


11. C (11.1.1: WD 488)

12. D (11.1.1: WD 489)

13. A (11.1.2: WD 491)

14. C (11.1.2: WD 492)

15. D (11.2.1: WD 494)

16. C (11.2.3: WD 500)

17. D (11.3.1: WD 502)

18. B (11.3.1: WD 502)

19. A (11.3.1: WD 504)

20. A (11.3.4: WD 510)

True / False:

21. F (11.1: WD 488)

22. T (11.1: WD 488)

23. T (11.2: WD 494)

24. F (11.2.2: WD 498)

25. T (11.3: WD 501)

26. F (11.3.1: WD 502)

27. F (11.3.1: WD 502)

28. T (11.3.2: WD 506)

29. T (11.3.2: WD 506)

30. F (11.3.2: WD 506)
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	Developing Applications in Word


Overview

Chapter 11 covers two distinct areas.  The first is the use and management of macros in Word.  Sections 11.1 and 11.2 cover the recording, executing and deleting of macros as well as editing the resulting code and printing the code.  The second portion of the chapter provides instruction on the advanced use of the toolbars in Word.  These toolbars can be modified (buttons added, removed, changed), relocated (floating or docked), or new toolbars created by the user.

Tips and Teaching Strategies

Recording a macro and then printing and viewing the resulting VBA code is a nice introduction to the world of programming.  The resulting code (should be!) error-free, well formatted and fully functional (depending on what tasks are recorded).  The only down side to this approach is that the code is not commented automatically.  Consider assigning a project which has the students recording a macro, providing comments in the source code, and then printing the source code.

Section 11.1 – Creating Macros
Section 11.1 covers the basics of working with macros in Word.  Specifically, this section provides instruction on the creation, execution, and deletion of recorded macros.

Section 11.1.1 – Recording a Macro

Concept:
Recording a macro in Word

Method:
To record a Word macro, choose the Macro menu item from the Tools menu, and then choose the Record New Macro menu item.  The Record Macro dialog box will appear.  Enter a name for your macro in the Macro name text area, a description for the macro in the Description text area.  To assign the macro to a keyboard shortcut, click the Keyboard button in the Assign macro to area.

In the Customize Keyboard dialog box that appears, ensure that the insertion point is located in the Press new shortcut key text box.  Once it is, press the keyboard shortcut for this new macro, and click the Assign button followed by the Close button.

The Stop Recording toolbar will appear, allowing you to control the macro.  Once it appears, the macro is being recorded, so all subsequent keystrokes are added to the macro.  Use the toolbar’s buttons to pause/resume and stop recording the macro.  Once the macro recording has been stopped, it will be added to the Normal template, unless you configured the macro to be saved elsewhere.

Notes:
To begin creating a new macro, you can also double-click on the REC toggle in the status bar.  Doing so will display the Record Macro dialog box.

Section 11.1.2 – Playing Back a Macro

Concept:
Running an existing macro

Method:
To execute an existing macro, choose the Macro menu item from the Tools menu, and then choose the Macros menu item.  The Macros dialog box will be displayed.  Once the dialog is visible, select the macro to execute and click the Run button.

Notes:
You can display the Macros dialog box by typing the keyboard shortcut Alt+F8 rather than using the menu system.

Section 11.1.3 – Deleting a Macro

Concept:
Deleting a macro

Method:
To remove a macro from the template or application, choose the Macro menu item from the Tools menu, and then choose the Macros menu item.  The Macros dialog box will open, where you can select the desired existing macro from the list in the center of the dialog box.  Once selected, click the Delete button to remove the selected Macro.  Word will confirm the deletion.  Once the macro is deleted you can click the Close button to dismiss the dialog box.

Notes:
None.

Section 11.2 – Editing Macros

Section 11.2 covers the fundamentals of editing macros in a Microsoft Word document.  The section provides instruction on launching the Visual Basic Editor (to edit the macro’s code), saving a modified macro, and printing a macro’s code.

Section 11.2.1 – Launching the Visual Basic Editor

Concept:
Displaying the Visual Basic Editor 

Method:
By displaying the Visual Basic Editor, you can edit the Visual Basic code that defines a macro.  To display the editor, choose the Macro menu item from the Tool menu, and then choose the Macros menu item.  Select a macro to edit from the Macros dialog box that appears and click the Edit button.  The Visual Basic Editor will appear, allowing you to edit the selected macro.

Notes:
You can open the Visual Basic Editor directly by typing the keyboard shortcut Alt+F11.

Section 11.2.2 – Modifying a Recorded Macro

Concept:
Modifying macro code

Method:
To modify a macro’s code, open the Visual Basic Editor as described in Section 11.2.1.  Then, edit the code as desired using the editor.  To save your changes, choose either:

· The Save Normal menu item from the File menu on the editor’s menu bar – saves the current macro (user defined or global)

· The Close and Return menu item from the File menu on the editor’s menu bar – saves the global macro and returns the user to Word

Notes:
None.

Section 11.2.3 – Printing Your Macros

Concept:
Printing the current macro

Method:
To print the current macro, open the Visual Basic Editor and choose the Print menu item from the File menu.  Then, select the Current module option button to print the open module and click the OK button to print the macro’s code.

Notes:
None.

Section 11.3 – Customizing Menus and Toolbars

Section 11.3 details working with the Word toolbars for further customization of Word’s working environment.  Included in this section are instructions for modifying the menu bar, various display manipulations of toolbars, modifying the buttons present on toolbars, and creating a new toolbar from scratch.

Section 11.3.1 – Modifying the Menu Bar

Concept:
Modifying the menu bar in Word

Method:
To modify the menu bar in Word, choose the Customize menu item from the Tools menu.  Then, click the Commands tab in the Customize dialog box that appears.

Next, select a menu category from the Categories list box.  Select and drag a command from the Commands list box to its desired location on the menu bar.  Release the command and it will be placed on the selected menu bar.  Click the Close button to complete the operation and to dismiss the Customize dialog box.

Notes:
While the Customize dialog box is displayed, you can edit any menu item by right-clicking on it and using the menu that appears to edit the menu item’s name, remove it from the menu, change the item’s icon, etc.

Section 11.3.2 – Manipulating Toolbars

Concept:
Floating a toolbar

Method:
To float a toolbar in Word, drag it away from its docked area by using the move handle that appears at the far left-hand side of a docked toolbar.

Notes:
None.

Concept:
Docking a floating toolbar

Method:
To dock a floating toolbar, drag the toolbar bar its Title bar to the top, bottom, left or right wall in the application window.

Notes:
None.

Concept:
Toggling the display of a toolbar

Method:
To toggle the display of a toolbar, choose the Toolbars menu item from the View menu, and then choose the desired toolbar to toggle from the menu that appears.

Notes:
You can also right-click on a displayed toolbar and select the desired toolbar to toggle as well.

Section 11.3.3 – Customizing a Toolbar

Concept:
Adding buttons to a toolbar

Method:
To add additional buttons to any Word toolbar, open the Customize dialog box and click the Commands table.  Then, drag a button from the Commands list to a toolbar to add it to the selected toolbar.  Click the Close button on the Customize dialog box to complete the changes.

Notes:
None.

Concept:
Deleting buttons from a toolbar

Method:
To delete one or more buttons from a toolbar, open the Customize dialog box and then drag the selected button away from the toolbar to delete it.  Click the Close button on the Customize dialog box to complete the changes.

Notes:
None.

Concept:
Changing the order of buttons on a toolbar

Method:
To change the order of buttons on a toolbar, first open the Customize dialog box.  Then, drag a selected button within its toolbar to change its placement on the toolbar.  Click the Close button on the Customize dialog box to complete the changes. 

Notes:
None.

Section 11.3.4 – Creating a New Toolbar

Concept:
Creating a new toolbar

Method:
To create a new toolbar in Word, open the Customize dialog box and click the Toolbars tab.  Then, click the New button and provide a name for the new toolbar in the Toolbar name: text area and click the OK button.  The new toolbar will be created and displayed in the application window.

You can add buttons to the new toolbar just created by following the steps in Section 11.3.3 above.  Click the Close button on the Customize dialog box to complete the operation.

Notes:
None.
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	Chapter 11

	Extra-Curricular Activities


Activity 1 Create a new macro named Copyright that could be used to add a copyright line to your documents.  This information should contain a copyright statement, the current year, your name, and any other information you’d like to add.  While creating the macro, be sure to apply at least five formatting characteristics, including paragraph indenting, font size, font style, color, and so on.  Be sure to save the macro since you’ll need it in Activity #2. Print the macro that you created.

Activity 2 Now you’re ready to edit the Copyright macro you created in Activity #1. Use the Visual Basic Editor to remove any unnecessary steps, or add instructions that could not be recorded in Word. Take this opportunity to change the formatting as well.  Print out the revised macro when you’re done.

Activity 3 Create a new toolbar within Word, name it MyToolbar, and add the toolbar to the Normal template.  Add the following items to your new toolbar:
· the Next Misspelling command button (available in the Tools category of commands);
· the Visual Basic Editor command button (available in the Tools category of commands);
· the Open Hyperlink command button (available in the Web category of commands).
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Chapter 11 
Answers to End-of-Chapter Review Questions

Short Answer

1.
To dock a toolbar, drag it by its Title bar to the top, bottom, left, or right wall in the application window. 

2.
To delete a macro, select the macro in the Macros dialog box and then click the Delete command button. 

3.
To rename an existing toolbar button, choose Tools, Customize and then right-click the button you want to rename. Choose Name from the right-click menu and then type the new label in the attached text box.

4.
By inserting a concise description of your macro in the Description text box, it will be easier to identify your macro in the future.

5.
VBA is a programming language, shared by Office 2000 applications, for writing macros.

6.
A macro contains stored instructions for automating repetitive tasks and improving the accuracy with which they’re performed.

7.
Several reasons exist for editing macros. For example, you may have chosen the wrong command during the recording process, or you may need to change data that you entered.

8.
To launch the Visual Basic Editor, choose Tools, Macro, Macros and then click the Edit command button after selecting a macro to edit. You can also launch the Editor directly by pressing [image: image1.png]
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. 

9.
To assign a macro to a toolbar button, choose Tools, Customize from Word’s Menu bar and then click the Commands tab. Select Macros in the Categories list box and then drag the macro to the desired toolbar. Rename, or otherwise modify, the button as desired.

10.
To display or hide an existing toolbar, right-click a displayed toolbar and then make a toolbar selection from the right-click menu.

True/False

	1.
	True
	6.
	False

	2.
	True
	7.
	False

	3.
	False
	8.
	True

	4.
	True
	9.
	True

	5.
	False
	10.
	False


Multiple-Choice

	1.
	c
	6.
	b

	2.
	b
	7.
	a

	3.
	d
	8.
	a

	4.
	c
	9.
	b

	5.
	d
	10.
	a
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