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	Chapter 12

	Pre-Test / Post-Test Questions


Fill-in-the-blanks:

1. The _____ _____ VBA Editor window is used to display a hierarchical list of the object, code modules, user forms, and other files associated with a VBA project.

2. The _____ VBA Editor window is used to modify the environment or test code before placing it into a procedure.

3.  Stepping through a macro’s code line-by-line is also known as _____.

4. The point where execution may stop (on user command) when debugging is known as the _____.

5. A _____ is a group of objects.

6. A _____ is an action you can perform with an object.

7. A _____ procedure performs a calculation and then returns or assigns a value to a variable.

8. The _____ function can be used to display a built-in form for the purpose of gathering simple pieces of information from the user.

9. In Visual Basic for Applications, a _____ expression is used to evaluate a question about a property or a variable’s value.

10. A _____ _____ form field is used to collect textual or numerical information from a user in a document.

Multiple choice:

11. Which VBA Editor window is used to display, write, edit, debug, and print macros and other procedures?

a. Project Explorer

b. Properties

c. Immediate

d. Code

12. Which VBA Editor window is used to display the current procedure’s variables, along with their values and data types?

a. Watch

b. Locals

c. Immediate

d. Code

13. Each program statement must follow:

a. a specific statement

b. a specific syntax

c. a programming manual

d. none of the above

14. Some types of programming errors are logic errors or:

a. calculation errors

b. format errors

c. conditional errors

d. none of the above

15. Sub is an example of which of the following?

a. method

b. argument

c. keyword

d. collection

16. Comments in VBA programming code are preceded by which character?

a. an asterisk (*)

b. a comma (,)

c. a percent sign (%)

d. an apostrophe (‘)

17. Which character is used to separate an object from its property or method (in VBA programming code)?

a. a period (.)

b. a comma (,)

c. a percent sign (%)

d. an apostrophe (‘)

18. What is the default data type?

a. byte

b. integer

c. variant

d. currency

19. Which value is returned if a user clicks the Abort button from a message box created with the MsgBox function?

a. 3

b. 4

c. 5

d. 6

20. Which type of form field allows a user to select from a group of choices?

a. text box form field

b. check box form field

c. drop-down form field

d. none of the above

True / False:

21.  All of the major Office 2003 applications expose their objects to VBA.

22.  The Watch VBA Editor window is used to display the values of watch expressions that you’ve set in order to observe the behavior of variables or debug program statements.

23.  A VBA project file is the container that stores all of the code modules, user forms, or custom dialog boxes, and other objects related to a single document.

24.  VBA does tolerate spelling errors when you type code.

25.  Use the F9 key to step through a macro’s programming code, line-by-line.

26.  A collection is most easily defined as a group of text.

27.  A property is related to the characteristic of an object.

28.  Commas are used to separate function arguments in VBA programming.

29.  In Visual Basic for applications, a conditional expression is used to evaluate a question about a property or a variable’s value.

30.  If a Word form is protected, other users can fill in the form but not make changes to the form.

	Chapter 12

	Pre-Test / Post-Test Answer Key


Fill-in-the-blanks

1. Project Explorer (12.1.1: WD 528)

2. Immediate (12.1.1: WD 528)

3. debugging (12.1.2: WD 533)

4. breakpoint (12.1.3: WD 536)

5. collection (12.2: WD 539)

6. method (12.2: WD 540)

7. Function (12.2.1: WD 541)

8. InputBox (12.3.1: WD 546)

9. conditional (12.3.2: WD 555)

10. text box (12.4.1: WD 559)

Multiple choice:


11. D (12.1.1: WD 528)

12. B (12.1.1: WD 528)

13. B (12.1.2: WD 533)

14. A (12.1.2: WD 534)

15. C (12.2: WD 538)

16. D (12.2: WD 539)

17. A (12.2: WD 540)

18. C (12.3.2: WD 540)

19. A (12.3.2: WD 543)

20. C (12.4.1: WD 559)

True / False:

21. T (12.1.1: WD 528)

22. T (12.1.1: WD 528)

23. T (12.1.1: WD 530)

24. F (12.1.2: WD 533)

25. F (12.1.2: WD 534)

26. F (12.2: WD 539)

27. T (12.2: WD 540)

28. T (12.3.1: WD 550)

29. T (12.3.3: WD 555)

30. T (12.4.2: WD 561)
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	Exploring Visual Basic for Applications


Overview

Chapter 12 provides an introductory overview for working with Visual Basic for Applications inside of Microsoft Office Word 2003.  The chapter covers such topics as working with the VBA programming environment, familiarization of the various VBA Editor windows, debugging code, setting breakpoints, and creating new procedures.  The chapter also introduces two VBA functions (INPUTBOX and MSGBOX), and making decisions with the IF/THEN/ELSE statement.  Chapter 12 concludes with an introduction to creation and management of forms within a Word document.

Tips and Teaching Strategies

Programming to many novice users can be quite a painful and taxing ordeal.  Consider carefully how much programming you plan to introduce to your students.  While “recording” of macros and viewing the resulting code seems rather simple, coding from scratch can be quite time consuming and daunting to many students.  If you choose to introduce this level of coding, consider giving your students code fragments to enter and then possibly execute via a form button.  This type of introduction is likely to be more manageable and ties these two topics from this chapter together nicely.

Section 12.1 – Introducing the VBA Environment

Section 12.1 provides and overview of working with the VBA Environment.  The first subsection covers the display of the various windows associated with the environment (VBA Editor).  The section also covers debugging macro code by executing code one line at a time (stepping) and by using breakpoints in the code.

Section 12.1.1 – Touring the Visual Basic Editor

Concept:
Viewing the Project Explorer and Properties Window in the VBA Editor

Method:
To view the Project Explorer and Properties Window in the VBA Editor, open the editor for a given macro (see Section 11.2.1).  Then, you can open the Project Explorer (if it is not already shown) by choosing the Project Explorer menu item from the View menu or by pressing Ctrl+R.  The Properties Window can be display by choosing the Properties Window menu item from the View menu or by typing the F4 key.

Notes:
None.

Concept:
Viewing the Code and Immediate Windows in the VBA Editor

Method:
To view the Code and Immediate Windows in the VBA Editor, first open the editor.  Then, you can display the Code Window by choosing the Code menu item from the View menu or by typing F7.  The Immediate Window is displayed by choosing the Immediate Window menu item from the View menu or by typing Ctrl+G. 

Notes:
None.

Concept:
Viewing the Locals and Watch Windows in the VBA Editor

Method:
To view the Locals and Watch Windows in the VBA Editor, first open the editor.  Then, you can display the Locals Window by choosing the Locals Window menu item from the View menu.  The Watch Windows is displayed by choosing the Watch Window menu item from the View menu.

Notes:
None.

Section 12.1.2 – Stepping Through a Macro

Concept:
Stepping line by line through a macro’s execution

Method:
To better understand or debug a macro you can step through its execution line by line.  To accomplish this, open the Macros dialog box and select the desired macro.  Then, click the Step Into button.  The VBA Editor will appear and the first line of the macro’s code will appear highlighted with a yellow background.

To execute only the first line of code, press the F8 button.  The highlighted code will be executed and the execution will then pause.  You can continue to press the F8 button to step line-at-a-time through the remainder of the macro, or you can press the Reset button to terminate stepping through the macro.

Notes:
None.

Section 12.1.3 – Using Breakpoints

Concept:
Setting a breakpoint in macro code

Method:
To set a breakpoint in macro code and have the execution of the macro stop at the selected point (the breakpoint), open the macro in the VBA Editor, and select the desired line of code.  Then, choose the Toggle Breakpoint menu item from the Debug menu, click in the Margin Indicator bar to the left of the desired line of code or press F9.  The selected line will be tagged with a breakpoint (small red stop sign icon in the Margin Indicator bar).

Then, begin running the macro (hit the F5 key).  The macro will pause prior to executing a line with a breakpoint and will highlight the line containing the breakpoint with a yellow background.  You can execute the highlighted line by hitting the F8 key.

Notes:
None.

Section 12.2 – Understanding the VBA Language

Section 12.2 walks the students through the process of creating a new procedure in the VBA Editor.  The section is quite detailed and lengthy, so only the process of creating the new procedure (via the dialog box) is summarized here.

Section 12.2.1 – Writing VBA Code

Concept:
Creating/Inserting a procedure

Method:
To create a procedure in the VBA Editor, open the editor as discussed previously.  Then, choose the Procedure menu item from the Insert menu.  The Add Procedure dialog box will be displayed.  Type the name of the new procedure in the Name text area, and select a procedure type from the Type area.  Additional characteristics can be set at this time as well.  Click the OK button to dismiss the Add Procedure dialog box and enter the code for the procedure in the Code window. 

Notes:
None.

Section 12.3 – Interacting with the User
This section covers two useful VB programming functions, the InputBox and MsgBox functions.  They are used to query the user for information and to display a message to the user, respectively.  Additionally, Section 12.3 covers the use of the IF/THEN/ELSE programming statement, used to evaluate a property or a variable’s value.

Section 12.3.1 – Using the InputBox Function

Concept:
The InputBox function

Method:
The InputBox function can be used to display a dialog box requesting information from the user.  The syntax of the function is:  returnVar = InputBox(prompt, title, default), where:

· returnVar is the name of the variable that will contain the value provided by the user in the dialog box

· prompt is a string informing the user what to input

· title is an optional string which will be displayed in the title bar of the dialog box

· default is an optional string which is the default value for the user (added to the text area presented in the dialog box)

Notes:
None.

Section 12.3.2 – Using the MsgBox Function

Concept:
The MsgBox Function

Method:
The MsgBox function can be used to display a built-in form for the purpose of providing information to the user.  The syntax of the function is:  MSGBOX “prompt” or of the form
returnVal = MsgBox(prompt, buttons, title), where:

· prompt is the message to display to the user

· buttons is one or more button optional constants (not all of which are listed in the text)

· title is an optional string which will be displayed in the title bar of the dialog box

Notes:
None.

Section 12.3.3 – Making Decisions with If…Then…Else

Concept:
Using the IF/THEN/ELSE statement

Method:
The IF/THEN/ELSE statement in VBA programming allows for decision support within the language.  The statement takes the form of:

If condition Then


statements to execute

Else


statements to execute

End If

Notes:
None.

Section 12.4 – Creating a Custom Form
Section 12.4 covers the fundamentals of creating and using a form in a Word document.  This section instructs the students on inserting a form field into a document, protecting the form from further changes by other users, and modifying a field’s options and settings.

Section 12.4.1 – Placing Controls on a Form

Concept:
Adding a form control to a document

Method:
To add a form control to a document, you must first display the Forms toolbar.  This is achieved by right-clicking on any toolbar’s button and then choosing the Forms menu item from the menu that appears.

Next, position the insertion point where the control will be added to the document and then click on a control from the Forms toolbar.  The desired control will be added at the selected position.

Notes:
None.

Section 12.4.2 – Protecting a Form

Concept:
Protecting a form from changes

Method:
To protect a form from changes by other users, choose the Protect Document menu item from the Tools menu.  Then, select the Forms option button and click the OK button.

Notes:
You can also click the Protect Form button on the Forms toolbar.

Section 12.4.3 – Changing Form Field Options

Concept:
Changing a form field’s options

Method:
To change the options for a specified form field, double-click the field or select the field and click the Form Field Options button on the Forms toolbar.  Then use the Field Options dialog box to modify the settings and characteristics of the desired field.

Notes:
None.
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	Chapter 12

	Extra-Curricular Activities


Activity 1 Use Word to create a new document that will be used to collect movie reviews. Open the Visual Basic Editor and use the InputBox function to collect such information as the title of the move. Use checkboxes or a drop-down list to allow users to rate how well they enjoyed the movie that they saw. Be sure to not use a default value and to provide a title for your input box. 

Activity 2 Open the document you created in Activity #1 to analyze the results obtained from the user.  If users reply that they did not enjoy the movie, display a message box using MsgBox function that asks why they didn’t like the film.  If users reply that they did enjoy the movie, display a message box thanking the user for their participation in the survey.

Activity 3 Use Word to create a new document that will be used as a registration form for a guest lecture or other special event that you would be interested in organizing. Include fields for the registration information (such as name, address, and telephone number), payment info (credit card or cash), and number of attendees.  Use at least one pull-down list in the document (such as for the person’s title or a listing of U.S. states).  Print the form and submit it to your instructor for grading.
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Chapter 12 
Answers to End-of-Chapter Review Questions

Short Answer

1.
If…Then statements are used when you need to have the program perform different steps based on how a condition evaluates. The program evaluates the conditional expression and then branches to the appropriate instructions based on its outcome.

2.
Design time describes the process of creating a program or adding ActiveX controls to a document. Run time describes the time when the code is actually executed. 

3.
The Properties window displays the properties and settings for the selected item. The window is divided into two columns. The leftmost column displays the property name and the rightmost column displays its current value or setting.

4.
An object is a reference to an element, such as a document, while a method is an action performed by that object, such as activate, open, or close.

5.
An object is a reference to an element, such as a document, while the property is a characteristic or attribute of that object, such as its name or color.

6.
Opening, saving, maximizing, and closing are all examples of a Word event.

7.
The MsgBox function returns a value that indicates which command button the user clicked.

8.
If a variable’s data type is not declared, then VBA defines the variable as a variant data type, which consumes more memory and is less efficient than other data types.

9.
A variable is a temporary storage location for data. Variables do not always contain the same values and can be changed during the operation of a procedure. Constants are values that are static and do not change.

10.
The InputBox function is used to display a built-in form for the purpose of gathering simple pieces of information from the user.
True/False

	1.
	True
	6.
	False

	2.
	False
	7.
	True

	3.
	True
	8.
	True

	4.
	True
	9.
	True

	5.
	False
	10.
	False


Multiple-Choice

	1.
	b
	6.
	b

	2.
	b
	7.
	a

	3.
	a
	8.
	b

	4.
	a
	9.
	d

	5.
	c
	10.
	b
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