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	Chapter 10
	Pre-Test/Post-Test Questions


Multiple choice:

1. An example of lookup tables includes those used in which of the following?

a. sales commissions

b. currency exchange

c. web searches

d. both a and b

2. Which Excel function returns a value from a specified row and column intersection?

a. INDEX

b. MATCH

c. HLOOKUP

d. VLOOKUP

3. Once a worksheet is protected, you can use which key to quickly cycle through all of the unprotected cells for user input?

a. Enter

b. Ctrl

c. Alt

d. Tab

4. What is the name of the template that Excel allows you to create which can contain the default settings for new workbooks and worksheets?

a. AutoTemplates

b. AutoWorkbooks

c. AutoStartTemplates

d. none of the above

5. A query is which of the following?

a. a question you ask of a data source

b. a response from a question that you ask of a data source

c. the source of data which can have questions asked of it

d. none of the above

6. Excel 2003’s Lookup and Reference functions enable you to find and _______________ data from a table or list.

a.
search

b.
modify

c.
delete

d.
extract

7. One of the most secure methods for transmitting workbooks via electronic mail or file transfer is to _______________.

a.
send file as attachments

b.
use data encryption

c.
password protect the workbook

d.
zip the file before sending

8. The simplest method for sharing information between two documents is to insert a static representation of the original data into the  receiving document.  This is termed:

a.
packaging

b.
pasting

c.
linking

d.
embedding

9. Which Excel function searches the left-most column of a specified array for a given value and then returns a value in the same row?

a. INDEX

b. MATCH

c. VLOOKUP

d. HLOOKUP

10. When entering a password in Excel, the characters of the password will be displayed as which character?

a. $

b. %

c. *

d. @

11. Which of the following is not a valid text converter for exporting Excel data?

a. ASCII

b. CVS

c. dBase

d. SYLK

12. Which wizard can be used to convert a text file into a worksheet?

a. Text Conversion Wizard

b. Text Upload Wizard

c. Text Manipulation Wizard

d. Text Import Wizard

13. When selecting items to import from a web query (or XML file), you designate the desired items by clicking on what icon?

a. a circle 

b. an arrow

c. a plus (or cross) sign

d. a minus sign

14. An Excel password can contain up to _______________ characters.

a.
32

b.
64

c.
128

d.
255 

15. _______________ data involves inserting a source document into a destination document.

a.
embedding

b.
linking

c.
pasting

d.
packaging 

16. Excel 2003 introduces the new XML _______________ task pane to help you map worksheet cells to data elements stored in an XML document file.

a.
structure

b.
schema

c.
source

d.
properties

True / False:

17.  A lookup formula typically contains one or more built-in functions and several arguments.

18. The base passwords combine upper- and lower-case characters with numbers and symbols.

19. You can enter descriptive property information for each workbook file, providing additional information about the author and contents of the workbook.

20. You can not open or import data into Excel which is stored in database files.

21. XML stands for Exchangeable Markup Language.

22. The most popular lookup function is HLookup.

23. Excel 2003 default settings cannot be modified.

24. You can not hide and protect individual tabs of worksheets, charts, and modules within Excel.

25. When working in read-only mode, users can save changes back to the original workbook file.

26. Excel’s built-in templates appear on the General tab of the Templates dialog box.

27. There are four distinct methods for sharing data between the Office applications.

28. XML is a meta-markup language for Web-based documents that describes structured data in a standard way.

29. Excel 2003’s Web Queries allow you to retrieve data stored in HTML and XML documents.

30. Excel 2003 passwords are case sensitive.

Fill-in-the-blanks:

31. The _____ _____ leads you step-by-step through constructing a lookup formula that returns the cell contents of a row and column intersection.

32. By default, Excel locks each and every cell in a worksheet, but does not activate sheet _____.

33. A _____ is a word or name that is easy for you to remember, but difficult for others to guess.

34. Characters used to separate data fields in text files are known as _____.

35. Microsoft Excel’s _____ _____ allow you to retrieve data stored in HTML and XML documents.

36. Excel’s protection features work on _____ levels within the program.

37. A _____ is a special type of workbook file that you can use as a model from which to create new workbooks.

38. The _____ template is accessed when you choose the Insert, Worksheet command from inside a workbook.

39. In _______________ you establish a dynamic link between the source and destination documents.

40. Excel 2003 automatically creates an XML list on _______________ of the workbook.

	Chapter 10

	Pre-Test/Post-Test Answer Key


Multiple choice:


1. D (10.1:10-3)

2. A (10.1.2:10-9)

3. D (10.2.1:10-17)

4. A (10.3.1:10-29)

5. A (10.5.1:10-58)

6. D (10.1.2:10-10)

7. B (10.2.4:10-30)

8. B (10.4.5:10-62)

9. C (10.1.2:10-9)

10. C (10.2.2:10-25)

11. C (10.4.1:10-38)

12. D (10.4.3:10-43)

13. B (10.5.4:10-74)

14. D (10.2.2:10-25)

15. A (10.4.5:10-62)

16. C (10.5.5:10-88)

True / False:

17. T (10.1:10-3)

18. T (10.2.2:10-23)

19. T (10.2.3:10-26)

20. F (10.4.2:10-41)

21. F (10.5.1:10-58)

22. F (10.1.2:10-10)

23. F (10.3.3:10-44)

24. F (10.2:10-16)

25. F (10.2.2:10-23)

26. F (10.3:10-28)

27. F (10.4.5:10-51)

28. T (10.5.3:10-71)

29. T (10.5.1:10-69)

30. T (10.2.2:10-25)

Fill-in-the-blanks

31. Lookup Wizard (10.1:10-3)

32. protection (10.2:10-16)

33. password (10.2.2:10-23)

34. delimiters (10.4.3:10-44)

35. Web queries (10.5.1:10-58)

36. Three (file, workbook and sheet) (10.2:10-16)

37. Template (10.3:10-28)

38. Sheet.xlt (10.3.1:10-29)

39. Linking (10.4.5:10-62)

40. Sheet1 (10.5.6:10-93)
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	Chapter 10
	Automating and Extending Excel


Overview

Chapter 10 covers the fundamentals for automating and extending the functionality of Excel.  The chapter opens with a discussion of the use of lookup tables, the Lookup Wizard add-in, and functions that support lookups.  The chapter then proceeds to include instruction on the protection mechanisms which are present in Excel.  This includes cell, worksheet, and workbook protections, password-protection, and digital signature for a workbook.  Chapter 10 additionally provides coverage of the use and creation of templates for Excel, importing and exporting data from structured data files and external sources, as well as creating web queries and the creation of interactive web-based spreadsheet files.

Tips and Teaching Strategies

Use caution when covering the material dealing with external data file formats.  Most especially are the references and work with XML.  It should not be surprising that novice computer students are not familiar with structured data formats and may be easily befuddled with the use of XML.

Note that the students may respond well to the use of templates, especially if they understand how templates can save them time in the future.  It is not uncommon to see commercial businesses use templates to standardize the look and feel of spreadsheets throughout their organizations.  Consider generating a template to share with the students for your school; and then having them complete an assignment using the provided template.

Section 10.1 – Using Lookup Tables

Section 10.1 introduces the use of lookup tables through two different means.  First, the use of the Lookup Wizard Add-in is presented as an easy interface to using the lookup functions.  Later in the section, four of Excel’s functions are covered for performing the same task.  These functions include INDEX, MATCH, HLOOKUP, and VLOOKUP.

Section 10.1.1 – Creating a Lookup Function

Concept:
Using the Lookup Wizard Add-in to create a lookup function

Method:
To begin to use the Lookup Wizard Add-in, choose the Add-ins… menu item from the Tools menu.  Then, select the Lookup Wizard item and click the OK button.  When the wizard appears, provide the range of cells to search, on the first page of the wizard.  Click the Next > button to progress to the second page, where you select the row and column which contains the value to find.  Click the Next > button to move to the third page.

Next, specify what form the result will take on (the formula’s result, or the formula’s result and other parameters), and then click the Next > button.  Finally, specify the location the result will be placed in (multiple locations may need to be provided if you selected the verbose output option).

Notes:
The Lookup Add-in may not be installed by default.  Thus, when you attempt to load/run the add-in for the first time, you may need the installation disk to complete the installation of the Lookup Add-in.
Section 10.1.2 – Using Lookup and Reference Functions

Concept:
Lookup and Reference Functions

Method:
Excel provides several functions for use in reference and lookup tasks.  Included in this section are the following:

· Index function – returns a value from a specified row and column intersection.  Syntax: =index(array, row_num, col_num), where array is the range of cells to search in, and row_num and col_num are the row and column in the specified array from which the value is returned.  The value at the intersection of row_num and col_num in the array is returned by this function.

· Match function – returns the position of a value in a specified array.  Syntax: =match(lookup_value, lookup_array, match_type), where lookup_value is the value to locate and lookup_array is the range of cells which may contain the value sought.  If match does not find the specified value, a #N/A is returned.
· HLookup function – Searches the top row of a specified array for a given value and then returns a value in the same column.             Syntax: =hlookup(lookup_value, table_array, row_index_num, range_lookup), where lookup_value is the value to find in the top row, table_array is the range of cells to search, row_index_num is the row number from which the returned value is obtained, and range_lookup is a logical (Boolean) value which indicates if an approximate match is acceptable.

· VLookup function – Searches the left-most column of a specified array for a given value and then returns a value in the same row.  Syntax: =vlookup(lookup_value, table_array, col_index_num, range_lookup), where lookup_value is the value to locate in the left-most column, table_array is the range of cells to search, col_index is the column number from which the returned value is obtained, and the range_lookup is a logical (Boolean) value which indicates if an approximate match is acceptable.

Notes:
None.

Section 10.2 – Protecting Your Work

Section 10.2 discusses the various methods for protecting the contents of a worksheet and workbook.  Protection methods can take place at the cell, sheet, and workbook levels.  In addition to the protection instructions provided, this section also covers how to supplement the workbook’s properties, thereby providing additional information about the author and contents of the workbook.

Section 10.2.1 – Protecting Cells, Worksheets and Workbooks
Concept:
Protecting cells
Method:
To protect cells, you can lock the cell (preventing it from being moved, deleted, changed, or resized) or hide the formula a cell contains (preventing it from being viewed in the formula bar when the cell is selected).  To lock a cell or hide a formula, select the desired cell(s) and choose the Cells… menu item from the Format menu.

Then, click the Protection tab on the Format Cells dialog box that appears.  Finally, select the Locked and/or Hidden check boxes and click the OK button.
Notes:
Locking and/or hiding does not take effect unless the Excel worksheet is protected as well.  Details on protecting a worksheet are found below.

Concept:
Toggling worksheet protection

Method:
To toggle worksheet protection, choose the Protection menu item from the Tools menu, and then choose the Protect Sheet menu item from the menu that appears.  To unprotect a worksheet, perform the same steps but select the Unprotect Sheet menu item in the last step.

When protecting a worksheet, the Protect Sheet dialog box will appear, allowing for the selection of various forms of protection.  Since we can’t list them all here, we’ll mention that you select the desired protection options for the sheet and click the OK button, enabling the protection.  In addition, a password can be given at the time of protection which prohibits unauthorized unprotecting of the sheet (other users will need to know the password to unprotect the sheet). 

Notes:
None.

Concept:
Hiding and unhiding a worksheet

Method:
To hide a worksheet, select the desired sheet by clicking on its tab at the bottom of the sheet.  Then, choose the Sheet menu item from the Format menu, and choose the Hide menu item from the menu that appears.

To unhide a worksheet, choose the Sheet menu item from the Format menu and then choose the Unhide menu item from the menu that appears.  The Unhide dialog box will appear.  Select the desired sheets you wish to unhide form the Unhide sheet: list and click the OK button.

Notes:
None.

Concept:
Toggling workbook protection

Method:
To toggle the protection of an Excel workbook, choose the Protection menu item from the Tools menu, and then choose the Protect Workbook menu item from the menu that appears.  To unprotect a workbook, perform the same steps but select the Unprotect Workbook menu item in the last step.

When protecting a workbook, the Protect Workbook dialog box will appear, allowing the selection of the various forms of protection (structure and windows), as well as specifying a password for the protection.  Select the desired protection options and provide a password in the Password (optional): text area and click the OK button to protect the current workbook.

Notes:
None.

Section 10.2.2 – Password-Protecting a Workbook

Concept:
Setting save options for password protecting a workbook

Method:
While saving a workbook, you can set various protection options.  To do so, choose the Save As menu item from the File menu and then click the Tools button in the Save As dialog box’s toolbar area.  In the menu that will appear, choose the General Options menu item.  A smaller dialog box, titled Save Options, will appear.

In the Save Options dialog box, you can provide passwords for opening a workbook, modifying a workbook, and selecting a Read-only recommendation option.  The latter option will display a warning message requesting that the user not modify the workbook.  Click the OK button to complete the protections and to dismiss the Save Options dialog box.  You can then specify a file name and location in the Save As dialog box, and click the OK button to save the file.

Notes:
None.

Section 10.2.3 – Setting Workbook Properties

Concept:
Setting workbook properties

Method:
Workbook properties can be set, adding descriptive information about the author and contents of each workbook.  To take advantage of this feature, choose the Properties menu item from the File menu.

The Properties dialog box will appear and allows a user to click through the various tabs of the dialog box.  Each tab (General, Summary, Statistics, Contents, Custom) can hold additional information of the workbook, much of which can be edited by the author of the workbook.  Click the OK button to set the properties and to dismiss the dialog box.

Notes:
None.

Section 10.2.4 – Managing Security and Privacy

Concept:
To encrypt and digitally sign a workbook

Method:
In today’s world it is more important to protect digital data.  Excel 2003 allows you to encrypt the workbook.  To encrypt the workbook, select the Options menu choice from the Tools menu and then click the Security tab.
Next enter the password and then click on Digital Signature Command button to attach a certificate to the workbook.
Notes:
To enable digital signature, one must purchase a digital certificate from an accredited authority.
Section 10.3 – Working with Templates

This section provides instruction on working with Excel templates.  Templates can be used to apply a common style and appearance to new worksheets and workbooks.  Section 10.3 details how to create and apply a new template, editing an existing template, and how to apply a template to an existing workbook.

Section 10.3.1 – Creating and Applying Templates

Concept:
Creating a new Excel template

Method:
To create a new template for Excel, first create a workbook which will be saved as a template.  Then, choose the Save As menu item from the File menu.  In the Save As dialog box that appears, select the Template (*.xlt) item from the Save as type drop-down list box.  

Then, use the Save in list box to locate and select the Templates directory from the Office installation area (generally in C:\Windows\Application Data\Microsoft\Templates).  Finally, provide a name for the template in the File name: text area and click the Save button to save the file as a template.

Notes:
None.

Concept:
Applying a template to a new workbook

Method:
To apply a template to a new Excel workbook that you are creating, choose the New menu item from the File menu.  Then, click the General Templates link, located under the New from template area.  The Templates dialog box will appear, allowing you to select a template to apply to the new workbook.  Templates created by users will appear in the window displayed when the General tab is clicked.  Select a template to apply by double-clicking on the icon for the desired template and the template will be applied to the new workbook.

Notes:
None.

Concept:
Applying a template to an existing workbook

Method:
To apply a template to an existing workbook, right-click on one of the workbook’s existing sheet tabs and choose the Insert menu item from the menu that appears.  Then, in the Insert dialog box that appears, select the desired template by double-clicking on the template’s icon.

Notes:
When applying a template to an existing workbook, all worksheets from the template will be added to the workbook.  Those worksheets previously present in the workbook will remain untouched by the application of the template.

Section 10.3.2 – Editing Templates

Concept:
Editing an existing template

Method:
You can edit an existing template to change its appearance.  To do so, open the template file (likely located in the Templates directory mentioned above).  A template file can be edited as any other workbook can be.  When your edits have been completed, save the template file by choosing the Save menu item from the File menu.  The template file will be overwritten with your corrections.

Notes:
None.

Section 10.3.3 – Modify Excel’s Default Settings

Concept:
Modify Default Settings

Method:
Excel 2003 default settings can be changed by choosing the Options menu choice from the Tools menu.  Next click on the General tab and select the desired options.

Notes:
None.

Section 10.4 – Importing and Exporting Data

Section 10.4 covers the fundamentals of importing and exporting data to/from Excel via the use of other data formats (non-Excel files).  These include importing data from other spreadsheet file formats, databases, and text files.  The use of file type converters and the Text Import Wizard are given attention, as well as reviewing how to share data with other Office System 2003 applications.

Section 10.4.1 – Saving and Exporting Structured Data

Concept:
Saving and Exporting Excel data in another format

Method:
Data from Excel worksheets can be saved (and thus exported) in a variety of other formats.  These formats include formats for other spreadsheets (older versions of Excel, Lotus 1-2-3 and Quattro Pro), databases (Access, dBase, SQL) and text formats (ASCII, CSV, DIF, and SYLK).  Once in another format, the data can be read by other programs.

To export worksheet data, choose the Save As menu item from the File menu.  Then, in the Save As dialog box that appears, select a file format from the Save As type drop-down list (the format of the data you are exporting) and choose a location and file name in the Save in drop-down list and File name: text areas, respectively.  Finally, click the Save button to export the worksheet.  Only the currently displayed worksheet will be exported to the file.

Notes:
None.

Section 10.4.2 – Importing Data Using File Type Converters

Concept:
Importing data in other formats

Method:
Data files of non-Excel formats can be imported (depending on the format of the data) into Excel.  To accomplish this, you open the desired file as you would any other file (choose the Open menu item from the File menu).

In the Open dialog box that appears, select the location of the desired file from the Look in: drop-down list box, and select the format of the file from the Files of type drop-down list box.  Then, locate the desired file in the file listing area (center of the dialog box) and double-click on the desired file name to open the file.  If the format is compatible with Excel, the data will be imported and a worksheet created containing the imported data.

Notes:
None.

Section 10.4.3 – Importing Data Using the Text Import Wizard

Concept:
Importing textual data via the Text Import Wizard

Method:
To import textual data from files, you can open the data files and use the Text Import Wizard to assist you.  Choose the Open menu item from the File menu and select the location of the desired file from the Look in drop-down list box.  Then, select the Text Files item in the Files of type drop-down list box.  Next, double-click on the desired file name in the list area.  The Text Import Wizard will appear, presenting a three page dialog sequence asking a variety of questions about the format of the data and how it is to be imported.  Briefly, the pages ask the following questions:

· Page 1 – which line of the input file does the data start on and if the data is delimited (is the data separated by specific characters)?
· Page 2 – what delimiters are between the data and what the data will look like when imported (what columns does it call in)?
· Page 3 – what data formats should be implemented for each identified column from step 2?
Finally, click the Finish button on the Text Import Wizard to complete the import process.

Notes:
None.

Section 10.4.4 – Importing Data From External Sources

Concept:
Importing data from external data sources

Method:
Data can be imported directly from an external data source (such as a running database via a query) into Excel.  To import data in this manner, create a new workbook which will contain the data.  Position the insertion point at a cell location which will be the upper left corner of the target data range (where the data will be placed).

Choose the Import External Data menu item from the Data menu, and then choose the Import Data menu item from the menu that appears.  Next, in the Select Data Source dialog box that appears, select the data location by using the Look in: drop-down list.  Data locations can include Access data files and existing connections to data sources (generally listed in the My Data Sources item in the Look in: drop-down list).

Once the data source is located, double-click on its label or icon to establish a connection to it.  The Import Data dialog box will then appear, prompting you to define the location of where the data is to be copied to.  The location of the insertion point is placed in the Existing worksheet text area, but can be overridden or a new worksheet can be created instead.  Finally, click the OK button to the selected location.

Properties for updating the data can be set by using the External Data Range Properties dialog box.  To display the dialog box choose the Import External Data menu item from the Data menu, and then choose the Data Range Properties menu item from the resulting menu.  The dialog box provides a plethora of options and settings, too numerous to mention here.

Notes:
None.

Section 10.4.5 – Sharing Data in Microsoft Office 2003
Concept:
To share data using Office Clipboard
Method:
You can share data among different Office 2003 applications by using the Office 2003 clipboard.  To do so, select the desired source data and click the Copy button on the Standard toolbar in the source application.  Then, open the destination application and either create a new file (document, spreadsheet, etc.) or open an existing one.  Position the insertion point in the destination file and click the Paste button to paste the copied data.  Office 2003 Clipboard can store up to 24 different items that can be pasted to other applications.
Notes:
You can use the Paste Special menu item (from the Edit menu) to paste the copied data as a linked or embedded object.

Section 10.5 – Working with HTML and XML
Section 10.5 covers several methods for importing and exporting data from (and to) the Web.  These methods include importing data from HTML and XML documents, copying data from web pages (via a browser), publishing interactive web-based spreadsheets; as well as exporting and import data to/from XML documents.

Section 10.5.1 – Importing Web Data

Concept:
Creating a web query

Method:
To create a web query (allowing you to import data found on web sites into an Excel worksheet), choose the Import External Data menu item from the Data menu, and then choose the New Web Query menu item.  The New Web Query dialog box will appear.  Enter the URL address of the desired web page you wish to query in the Address text box and click the Go button to load the web page.

Next, click the arrows next to each table that you wish to import to Excel.  Note that more than one table can be imported at a time.  Save the query for later use by clicking on the Save Query button and entering a name for the query in the Save Query dialog box that appears.  Finally, click the Import button to import the data from the selected tables.

Notes:
None.

Concept:
To run a web query

Method:
To run an existing web query, choose the Import External Data menu item from the Data menu, and then choose the Import Data menu item.  Next, select the desired query to execute and click the Open command button.  If prompted, specify the worksheet location for storing the results and any parameters required to run the query.

Notes:
None.

Section 10.5.2 – Round-Tripping with HTML
Concept:
Copying Web-based HTML data into an Excel worksheet

Method:
Data can be copied from a web browser directly into Excel.  To accomplish this, select the desired data in the web browser and press Ctrl+C top copy the data to the Windows clipboard.  Next, open the desired destination worksheet in Excel and position the insertion point at the top left-hand cell of the target range where the data will be pasted to.  Press Ctrl+V (or click the Paste button on the Standard toolbar) to paste the data into the selected location.  The Paste Options button can be used to refine the formatting applied to the pasted data.

Notes:
None.

Concept:
Publishing an interactive Web page for HTML round-tripping

Method:
To publish an Excel worksheet as an interactive web page, select the worksheet to publish and choose the Save as Web Page menu item from the File menu.  Next, click the Publish button in the Save as dialog box that has appeared.  The Publish as Web Page dialog box will then appear, allowing you to select the interactivity by selecting the Add interactivity with check box in the Viewing options area.  Additionally, select the Spreadsheet functionality item from the drop-down list box and enter a web page name in the File name text area.  Finally, click the Publish button to create the interactive web page.

Notes:
None.

Section 10.5.3 – Sharing Data Using XML

Concept:
Saving a workbook as an XML-SS document

Method:
You can save your Excel workbook as an XML document, allowing you to use it as an external data source for a wide variety of other applications.  To save a workbook as an XML document, choose the Save As menu item from the File menu.

Then, select the XML Spreadsheet item in the Save as type drop-down list box on the Save As dialog box that has appeared.  In addition, select a location for the XML file from the Save in drop-down list box and provide a file name for the XML file in the File name text area.  Finally, click the Save button and the worksheet will be saved as a new XML file in the location specified.

Notes:
None.

Section 10.5.4 – Importing XML Data

Concept:
Opening an XML document
Method:
To open an existing XML document with Excel, choose the Open menu item from the File menu.  Then, select the XML Files item from the Files of type drop-down list box.  Select a location to search for the desired file by using the Look in: drop-down list box and double-click on the desired file name in the list area to open the XML Spreadsheet file.

Notes:
None.

Concept:
Creating an XML web query

Method:
Creating an XML web query is very similar to creating an HTML query.  To begin, choose the Import External Data menu item from the Data menu, and then choose the New Web Query menu item from the menu that appears.  The New Web Query dialog box will appear.  Next, enter the URL address of the existing XML document, and click the Go button.

The XML document will load and be displayed in the large area in the dialog box.  Click the arrow icon to designate the entire XML file to be opened (there likely are no other arrows to click), and then click the Import button.  The Import Data dialog box will appear, asking you to choose the location the data will be copied to (a cell reference or to a new worksheet).  Make the appropriate selection and click the OK button to import the data from the XML file.

Notes:
None
Section 10.5.5 – Using the XML Source Task Pane

Concept:
Display XML Source Task Pane

Method:
To display XML Source Task Pane, choose XML menu option from the Data menu and then choose XML Source.

Alternatively, the Task Pane can also be displayed by choosing the Task Pane option from the View menu and then selecting XML Source.

Notes:
None.

Section 10.5.6 – Mapping and Manipulating XML Elements

Concept:
To map XML elements to cells in a worksheet

Method:
To access external data in XML documents, first you must define the XML maps.  To map XML elements, choose XML option from the Data menu and then select XML Source.  Next you must select the elements in the XML Source Task Pane and then drag elements to the worksheet location.
Notes:
None.
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Chapter 10 
Answers to End-Of-Chapter Review Questions

Short Answer

1.
How does a lookup table differ in structure from a worksheet list? A lookup table differs from a worksheet list in that it typically provides both row and column labels, as opposed to a single field header row.

2.
Name the five tabs displayed for workbook properties. The following tabs appear in the workbook Properties dialog box: General, Summary, Statistics, Contents, and Custom.
3.
What are the three levels of protection for your work in Excel 2003? File-level protection limits access to authorized users.  Workbook-level protection allows the user to protect and hide individual sheets. Sheet-level protection allows the user to lock cells and objects.

4.
Provide an example of a good workbook password. Why is it good? Any password is acceptable; although passwords like "Locked3&Out" are more difficult to guess since they contain upper/lower case, symbols, and numbers.
5.
How do templates save you time and ensure design consistency? Templates contain common text, formatting, formulas, styles, objects, and macros that can be used as a model for all new workbooks. Many people can access the same workbook templates to ensure consistency from user to user.

6.
Name two types of files that Excel 2003 can use to create XML maps.  An XML document (.XML) file and an XML Schema (.XSD) file.

7.
What is the primary difference between opening and importing an external data file? Opening an external data file uses the File ( Open command and initiates one of Excel 2003’s converter programs to import the data. Importing an external data file uses the Data ( Import External Data command. This command is typically used to create a data connection for querying an external data source. Rather than performing a one-time conversion of the data, a data connection allows the imported data to be refreshed at any time from the original source.
8.
Name the three methods for sharing data between Office applications. Pasting data refers to inserting static text into a destination document. Linking data refers to establishing a link between a source and a destination document. Embedding data refers to inserting a source document into a destination document.

9.
How would you import a specific portion of an HTML document into a worksheet? Using the Clipboard or drag and drop methods, you can copy and paste selections of an HTML document. You can also use the Data ( Import External Data ( New Web Query command to display the New Web Query dialog box. Then, click on an arrow icon ([image: image1.png]


) that appears beside the desired HTML table. 

10.
Explain the difference between an XML document and an XML Spreadsheet file? An XML document is simply a text file that contains an arrangement of elements, attributes, data content, and processing instructions following the Extensible Markup Language (XML) specification. An XML Spreadsheet (XML-SS) file is a special type of XML document that is based on a Microsoft schema for preserving a workbook’s structure, formatting, and data. You can open and save an XML-SS file in Microsoft Office Excel 2003 as you would any workbook. An XML document must be converted or imported into a workbook—typically ending up in an XML list.

True/False

	1.
	T
	6.
	F

	2.
	F
	7.
	T

	3.
	T
	8.
	T

	4.
	F
	9.
	F

	5.
	T
	10.
	T


Multiple-Choice

	1.
	a
	6.
	c

	2.
	c
	7.
	d

	3.
	c
	8.
	b

	4.
	c
	9.
	a

	5.
	b
	10.
	a
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