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	Chapter 12
	Pre-Test/Post-Test Questions


Multiple choice:

1. Which window in the Visual Basic Editor displays the characteristics and settings for a selected object?

a. Project Explorer Window

b. Properties Window

c. Watch Window

d. Immediate Window

2. Which of the following is known as the location where code will specifically stop executing, allowing you to examine a procedure’s variables, or to begin stepping line by line?

a. breakpoint

b. stop point

c. debug point

d. none of the above

3. Comments in VBA are preceded by which character?

a. a space

b. a comma

c. a single quote

d. an asterisk

4. When you need to evaluate a condition for more than one or two results, use which of the following design structures?

a. Select…Case

b. If…Then

c. For…Next

d. Do…While

5. ActiveX controls were formerly known as what?

a. AX controls

b. OLE controls

c. Active controls

d. both b and c

6. Using the _______________ control, you can display values from a worksheet list and then place the selected value into a linked cell.

a. dialog box

b. control box

c. drop box

d. radio button

e. fill box

7. A _______________ add-in is an add-in architecture that allows you to create a single solution to run on all Office 2003 applications.

a. XML

b. VBF

c. ActiveX

d. COM

e. DCOM

8. Which window in the Visual Basic Editor displays the values of expressions that you’ve set in order to observe the behavior of variables or debug program statements?

a. Project Explorer Window

b. Properties Window

c. Watch Window

d. Immediate Window

9. Which keyboard shortcut will display the Editing window of the Visual Basic Editor?

a. Alt+F10

b. Alt+F11

c. Alt+F12

d. Alt+Ctrl

10. The keyword in VBA which precedes the definition of a variable or constant is:

a. var

b. const

c. dim

d. none of the above

11. The Control Toolbox is a special kind of what object?

a. dialog box

b. form

c. worksheet

d. toolbar

12. When moving a control object around a worksheet, which key (when pressed) aligns the control to the cell grid on the worksheet?

a. Ctrl

b. F5

c. Alt

d. Right Shift

13. One of the best methods for learning VBA is to examine the code generated by the _______________.

a.
debugger

b.
compiler

c.
macro recorder

d.
VB Script

e.
none of the above

True / False:

14.  VB Script stands for Visual Basic Scripting Edition.

15. You can step through a macro’s code line by line to determine what it is doing.

16. A variable is a characteristic of an object.

17. The UPPERCASE function converts a text string to uppercase in VBA.

18. Besides responding to events, linking controls and cells provides a new level of interactivity for your workbook applications.

19.  In the Visual Basic Editor, you can use ActiveX controls to create custom user forms for your workbook applications.

20. VBA is an acronym for Visual Basic for Accounting.

21. The end of a macro procedure is marked by the End Proc keyword.

22. The default variant data type allows you to store any kind of data (in VBA).

23. The MSGBOX function is used to display a built-in form, complete with command buttons and icons, for the purpose of providing information to the user.

24. To have an add-in loaded automatically each time Excel is launched, place the add-in in the StartXL folder.

25. You do not need to create or save a project file—each project is saved automatically when you save its associated workbook.

26. Each object has its own unique collection of properties and methods.  Method has to do with a characteristic of an object, while Property has to do with the actions an object can perform.

Fill-in-the-blanks:

27. The object-oriented programming model used in VBA is called _____-driven programming.

28. A VBA _____ _____ is the container that stores all of the code modules, user forms, or custom dialog boxes, and other objects related to a single workbook.

29. A _____ is a word in VBA which is reserved for a specific purpose.

30. _____ structures allow you to test conditions for processing and to perform looping operations.

31. In addition to executing macro procedures, you can use ActiveX controls to display and _____ information.

32. _______________ controls are prebuilt, reusable software components.

33. A _______________ is a temporary storage location in your computer’s memory where you can collect data from the user or retain results from calculations.
34. An _____ can be initiated by the user, as in clicking a button, or by the software program, as in performing an automated or scheduled backup.

35. Each programming statement in VBA must follow a specific _____, or programming rule.

36. A _____ is most easily defined as a group of objects.

37. The _____ function is used to display a built-in form for the purpose of gathering simple pieces of information from the user.

38. A _____ add-in is a new add-in architecture that allows you to create a single solution to run on all Office System 2003 applications.

39. The _______________ loop structure executes a set number of times.

The _______________ Toolbox is a special toolbar containing ActiveX controls, such as list boxes and command buttons, that you may add to your worksheets.

	Chapter 12

	Pre-Test/Post-Test Answer Key


Multiple choice:


1. B (12.1.1:EX 786)

2. A (12.1.3:EX 793)

3. C (12.2:EX 795)

4. A (12.3.2:EX 812)

5. B (12.5:EX 827)

6. B (12.5.2:EX 831)

7. D (12.5.3:EX 834)

8. C (12.1.1:EX 786)

9. B (12.1.3:EX 793)

10. C (12.2.2:EX 803)

11. D (12.5.1:EX 827)

12. C (12.5.1:EX 827)

13. C (12.1.2: EX 791)

True / False:

14. T (12.1:EX 786)

15. T (12.1.2:EX 791)

16. F (12.2:EX 795)

17. F (12.3.1:EX 808)

18. T (12.5.2:EX 831)

19. T (12.5.1:EX 827)

20. F (12.1:EX 786)

21. F (12.2:EX 795)

22. T (12.2:EX 795)

23. T (12.4.1:EX 821)

24. F (12.5.3:EX 834)

25. T (12.1.1:EX 786)

26. F (12.2:EX 795)

Fill-in-the-blanks

27. event (12.1:EX 786)

28. project file (12.1.1:EX 786)

29. keyword (12.2:EX 795)

30. Control (12.3:EX 808)

31. collect (12.5.2:EX 831)

32. ActiveX (12.5:EX 827)

33. variable (12.2:EX 795)
34. event (12.1:EX 786)

35. syntax (12.1.2:EX 791)

36. collection (12.2:EX 795)

37. INPUTBOX (12.4.2:EX 824)

38. COM (12.5.3:EX 834)

39. For…Next (12.3.4:EX 818)

40. Control (12.5.1:EX 827)

Resource II

Microsoft Office Excel 2003
Instructor’s Manual
Chapter 12

	Chapter 12
	Introducing Visual Basic for Applications


Overview

Chapter 12 provides an introductory overview for working with Visual Basic for Applications (VBA) inside of Microsoft Excel.  The chapter covers such topics as working with the VBA programming environment, familiarization of the various VBA Editor windows, debugging code, setting breakpoints, and creating new procedures.  The chapter also introduces two VBA functions (INPUTBOX and MSGBOX), and a variety of control statements (such as IF/THEN/ELSE, SWTICH/CASE, FOR/NEXT, and DO/WHILE).  Chapter 12 concludes with an introduction to adding interactivity to an Excel workbook via controls and deploy the workbook as an application.
Tips and Teaching Strategies

Programming, to many novice users, can be quite a painful and taxing ordeal.  Consider carefully how much programming you plan to introduce to your students.  While “recording” of macros and viewing the resulting code seems rather simple, coding from scratch can be quite time consuming and daunting to many students.  If you choose to introduce this level of coding, consider giving your students code fragments to enter and then possibly execute via a form button.  This type of introduction is likely to be more manageable and ties these two topics from this chapter together nicely.

Section 12.1 – Introducing the VBA Environment

Section 12.1 provides and overview of working with the VBA Environment.  The first subsection covers the display of the various windows associated with the environment (VBA Editor).  The section also covers debugging macro code by executing code one line at a time (stepping) and by using breakpoints in the code.

Section 12.1.1 – Touring the Visual Basic Editor

Concept:
Viewing the Project Explorer and Properties Window in the VBA Editor

Method:
To view the Project Explorer and Properties Window in the VBA Editor, open the editor for a given macro (see Section 11.4.4).  Then, you can open the Project Explorer (if it is not already shown) by choosing the Project Explorer menu item from the View menu or by pressing Ctrl+R.  The Properties Window can be displayed by choosing the Properties Window menu item from the View menu or by typing the F4 key.

Notes:
None.

Concept:
Viewing the Code and Immediate Windows in the VBA Editor

Method:
To view the Code and Immediate Windows in the VBA Editor, first open the editor.  Then, you can display the Code Window by choosing the Code menu item from the View menu or by typing F7.  The Immediate Window is displayed by choosing the Immediate Window menu item from the View menu or by typing Ctrl+G. 

Notes:
None.

Concept:
Viewing the Locals and Watch Windows in the VBA Editor

Method:
To view the Locals and Watch Windows in the VBA Editor, first open the editor.  Then, you can display the Locals Window by choosing the Locals Window menu item from the View menu.  The Watch Windows is displayed by choosing the Watch Window menu item from the View menu.

Notes:
None.

Section 12.1.2 – Stepping Through a Macro

Concept:
Stepping line by line through a macro’s execution

Method:
To better understand or debug a macro you can step through its execution line-by-line.  To accomplish this, open the Macros dialog box and select the desired macro.  Then, click the Step Into button.  The VBA Editor will appear and the first line of the macro’s code will appear highlighted with a yellow background.

To execute only the first line of code, press the F8 button.  The highlighted code will be executed and the execution will then pause.  You can continue to press the F8 button to step line-at-a-time through the remainder of the macro, or you can press the Reset button to terminate stepping through the macro.

Notes:
None.

Section 12.1.3 – Using Breakpoints

Concept:
Setting a breakpoint in macro code

Method:
To set a breakpoint in macro code and have the execution of the macro stop at the selected point (the breakpoint), open the macro in the VBA Editor, and select the desired line of code.  Then, choose the Toggle Breakpoint menu item from the Debug menu, click in the Margin Indicator bar to the left of the desired line of code or press F9.  The selected line will be tagged with a breakpoint (small red stop sign icon in the Margin Indicator bar).

Then, begin running the macro (hit the F5 key).  The macro will pause prior to executing a line with a breakpoint and will highlight the line containing the breakpoint with a yellow background.  You can execute the highlighted line by hitting the F8 key.

Notes:
None.

Section 12.2 – Understanding the VBA Language

Section 12.2 walks the students through the process of creating a new procedure in the VBA Editor and accessing and using objects in the Visual Basic model.

Section 12.2.1 – Writing VBA Code

Concept:
Creating/Inserting a procedure

Method:
To create a procedure in the VBA Editor, open the editor as discussed previously.  Then, choose the Procedure menu item from the Insert menu.  The Add Procedure dialog box will be displayed.  Type the name of the new procedure in the Name text area, and select a procedure type from the Type area.  Additional characteristics can be set at this time as well.  Click the OK button to dismiss the Add Procedure dialog box and enter the code for the procedure in the Code window. 

Notes:
None.

Section 12.2.2 – Working with Excel Objects

Concept:
Referencing Excel’s objects

Method:
Section 12.2.2 provides an example of referencing cells from within Visual Basic code.  A summary of the material presented is as follows:

· A range of cells can be referenced as RANGE(cellRef) or RANGE(cellRef:cellRef), where cellRef is a reference to a cell in a worksheet.  Visual Basic also allows for the range references to occur without the RANGE keyword, if the cell references are surrounded by square brackets.

· A value of a cell can be set by using the code: [celRef].Value = val, where cellRef a reference to a single cell, and val is the value to set the referenced cell to.

·  A cell or range of cells can be selected by using the code: [cellRef].Select, where cellRef is a reference to a single cell or a range of cells.

Notes:
None.

Section 12.3 – Controlling Your Procedures

This section deals with VBA programming statements which will help control procedures more effectively.  Section 12.3 covers the use of decision making via the IF/THEN and SELECT/CASE statements, as well as looping control with the FOR/NEXT and DO/WHILE statements. 

Section 12.3.1 – Making Decisions with IF…THEN

Concept:
Using the IF/THEN/ELSE statement

Method:
The IF/THEN/ELSE statement in VBA programming allows for decision support within the language.  The statement takes the form of:

If condition Then


statements to execute

Else


statements to execute

End If

Notes:
None.

Section 12.3.2 – Making Decisions with SELECT…CASE

Concept:
Using the SELECT/CASE statement

Method:
The SELECT/CASE statement is VBA programming branches your procedure based on a value or condition.  The statement takes the form of:

Select Case expression
Case value1

statements to execute

Case value2


statements to execute

Case Else


statements to execute

End Select

Notes:
None.

Section 12.3.3 – Looping with FOR…NEXT

Concept:
Using the FOR…NEXT statement

Method:
A FOR…NEXT loop is used to execute a series of instructions a specified number of times.  The statement takes the form of:

For counter = start To end

statements to execute

Next counter
The statement can also take the form of:

For Each item In collection
statements to execute

Next item
Notes:
None.

Section 12.3.4 – Looping with DO…WHILE

Concept:
Using the DO…WHILE statement

Method:
The DO…WHILE statement executes a series of instructions each time a condition evaluates to true.  The statement takes the form of:

Do While condition
statements to execute

Loop

Notes:
None.

Section 12.4 – Interacting with the User
This section covers two useful VB programming functions, the INPUTBOX and MSGBOX functions.  They are used to query the user for information and to display a message to the user, respectively.

Section 12.4.1 – Using the MSGBOX Function

Concept:
The MSGBOX Function

Method:
The MSGBOX function can be used to display a built-in form for the purpose of providing information to the user.  The syntax of the function is:  MSGBOX “prompt” or of the form
returnVal = MSGBOX(prompt, buttons, title), where:

· prompt is the message to display to the user

· buttons is one or more button optional constants (not all of which are listed in the text)

· title is an optional string which will be displayed in the title bar of the dialog box

Notes:
None.

Section 12.4.2 – Using the INPUTBOX Function

Concept:
The INPUTBOX function

Method:
The INPUTBOX function can be used to display a dialog box requesting information from the user.  The syntax of the function is:  returnVar = INPUTBOX(prompt, title, default), where:

· returnVar is the name of the variable that will contain the value provided by the user in the dialog box

· prompt is a string informing the user what to input

· title is an optional string which will be displayed in the title bar of the dialog box

· default is an optional string which is the default value for the user (added to the text area presented in the dialog box)

Notes:
None.

Section 12.5 – Working with Controls
Section 12.5 concludes this textbook with topics related to using controls to add interactivity to Excel worksheets.  This section provides instruction on adding ActiveX controls to a worksheet, and linking controls to worksheet cells.  The Section ends with a discussion of deploying an Excel workbook as either an Excel Add-in or a COM Add-in.

Section 12.5.1 – Placing a Command Button on the Worksheet

Concept:
Adding an ActiveX control to a worksheet

Method:
To add an ActiveX control to a worksheet in Excel, display the Control Toolbox by right-clicking on a toolbar and choosing the Control Toolbox menu item from the menu that appears.

Next, click the desired control from the toolbox which has been displayed, and drag the mouse (not the control) over the the location on the worksheet where you’d like the control to be placed.  Use the ALT key to drag the control, aligning it with the worksheet’s grid (if desired).  Release the mouse and the control will be placed on the worksheet in the selected location.

You can move and resize a control as you would a graphic object in Excel, such as a chart object.  Right-click on the control and select the View Code menu item to display the Visual Basic Editor, so that you can edit the procedure which is called when an action takes place on the control (e.g. a button is clicked, or a check box is selected).

Notes:
None.

Section 12.5.2 – Linking Controls and Cells

Concept:
Setting properties of controls

Method:
Section 12.5.2 uses the notion of setting the properties of ActiveX controls on worksheets to link a control and a cell.  To set the properties of a control, right-click on the desired control and select the Properties menu item from the menu that appears.

In the text, Section 12.5.2 links a combo box control to a cell by providing a range of cells to use as the combo box’s list (set the ListFillRange property for the control) and places the selected list item from the control in a specified cell (by setting the LinkedCell property).

Notes:
None.

Section 12.5.3 – Deploying Your Applications

Concept:
Creating an Excel custom add-in program

Method:
To create an Excel custom add-in program to deploy your workbook as an application.  In actuality, you are making available your macro procedures and functions, while hiding the worksheets and macros.  To create the add-in, save the workbook as a Microsoft Excel Add-In (*.xla) file type.

Notes:
None
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Chapter 12 
Answers to End-Of-Chapter Review Questions

Short Answer

1.
Describe the relationship between an object and a property. An object is a reference to an element, such as a worksheet, while a property is a characteristic or attribute of that object, such as its name or color.
2.
Describe the relationship between an object and a method. An object is a reference to an element, such as a worksheet, while a method is an action performed by that object, such as activate, open, or close.
3.
Provide an example of an event in Excel 2003. Opening, saving, maximizing, and closing are all examples of an Excel event.
4.
What information is provided in the Properties window? The Properties window displays the properties and settings for the selected item. The window is divided into two columns. The leftmost column displays the property name and the rightmost column displays its current value or setting.
5.
Explain the difference between design time and run time. Design time describes the process of creating a program or adding ActiveX controls to a worksheet. Run time describes the time when the code is actually executed. 
6.
Explain the difference between a variable and a constant. A variable is a temporary storage location for data. Variables do not always contain the same values and can be changed during the operation of a procedure. Constants are values that are static and do not change.
7.
Why should you specify a variable’s data type in its declaration? If a variable’s data type is not declared, then VBA defines the variable as a variant data type, which consumes more memory and is less efficient than other data types.
8.
When do you use a branching control structure? Branching control structures are used when you need to have the program perform different steps based on how a condition evaluates. The program evaluates the conditional expression and then branches to the appropriate instructions based on its outcome.
9.
When do you use a looping control structure? Looping control structures are used when you need to run the same lines of code repeatedly. For example, to automatically assign a number to each record in a list, the procedure needs to process each record and apply the same code to increment a number.
10.
What does the value returned by the MsgBox function represent? The MsgBox function returns a value that indicates which command button the user clicked.
True/False

	1.
	T
	6.
	T

	2.
	T
	7.
	T

	3.
	F
	8.
	F

	4.
	F
	9.
	F

	5.
	F
	10.
	T


Multiple-Choice

	1.
	a
	6.
	b

	2.
	b
	7.
	a

	3.
	b
	8.
	a

	4.
	c
	9.
	c

	5.
	a
	10.
	d
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