Resource I

Microsoft Access 2003
Pre-Test / Post-Test

	Chapter 8
	Pre Test / Post Test Questions


Fill in the blanks:

1. Tabular datasheets and forms can be _____ in other forms.

2. Use the Form _____ section of a form to display the fields, labels, and other items that provide functionality.

3. A(n) _____ _____ is a control that does not have a source of data.

4. When a bound control is placed on a form, Access typically creates a _____ control that includes both the bound text box and its field label.

5. A section’s _____ _____ refers to the movement of the cursor (insertion point) when the user presses the Tab key.

6. You can use the _____ feature to quickly apply an entire group of formatting commands to a control, a selection of controls, a section, or the entire form.

7. A _____ _____ is a text box that performs a calculation using data stored in the underlying table or query.

8. A _____ _____ _____ is a special type of Web page that lets you work with an Access or SQL Server database through a Web browser.

9. There are _____ wizards that you can use to create the type of page mentioned in question 8.

10. You can create a grouped data access page by using the _____ Wizard.

Multiple choice:

11. A form object is typically divided into how many sections?

a. 1

b. 2

c. 3

d. 4

12. Which of the following controls is used to evaluate and display the results of formula expressions?

a. bound control

b. unbound control

c. calculated control

d. none of the above

13. Which of the following controls has a source of data that is an underlying field in a table or query?

a. field control

b. unbound control

c. calculated control

d. none of the above

14. Which key is used to help select multiple form objects on a form?

a. Ctrl

b. Shift

c. Alt

d. Insert

15. You can press which keystroke sequence to move through a form in reverse tab order?

a. Tab

b. Ctrl+Tab

c. Alt+Tab

d. Shift+Tab

16. Which report section listed below contains the main body of the report and is used to display the field data from a particular record source?

a. Report Footer

b. Report Detail

c. Report Header

d. Group Header

e. Group Footer

17. Which report section listed below appears once at the end of the report and typically displays grand totals and other summary information?

a. Report Footer

b. Report Detail

c. Report Header

d. Group Header

e. Group Footer

18. Which Access feature allows you to format controls based on the outcome of a calculated expression?

a. AutoFormat

b. expression format

c. calculated format

d. conditional formatting

19. What is the maximum number of expressions you can apply when using the feature from question 18?

a. 2

b. 3

c. 4

d. 5

20. When opening a data access page only users with the appropriate ________ ________ are allowed to make a connection to the database.
a. security clearance
b. database permissions
c. web address
d. required clearance
True / False:

21.  The Page Header and Page Footer sections of a form appear only when a form is printed.

22.  You can add fields to a form by dragging the field name from the Toolbox window.

23. Calculated controls are evaluated at runtime when the form is displayed to the user.

24.  When using a main form and a subform, the subform displays multiple records from the “many” side of a one-to-many relationship.

25.  When a control is selected, it is referred to as having contact.

26.  Reports collect data in textboxes.

27.  When attempting to move a report control, the mouse pointer will change its shape to a hand to indicate the mouse is in the correct position to drag the control.

28.  The conditional formatting feature of Access allows you to select a different font for the control to which you are applying the conditional formatting.

29.  Once grouped, you can add subtotal calculations to grouped data in an Access report.

30.  A data access page incorporates the Extensible Markup Language (XML).

	Chapter 8
	Pre Test / Post Test Answer Key


Fill in the blanks

1. embedded (8.1:AC 8-3)

2. Detail (8.1.1:AC 8-4)
3. unbound control (8.1.2:AC 8-10)

4. compound (8.1.3:AC 8-15)

5. tab order (8.2.2:AC 8-35)

6. AutoFormat (8.2.4:AC 8-39)

7. calculated control (8.3.3:AC 8-50)

8. data access page (8.5:AC 8-65)

9. two (8.5.1:AC 8-66)

10. Page (8.5.2:AC 8-70)

Multiple choice:


11. C (8.1.1:AC 8-4)

12. C (8.1.2:AC 8-10)

13. D (8.1.2:AC 8-10)

14. B (8.1.3:AC 8-16)

15. D (8.2.2:AC 8-35)

16. B (8.3.1:AC 8-42)

17. A (8.3.1:AC 8-42)

18. D (8.4.2:AC 8-59)

19. B (8.4.2:AC 8-59)

20. A (8.5.1:AC 8-70)

True / False:

21. T (8.1.1:AC 8-4)

22. F (8.1.3:AC 8-13)

23. T (8.1.4:AC 8-20)

24. T (8.1.5:AC 8-25)

25. F (8.2.2:AC 8-35)

26. F (8.3:AC 8-41)

27. T (8.3.2:AC 8-49)

28. F (8.4.2:AC 8-59)

29. T (8.4.3:AC 8-61)

30. T (8.5:AC 8-65)

Resource II

Microsoft Access 2003
Teaching Materials

	Chapter 8
	Creating Forms, Reports and Pages


Overview

Chapter 8 provides an introduction to the creation and formatting of forms as well as reports in Access.  The chapter also introduces the creation and use of data access pages and grouped data access pages.

Tips and Teaching Strategies

Use caution when covering data access pages.  To use them in a web browser, you must be using Microsoft’s Internet Explorer (version 5.0 or better).  Many students have access to various versions of Internet Explorer since it is commonly installed on their systems, though some do not.  Labs may have older versions of IE or versions of Netscape’s Navigator or other web browsing software which cannot take advantage of the capabilities the data access page provides.

Section 8.1 – Using the Form Design View

Section 8.1 begins the instructional coverage of creating and modifying forms in Access.  The section covers the creation of a new form via the Form Wizard, understanding the difference between bound and unbound controls on a form, inserting, deleting, sizing, and moving form controls, creating calculated controls, and creating a main form which contains a subform.

Section 8.1.1 – Viewing and Modifying a Form

Concept:
Viewing an existing form 

Method:
An existing form can be viewed in Access by clicking on the Forms button on the Object bar in the Database window.  Select the form you wish to open and click the Open button on the Database toolbar to open the form in Form View.

Notes:
None.

Concept:
Creating a form with the Form Wizard

Method:
A new form can be created with the help of the Form Wizard.  To use the wizard, click the Forms button on the Object bar in the Database window.  Double-click the Create form by using wizard icon.

In the Form Wizard dialog box select the table (or query) containing the fields you want included in the form via the Tables/Queries drop-down list, and select the fields to include from the list of Available Fields.  Click the Next > button to move to the second page of the wizard to select the layout style of the form.  On the third page of the wizard select a formatting style for the form.  The final page of the wizard instructs the user to name the form and to view or modify the form.

Notes:
The section also briefly covers the addition and removal of a form’s page header and page footer areas, as well as the selection of individual sections of the form via the Object drop-down list box.

Section 8.1.2 – Understanding Bound and Unbound Controls

Concept:
Bound vs. Unbound controls

Method:
A bound control is one whose source of data is an underlying field in a table or query.  Unbound controls do not have a source of data (for example, descriptive labels or graphic objects, such as lines and boxes).

To determine whether a control is bound or unbound right-click on the object and choose the Properties menu item from the shortcut menu. Select the data tab and select the Control Source property. If the object is bound, the data source it is bound to will be specified in the Control Source property.

Notes:
An easy way to remember the difference between a bound and unbound control is to imagine bound controls as being tied to the data, while unbound controls are free.
Section 8.1.3 – Inserting, Deleting, Sizing and Moving Controls

Concept:
Inserting a control using the Field List window

Method:
To use the Field List window to insert a new control on a form, display the desired form in Design View and drag a field from the Field List window onto the form.  Release the mouse button to drop the field (and an associated text label) onto the form at the position specified.

Notes:
None.

Concept:
Inserting a control using the Toolbox window.

Method:
To use the Toolbox window to insert a new control on a form, display the desired form in Design View.  Click the desired control button in the Toolbox window and click once on the form to place the control.

Notes:
Controls are placed and sized according to their defaults.  They can be resized following the directions below.

Concept:
Deleting a control on a form

Method:
To delete a control on a form, display the desired form in Design View and select the desired control to delete.  Press the Delete key to remove the control from the form.

Notes:
None.

Concept:
Moving and resizing a control on a form

Method:
To move a control on a form, display the form in Design View and select the desired control.  Drag the control’s moving handle to reposition the control.  To resize a control, drag the control’s sizing handles.

Notes:
None.

Section 8.1.4 – Creating a Calculated Control

Concept:
Creating a calculated control for a form

Method:
To add a calculated control to a form, open the desired form in Design View and display the Toolbox window.  Click on the Text Box button on the Toolbox window, and click in the form to place the control.  Type the desired expression in the Text Box, or click on the Build button on the Database toolbar to use the Expression Builder to create the expression for the control.

Notes:
None.

Section 8.1.5 – Creating a Main Form and Subform

Concept:
Creating a form which contains a subform

Method:
A main form with an embedded subform displays data from tables associated in a one-to-many relationship. The main form displays a single record from the “one” side of the relationship, while the subform displays multiple records from the “many” side.
To create a main form and subform using the Form Wizard click the Forms button in the Database window and double-click the Create form by using wizard icon.  Select the “one” table and add the desired fields and select the “many” table and add the desired fields. On the second page of the wizard, specify that the new form will contain a main form and a subform.

The remaining pages of the wizard determine the layout of the subform, the graphical style of the main and subform, and the names of each of the forms created.

Notes:
The creation of a subform and a main form results in two separate form objects in the database.  However, viewing the main form will display the subform embedded in the main form.

Concept:
Creating a subform for an existing main form

Method:
Open the main form in Design View. Click the Subform/Subreport button in the Toolbox window and drag the cross-hair mouse pointer across the form where you want the subform to appear. Right-click the Subform control in the Form window and choose Properties from the shortcut menu. Select the related table in the Source Object text box. View the subform embedded in the main form.
Notes:
None.

Section 8.2 – Customizing a Form

This section concentrates on the customization of a form and its controls.  The section provides coverage of the aligning, sizing and spacing of controls (relative to other controls), changing the tab order of the form, formatting a control using the Formatting toolbar and Properties window, and the AutoFormat command.

Section 8.2.1 – Aligning, Spacing, and Sizing Controls

Concept:
Aligning form objects to each other

Method:
To align form objects to each other, open the desired form in Design View and select two or more objects.  Choose the Align menu item from the Format menu and select an alignment style (left, right, top, bottom, to grid)

Notes:
None.

Concept:
Changing the spacing (horizontal or vertical) between form objects

Method:
To adjust the horizontal or vertical spacing between form objects, open the desired form in Design View and select two or more objects.  Choose the Horizontal Spacing or Vertical Spacing menu items from the Format menu and select an adjustment amount (Make Equal, Increase, or Decrease).

Notes:
None.

Concept:
Changing the height and width of form objects

Method:
To adjust the size of form objects, relative to each other, open the desired form in Design View and select two or more objects. Choose the Size menu item from the Format menu and select a sizing adjustment (To Fit, To Grid, To Tallest, To Shortest, To Widest, or To Narrowest).

Notes:
None.

Section 8.2.2 – Changing the Tab Order

Concept:
Changing the Tab Order of a form
Method:
To change the tab order of a form, open the form in Design View and choose the Tab Order menu item from the View menu.  In the Tab Order dialog box, click the Auto Order button to have Access order the objects for you or drag control names appearing in the Custom Order list box into the desired order and click the OK button.

Notes:
None.

Section 8.2.3 –Formatting Controls on a Form

Concept:
Formatting controls on a form using the Formatting toolbar

Method:
To format a control on a form using the Formatting toolbar, display the desired form in Design View and select the desired control object.  Use the formatting controls on the Formatting toolbar (such as, bold button, italics button, alignment buttons, font and font size buttons) to modify the appearance of the selected control.

Notes:
None.

Concept:
Formatting controls on a form using the Properties window

Method:
To format a control on a form using the Properties window, display the desired form in Design View and right-click on the desired control object.  Choose the Properties menu item from the shortcut menu and select the Format tab.
Select a property to modify by clicking in the text area to the right of the property name.  Use the property’s drop-down list to modify the property setting (if appropriate) or enter a new value in the property’s text area.  

Notes:
The method of editing a property is different for each property type.
Section 8.2.4 –Using the AutoFormat Command

Concept:
Using the AutoFormat command

Method:
You can use the AutoFormat command to change the appearance of a control, a section of a form, or the entire form.  Select the control(s), section, or entire form, and click the AutoFormat button on the Form Design toolbar (or choose the AutoFormat menu item from the Format menu).

In the AutoFormat dialog box, select an AutoFormat style from the list provided and click the OK button to apply the style to the selected items.

Notes:
None.

Section 8.3 – Using the Report Design View

Section 8.3 contains instructional coverage of creating and modifying reports in Access.  The section covers the creation of new reports via the Report Wizard, inserting, deleting, resizing, and moving report controls, and creating calculated controls in a report.

Section 8.3.1 – Viewing and Modifying a Report

Concept:
Viewing an existing report 

Method:
An existing report can be viewed in Access by clicking on the Reports button on the Object bar in the Database window.  Select the report you wish to open and click the Design View, the Print Preview, or the Print Layout button on the Database toolbar to view the report.
Notes:
For reports that must access and summarize a large number of records, Print Preview can take a few moments to display. The Layout Preview view provides a quick preview of the report using sample data.

Concept:
Creating a report with the Report Wizard

Method:
A new report can be created with the help of the Report Wizard.  To use the wizard, click the Reports button on the Object bar in the Database window and double-click the Create report by using wizard icon.

In the Report Wizard dialog box specify the source of the data for the report via the Tables/Queries drop-down list, and the list of fields.  Click the Next > button to move to the second page of the wizard and select the grouping levels for the report.  The third page of the wizard prompts for the sorting order and summary information for the report.

The next two pages of the wizard determine the report’s layout style and graphical style (respectively).  The final page of the wizard prompts for a name for the report and whether to view or modify the report.

Notes:
Report objects are divided into the following sections: Report Header, Report Detail, Report Footer, Group Header and Group Footer (only the Report Detail section is required, the other sections are used where appropriate).
Section 8.3.2 – Manipulating Controls in a Report

Concept:
Inserting a control into a report

Method:
To insert a control into a report, display the desired report in Design View and click the desired control in the Toolbox window and click once in the report to place the control, or drag a field from the Field list onto the report.

Notes:
None.

Concept:
Deleting a control on a report

Method:
To delete a control on a report, display the desired report in Design View. Select the desired control to delete and press the Delete key to remove the control from the report.

Notes:
None.

Concept:
Finalizing the placement and appearance of a control on a report

Method:
To move a control on a report, display the report in Design View, select the desired control and drag the control’s border to reposition the control.  To resize a control drag the control’s sizing handles. To align, space, and size controls in the report Design window, choose the following commands from the Format menu:
· Align to align controls with each other

· Horizontal Spacing to adjust the horizontal spacing between controls

· Vertical Spacing to adjust the vertical spacing between controls

· Size to adjust the height and width of  controls
Notes:
None.

Section 8.3.3 – Creating a Calculated Control

Concept:
Creating a calculated control for a report

Method:
To add a calculated control to a report, open the desired report in Design View and display the Toolbox widow.  Click the Text Box button on the Toolbox window and click in the report to place the control.  Type the desired expression in the Text Box, or click on the Build button on the Database toolbar to use the Expression Builder to create the expression for the control.

Notes:
None.

Section 8.4 – Customizing a Report

Section 8.4 provides instruction on how to format controls in an Access report using the Formatting toolbar and the Properties window for the selected control.  Additionally, this section covers applying conditional formatting, modifying the sorting and grouping properties of a report, as well as adjusting the page, orientation and margin settings for a report.

Section 8.4.1 – Formatting Controls in a Report

Concept:
Formatting controls in a report 

Method:
Select a control or group of controls and specify the desired formatting options using the Formatting toolbar, the Properties window, or the AutoFormat dialog box. 
Notes:
Formatting controls in a report is the same as formatting controls on a form.
Section 8.4.2 –Applying Conditional Formatting

Concept:
Using conditional formatting in a report

Method:
To apply conditional formatting to a control in a report, display the desired report in Design View and select the desired control in the report window.  Choose the Conditional Formatting menu item from the Format menu.

In the Conditional Formatting dialog box, specify a condition and a value for the selected control.  Conditions can be based upon the underlying data field to which the control is bound, or it can be an expression.  Additionally, provide the formatting characteristics to be applied to the control, if the condition or expression is met.  Characteristics include bolding, italics, underlining, font foreground color, and font background color.

Use the Add >> button to add up to three conditions, each with different sets of formatting.  Click the OK button to complete the conditional formatting and apply it to the selected control.

Notes:
None.

Section 8.4.3 – Sorting and Grouping Data

Concept:
Modifying the sorting and grouping properties of report data

Method:
To modify the sorting and grouping characteristics of a report, open the desired report in Design View and click on the Sorting and Grouping button on the toolbar.

To modify a sorting characteristic, select a sort order from the field’s Sort Order column.  To modify a grouping characteristic, select a field name from the Field/Expression column and select a property from the Group Properties area of the dialog box.  Use the drop-down list to modify a property and click the Close button to apply the changes.

Notes:
None.

Section 8.4.4 – Adjusting Page, Orientation and Margin Settings

Concept:
Modifying the page, orientation and margin settings for a report

Method:
To modify the page, orientation and margin settings for a report, select the desired report from the Database window and choose the Page Setup menu item from the File menu.  Use the Page Setup dialog box’s Margins, Page and Columns tabs to view and modify the various page, orientation and margin settings for the report.  Click the OK button when you have completed your changes to apply them to the selected report.

Notes:
None.

Section 8.5 – Creating Data Access Pages

This section covers the basic creation of a simple data access page as well as a grouped data access page.  Both types of pages are created with the help of an Access wizard.

Section 8.5.1 – Creating a Data Access Page Using a Wizard

Concept:
Creating a data access page via the AutoPage Wizard

Method:
Use the AutoPage Wizard to create a data access page, based on a desired table or query.  To start the wizard, click on the Pages button on the Objects bar of the Database Window and click the New button on the Database toolbar.
In the New Data Access Page dialog box, select the table or query the AutoPage will be based upon from the Choose drop-down list box and double-click on the AutoPage: Columnar list item.  Access will create and display the data access page in a fashion similar to an interactive page preview window.

To save the page, click the Save button on the Database toolbar and use the Save as Data Access Page dialog box to navigate to the location the file will be saved.  Provide a file name for the page in the File Name text area and click the OK button to save the page.

Notes:
An added benefit to using the Page Wizard is that you can display fields from multiple tables in a single data access page. 

Section 8.5.2 – Creating a Grouped Data Access Page

Concept:
Creating a grouped data access page via the Page Wizard

Method:
Use the Page Wizard to create a grouped data access page (which can display grouped data from more than one table or query).  To start the wizard, click the Pages button on the Objects bar in the Database window and double-click the Create data access page by using wizard list item.

In the Page Wizard dialog box select each data source from the Tables/Queries drop-down list and choose the fields to display from the Fields list.  In the second page of the wizard, select any grouping options to apply to the data access page (such as which field to group the records by).

The final page of the wizard prompts for a name for the page and whether to view or modify the page. Click the Finish button to complete the operation.

Notes:
None.

Resource III

Microsoft Access 2003
Extra-Curricular Activities

	Chapter 8

	Extra Curricular Activities


Activity 1 Create a copy of the database AC0800 and name it CopyChapter8.  Open the copy you have just created and add a new form which has a main form and a subform with the following characteristics:

· Create a form which shows each class in the main form and a listing of the students enrolled in the class in the subform.

· In the main form, display the course’s title and number of credits.

· In the subform, display each student’s first and last names, and their current GPA.

· Use a datasheet layout for the display of the subform.

· Apply the Ricepaper style to both forms (main and sub).

Save the main form with the name frmEnrollmentMain and the subform with the name frmEnrollmentSub.

Activity 2 Create a new report in the database that you copied in Activity 1.  The new report is essentially the same as the form created in Activity 1.  The report should include the following characteristics:

· Create a report which shows each class in the main group and a listing of the students enrolled in the class in the subgroup.

· In the main group, display the course’s title and number of credits.

· In the subgroup, display each student’s first and last names, and their current GPA.

· Sort the subgroups by the students’ last name.

· Apply the Outline 1 layout to the report generated.

· Apply the Corporate style to the report generated.

Save the report with the name rptEnrollment in the database and print a copy of the report to submit to your instructor.

Activity 3 Finally, create a grouped data access page of the same nature as the previous two activities.  Group the data first by number of credits and then by the title of the course.  Sort the remaining data by the GPA value in descending order.  Save the data page as pageEnrollment to the database.

Resource IV

Microsoft Access 2003
Answers to End-of-Chapter Review Questions

	Chapter 8
	Answers to End-of-Chapter Questions


Short Answer

1.
Bound, unbound, and calculated controls may all appear in the Form Detail section. The most common type, however, is the compound control, which consists of a label and a text box. Compound controls display the field names (labels) and data (text boxes) stored in the underlying table or query.

2.
The Form Header and Form Footer sections contain data that you want to display at the top and bottom of each form. You can use these areas to show titles (using label controls) and helpful comments or suggestions. You can also insert the current date and time in a calculated control for display in these sections.

3.
A bound control is tied to data in an underlying table or query and is used to display, edit, and store data. An unbound control is not tied to any data and is used for displaying information on a form or report. 

4.
Each portion of a compound control displays a moving handle in its top left-hand corner when selected. To move a text box control separately from its attached label control, drag the text box using its move handle (with the pointing hand mouse pointer) rather than its border.

5.
The navigational order of input controls, which include text boxes, option buttons, check boxes, and any other control that can accept focus, is called the tab order. Typically, a tab order flows from the top left-hand corner to the bottom right-hand corner. Changing the tab order means that you specify to which control the cursor moves when the user presses[image: image1.png]Tab



.

6.
Select the desired controls on a form or report and choose the Format, Size command. 

7.
Select the desired controls on a form or report and choose the Format, Align command.

8.
The Report Header appears once at the beginning of a printed report. The Page Header appears at the top of each printed page. The Report Detail section contains the main body of the report. For each record in the underlying table or query, a line item is typically printed in the Report Detail section.

9.
Conditional formatting is useful when you need to identify values that stray from a standard result. By formatting values according to whether or not they meet a specific condition, exceptional values are easier to locate and interpret. 

10.
To create a new Group Header section, display the Sorting and Grouping window and make the appropriate selections in the window. Insert or move controls into the new header section.

True/False

	1.
	T
	6.
	T

	2.
	T
	7.
	T

	3.
	F
	8.
	T

	4.
	T
	9.
	F

	5.
	F
	10.
	F


Multiple-Choice

	1.
	d
	6.
	a

	2.
	c
	7.
	b

	3.
	a
	8.
	d

	4.
	d
	9.
	c

	5.
	c
	10.
	b
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