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Microsoft Access 2003

Pre-Test / Post-Test

	Chapter 10

	Pre Test / Post Test Questions


Fill in the blanks:

1. Access 2003 provides _____ _____, which are automation tools for publishing tables, queries, and reports into Word documents and Excel worksheets.

2. One of the more powerful features offered in word processing software is the ability to _____ data into a standard document template for printing.

3. Through _____, you can establish a connection to a table object that exists in another database file.

4. The _____ _____ _____ is a Microsoft Access 2003 tool that allows you to verify and refresh the storage location of all linked tables.

5. XML _____ defines the rules and structure of data contained in an XML file.

6. In Access, you can combine multiple macros into a single _____ _____.

7. _____ are self-contained command instructions that can be joined together to automate frequently performed tasks.

8. A switchboard is a special-purpose _____.

9. The Table Analyzer Wizard normalizes a table by _____ fields that contain repeating values into new tables and establishing relationships between them.

10. With database _____, you can create multiple copies of a master database, add and modify data in the copies, and then, at a later time, add in the changes to update the master database.

Multiple choice:

11. Using the Publish It with Microsoft Word feature, you can generate what type of word processing document containing data from the selected table, query, or report?

a. Rich Tabled Format

b. Rich Text Forms

c. Rich Text Format

d. None of the above

12. The mail merge process requires how many files?

a. one

b. two

c. three

d. four

13. How many methods are discussed in the textbook for exporting data from Access to Excel?

a. two

b. three

c. four

d. none of the above

14. The acronym ODBC stands for which of the following?

a. Open Database Binary Compatibility

b. Open Database Compatibility

c. Open Database Connectivity

d. none of the above

15. The acronym XML stands for which of the following?

a. Extensible Markup Language

b. Extended Management Language

c. Extensive Marked Language

d. none of the above

16. A set of one or more actions that is stored as a single object in the Database window is know as which of the following?

a. form

b. procedure

c. expressions

d. macro

17. The macro (if present) executed first by Access when opening a database has what name?

a. Auto Start

b. AutoExecute

c. AutoExec

d. AutoRun

18. Which of the following can be created from a macro in Access?

a. button

b. toolbar

c. menu

d. only b and c

19. Which wizard in Access helps you develop an efficient relational database?

a. Table Analyzer Wizard

b. Database Splitter Wizard

c. Upsizing Wizard

d. None of the above

20. The best passwords combine which of the following?

a. upper and lowercase characters

b. numbers

c. symbols

d. all of the above

True / False:

21.  Word’s Mail Merge Wizard can help you master the process of performing a mail merge quickly.

22.  Data exported into Word from Access is inserted into the document as a chart.

23.  You can use the Office Clipboard to copy and paste up to 30 selections at a time between an Access database and Excel worksheet.

24.  When you delete a linked table, you remove the connection as well as remove the table from the external database.

25.  You can link data from text files, spreadsheets and other database management software.

26.  A switchboard provides a menu of choices that allow users to navigate the features of a database application more easily.

27.  You can run a macro in response to an event that occurs on a form or report.

28.  If a macro action condition is true, Access ignores the associated action.

29.  The Performance Analyzer Wizard is best used in the database design stage.

30.  Encrypting a database compacts the database file.

	Chapter 10

	Pre Test / Post Test Answer Key


Fill in the blanks

1. Office Links (10.1:10-3)

2. merge (10.1.2:10-6)

3. linking (10.2.1:10-19)

4. Linked Table Manager (10.2.3:10-23)

5. schemas (10.2.4:10-25)

6. macro group (10.3:10-30)

7. Actions (10.3.1:10-31)

8. form (10.3.4:10-48)

9. moving (10.4.1:10-59)

10. replication (10.4.3:10-67)

Multiple choice:


11. C (10.1.1:10-3)

12. B (10.1.2:10-6)

13. A (10.1.3:10-15)

14. C (10.2.2:10-23)

15. A (10.2.4:10-25)

16. D (10.3:10-30)

17. C (10.3.1:10-34)

18. D (10.3.5:10-51)

19. A (10.4.1:10-59)

20. D (10.5.1:10-75)

True / False:

21. T (10.1.1:10-6)

22. F (10.1.2:10-13)

23. F (10.1.4:10-15)

24. F (10.2.1:10-19)

25. T (10.2.2:10-21)

26. T (10.3:10-30)

27. T (10.3.2:10-35)

28. F (10.3.3:10-43)

29. F (10.4.2:10-64)

30. T (10.5.2:10-77)
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Microsoft Access 2003

Teaching Materials

	Chapter 10
	Automating and Extending Access


Overview

Chapter 10’s topics cover a wide range of features and tools to automate and extend Access databases.  Included in this chapter are exporting data from Access to Microsoft Word and Excel, accessing and linking to data in both Access and non-Access database files (such as dBASE and Paradox), exporting and importing data from/to Access using XML files, creating and executing macros, creating and using switchboard forms, as well as using the Table Analyzer and Performance Analyzer Wizards.  The chapter concludes with instructions on creating a more secure database by implementing a database password, encrypting and decrypting database files, as well as utilizing user-level controls for accessing and modifying a database. 

Tips and Teaching Strategies

While it should be obvious to all the students, it might be worth pointing out that to export data to another application as described in this chapter, one needs to have the destination application installed on their machine.

While covering the encryption and decryption of databases, it seems prudent to discuss file formats.  While Access has its own format for representing the database and database objects, Access is not the only program that can read files formatted for use by Access.  Similarly, Word files can be read by programs other than Word.  Since other programs can read the contents of an unencrypted database file, this is one more reason why databases, which need security and protection, should be encrypted by the designers to protect the contents. 

Section 10.1 – Integrating Access with Word and Excel

This section deals with the process of exporting data from Microsoft Access to two other Microsoft Office applications (Word and Excel).  With regards to the exporting of data to Word, two methods are presented in this section; the first is a straight export as a table.  The second method results in a mail merge of data from Access to Word.  Also included in this section are details for exporting data to Excel.

Section 10.1.1 – Publishing Data to Word 2003

Concept:
Publishing a table, report or query result to Microsoft Word

Method:
To export data to Word from Access, select the desired table, report or query in the Database window and click the down arrow on the Office Links button on the Database toolbar.

Select the Publish It with Microsoft Word item from the drop-down list.  Alternatively, choose the Office Links menu item from the Tools menu, and click the Publish It with Microsoft Word menu item.  With either approach, the selected object will be exported to Word, and the Word application will open, displaying the exported data. 

Notes:
None.

Section 10.1.2 – Merging Data with Word 2003

Concept:
Merging table or query result data with Microsoft Word

Method:
Data stored in an Access table, or data resulting from an Access query can be mail merged with Microsoft Word.  To perform the mail merge, select the desired data (table or query) to export from the Database window.  Choose the Office Links menu item from the Tools menu, and click the Merge It with Microsoft Word menu item or click the dropdown arrow on the Office Links button on the Database toolbar and click the Merge It with Microsoft Office Word button.

In the Word Mail Merge Wizard choose whether to link the data to an existing Word document or create a new document and link the document to the exported data.  The Word application will begin (displaying either the specified document or a new document), and the Mail Merge Task Pane will be shown to assist in the completion of the merge from within Word.

Notes:
In Microsoft Office Word 2003, you can import a table or query object that is stored in an Access 2003 database by clicking the Insert Database button on Word 2003’s Database toolbar. The data is inserted into the document as a table.

Section 10.1.3 – Analyzing Data in Excel 2003

Concept:
Exporting data to Excel

Method:
To export data from Access to Excel, select a table, query, or report from the Database window. Click the Office Links menu item from the Tools menu and choose the Analyze It with Microsoft Office Excel menu item or click the dropdown arrow on the Office Links button on the Database toolbar and click the Analyze It with Microsoft Office Excel button.

Microsoft Excel will start and the exported data you have selected will be loaded as a worksheet in a new workbook file.

Notes:
None.

Section 10.1.4 – Exporting Data to Excel 2003

Concept:
Exporting data to Excel using drag and drop

Method:
In addition to the method described in Section 10.1.3, data can be exported to Excel via the drag and drop method.  Select the desired data object in the Database window of Microsoft Access and drag the selected item to an already-opened Microsoft Excel worksheet.  Release the mouse button when the insertion point is over the location in Excel where the upper-left corner of the data is to appear.  The data is exported to Excel at the specified position.

Notes:
The Office Clipboard can also be used to copy and paste up to 24 selections at a time between an Access datasheet and an Excel worksheet.

Section 10.2 – Using Access with Other Databases

Section 10.2 provides instructions for using Access with other databases (and data sources).  The subsections present the details to link data tables from other Access databases, as well as non-Access databases.  The section then proceeds to present instructions on using the Linked Table Manager to verify and refresh linked tables.  Section 10.2 closes with coverage of the importing and exporting of data via XML data files. 

Section 10.2.1 – Linking to Data in Access Databases

Concept:
Linking a table from another Access database

Method:
Rather than exporting/importing data in a table from one database to another, you can establish a link to a table object that exists in another database file.  To link a table, open the database file in which you want to create the link and click the Tables button in the Objects bar.  Choose the Get External Data menu item from the File menu; click the Link Tables menu item.

Locate and select the database containing the table for linking in the Link dialog window and click the Link button.  Select the desired table(s) to link from the list displayed and click the Link command button to link the table(s) to the open database you are working with.

Notes:
Deleting a linked table in the local database only removes the connection; it does not destroy the actual table.

Section 10.2.2 – Linking to Data in Non-Access Databases

Concept:
Linking a table from a non-Access data source

Method:
You can link one or more tables from a non-Access data source.  The supported data sources include dBASE 5, dBASE IV, dBASE III, Microsoft Excel, Exchange, HTML Documents, Outlook, Paradox, text files, Windows SharePoint Services and ODBC Databases.  To link a table, open the database file in which you want to create the link and click the Tables button in the Objects bar.  Choose the Get External Data menu item from the File menu; click the Link Tables menu item.

In the Link dialog window choose the database format by selecting it in the Files of type drop-down list box and choose the desired database file to link. Click the Link command button to establish the link.

Notes:
None.

Section 10.2.3 – Using the Linked Table Manager

Concept:
Using the Linked Table Manager to verify and refresh linked tables

Method:
Access’ Linked Table Manager is a built-in tool which you can use to verify and refresh linked tables within a database.  To perform these tasks using the Linked Table Manager, choose the Database Utilities menu item from the Tools menu, and click the Linked Table Manager menu item.

In the Linked Table Manager dialog window select the linked tables you wish to update and click the OK command button.

Notes:
None.

Section 10.2.4 – Importing and Exporting XML

Concept:
Exporting a database object as an XML document file

Method:
To export a database object as an XML document file, open the database which contains the desired object (table, query, report).  Select the object from the Database window and choose the Export menu item from the File menu.

Use the Export dialog box to provide the name and location for the XML file you are about to create.  Be sure to select the XML item from the Save as type drop-down list box and click the Export command button.  The selected database object will be written to the specified location as an XML file.

Notes:
None.



Concept:
Importing structure and/or data from an XML file

Method:
You can import data or data and its structure from an existing XML data file.  To import XML data click the Tables button in the Database Objects bar and choose the Get External Data menu item from the File menu and click the Import menu item.

Select the XML item from the Files of type drop-down list box, and select the desired file from the Import dialog window.  Click the Import command button to import the selected file.

The Import XML dialog box shows a list of data objects which will be imported.  Choose to import only the structure of the objects or the data and the structure of the objects in the Options area of the window (click the Options button to display the area, if necessary). Click the OK button to complete the import procedure.

Notes:
None.

Section 10.3 – Automating Your Database

Section 10.3 focuses on tools, features, and steps to make the database you are working with more automated.  These topics include the creation and execution of macros from within Access, as well tying controls and events occurring on forms and reports to existing macros.  The creation, editing, and use of switchboard forms are also covered in this section, as is the use of expressions in macros.  This section concludes with a discussion of customizing the menu and toolbars contained in Access and the workspace and startup options when working with Access.

Section 10.3.1 – Creating and Playing Back a Macro

Concept:
Creating a new macro

Method:
Unlike recording macros in other Office applications, macros in Access are created by selecting actions in the Macro window.

To create a new macro in Access, click the Macros button in the Objects bar and click the New button on the Database window toolbar.  In the macro dialog window use the Action column to select an action for the macro, and provide a comment (if desired) in the Comment column, next to the action.  In addition, provide any needed parameters for the action in the Action Arguments area at the bottom of the window.

Once you have defined all of the actions for the new macro, click the Save button to open the Save As dialog window.  Provide a name for the new macro and click the OK button.

Notes:
None.



Concept:
Running a macro from the Database window

Method:
To run a macro from the Database window, double-click the macro in the Macros list area, or select a macro in the Macros list area and click the Run button on the Database window toolbar.

Notes:
None.



Concept:
Running a macro from the Menu bar

Method:
To run a macro from the Menu bar, choose the Macro menu item from the Tools menu, and click the Run Macro menu item.  Select a macro from the Macro Name drop-down list box in the Run Macro dialog box.  Click the OK button to run the selected macro.

Notes:
None.

Section 10.3.2 – Automating Objects in a Form or Report

Concept:
Creating a command button tied to a macro

Method:
To tie a command button on a form to the execution of a macro, open the desired form in Design view and ensure that the Control Wizard button is depressed.  Click the Command button on the Toolbox window and click on the form to place the button.

On the first page of the Control Wizard dialog window select the category and action you wish to associate with the button.  Click the Next button to move to the second (and third) pages of the wizard, where you provide more information about the selected action.  Note that these pages vary depending on the action selected.  In the final page of the wizard provide a name for the button you have added to the form.  Click the Finish button to complete the addition of the button and its association with the macro you have defined. 

Notes:
None.



Concept:
Using the Macro Builder tool to associate a macro with a form event 

Method:
Another method of associating an event on a form with a macro is to use the Macro Builder tool to create a macro for a particular form event.  To access the Macro Builder tool open the desired form in Design view and display the Properties window.  Click the Event tab on the Properties window.  In one of the form’s event property text boxes, click the Build (…) button.  In the Choose Builder dialog box select the Macro Builder item from the list box and click the OK button.

Use the Macro Builder window to define the macro which executes when the selected form event takes place.

Notes:
None.

Section 10.3.3 – Using Conditional Expressions in Macros

Concept:
Editing a macro

Method:
To edit an existing macro, click the Macros button in the Objects bar and select a macro in the list area.  Click the Design button on the Database window toolbar to open the selected macro in Design view and edit its actions, arguments, and comments.

Notes:
None.



Concept:
Adding conditional expressions in a macro

Method:
To add a conditional expression in a macro, display the desired macro in Design view, and click the Conditions button on the Macro Design toolbar.  For a given macro action, you can enter an expression in the Condition text area that corresponds to a desired macro action.  If the conditional expression evaluates to True when the macro executes, the corresponding action is executed.

Notes:
None.



Concept:
Printing a macro

Method:
To print a macro click the Macros button in the Objects bar and select a macro in the list area.  Choose the Print menu item from the File menu. In the Print Macro Definition dialog window specify which characteristics of the macro are to be printed.  Click the OK button to print the macro.

Notes:
None.

Section 10.3.4 – Creating a Switchboard Form

Concept:
Creating a switchboard

Method:
A switchboard form can be created to support user navigation of the database forms and reports.  To create a switchboard form, choose the Database Utilities menu item from the Tools menu, and click the Switchboard Manager menu item.  In the Switchboard Manager dialog window click the Edit… button to edit the options on the main switchboard page displayed to users.

The Edit Switchboard Page dialog window allows you to add, remove, or edit items on the selected switchboard.  Use the New… button to add additional items such as open a form or report, run a macro or code module or exit the application.  The Edit… button can be used to modify existing switchboard items, and the Delete button is used to remove a selected item from the switchboard.

Switchboard items can be moved up or down so that their appearance on the form is specified exactly.  Click the Close button on the Edit Switchboard Page dialog box to close the dialog and return to the Switchboard Manager window.  Click the Close button on the Switchboard Manager window to complete the creation of the switchboard.

Notes:
None.

Section 10.3.5 – Customizing the Menu and Toolbars

Concept:
Modifying the commands in an existing menu bar

Method:
By using the customization tools in Excel you can alter the content of the menu bar and menus that exist.  To modify the menu bar, choose the Customize menu item from the Tools menu or right-click a menu and choose Customize from the shortcut menu.  In the Customize dialog box click the Commands tab.

Select a category from the Categories list box and drag a command from the Commands list box to the desired location on the menu bar.  When you release the mouse, the dragged command will be added to the specified location on the menu bar or to the location in a menu.  Click the Close button on the dialog box to complete the changes to the menu.

Notes:
None.



Concept:
Customizing existing toolbars

Method:
To add, remove or change the order of commands on a toolbar, display the Customize dialog box as described above and perform one or more of the following steps to customize the toolbars further.

· Add a command to a toolbar – click the Commands tab of the Customize dialog box and drag a command to a toolbar to add the command to the desired toolbar.

· Removing a command from a toolbar – drag the desired command away from the toolbar and into the application window.  Release the mouse and the command will be removed from the desired toolbar.

· Changing the order of commands on a toolbar – drag command icons on the toolbar to a different position.  A vertical line (I-beam) will indicate where the icon will be placed when the mouse is released.

Notes:
None.



Concept:
Creating a new toolbar

Method:
To create a new (blank) toolbar, open the Customize dialog box as described above and click the Toolbars tab. Click the New command button in the dialog box.

Type a name for the new toolbar in the Toolbar name: text area and click the OK button.  The toolbar will be added to the list of toolbars in the Customize dialog box and displayed in the application window.  You can now add commands to the toolbar, as you did earlier in this section.

Notes:
None.



Concept:
Generating a menu or toolbar from a macro

Method:
You can create a menu or toolbar from an existing macro.  To utilize this feature, select the desired macro in the Macros list area of the Database window and choose the Macro menu item from the Tools menu.  Choose one of the following from the drop-down list:
· Create Menu from Macro
· Create Toolbar from Macro

· Create Shortcut Menu from Macro

Notes:
None.

Section 10.3.6 – Setting Workplace and Startup Options

Concept:
Setting workplace options

Method:
With twelve tabbed pages of options, the Options dialog window can greatly affect how Access behaves. To display the Options dialog window, choose the Options menu item from the Tools menu.  In the dialog window, click any of the tabs to display a group of related options for working with Access.  Click the OK button to complete the options changes.

Notes:
None.



Concept:
Setting startup options for the current database

Method:
You can set specific startup options (such as which form is displayed) when the current database is opened by users.  To set startup options, choose the Startup… menu item from the Tools menu.  In the Startup dialog box you can provide various changes to the configuration of how the database is displayed.

Use the Display Form/Page drop-down list to specify which form or data page a user will first see.  When a switchboard form is available, this can be an appropriate first screen for users of the database.  In the dialog box, you can also choose whether to display the database window and status bar.  Click the OK button to complete the settings.

Notes:
None.



Concept:
Creating a new group in the Objects bar

Method:
To create a new (custom) group in the Objects bar of the Database window, right-click in the Objects bar and choose the New Group menu item from the shortcut menu.  Provide a name for the new group in the New Group dialog box and click the OK button.  The new group with the specified name will be created and displayed in the Objects bar.

Notes:
Database objects can be dragged from existing groups (like tables, forms, etc.) into a custom group.

Section 10.4 – Developing Database Applications

Section 10.4 covers topics related to developing end-user applications. This section provides coverage on two wizards in Access which help optimize the underlying database, thereby increasing its speed.  The wizards discussed in this section are the Table Analyzer Wizard and the Performance Analyzer Wizard.  In addition, the section also discusses replication, creating a design master and replica databases, and splitting a database.

Section 10.4.1 – Using the Table Analyzer

Concept:
Using the Table Analyzer Wizard

Method:
The Table Analyzer Wizard can be use to eliminate redundant information, improve data integrity, and enhance a database’s efficiency.  The wizard is used to move redundant data values to new tables and to establish the required relationships between the tables.  To use the Table Analyzer Wizard, choose the Analyze menu item from the Tools menu and click the Table menu item.

The first two pages of the wizard will present definitions, examples, and descriptions of how it will analyze the table, and what corrective actions it may take.  The third page allows you to select which table the wizard will analyze, and the fourth page permits you to decide if you or the wizard will decide how to change the tables.

In the final page, the wizard’s solution is presented (or you are able to implement your own changes, if you selected that option on the third page of the wizard).  Click the Finished button to complete the changes presented.

Notes:
You can also start the Table Analyzer Wizard by clicking the down arrow on the Analyze button on the Database toolbar and choosing the Analyze Table option.
Section 10.4.2 – Using the Performance Analyzer

Concept:
Using the Performance Analyzer Wizard

Method:
The Performance Analyzer Wizard optimizes the performance (speed) of all objects in a database, including tables, queries, forms, and reports.  To start the wizard, choose the Analyze menu item from the Tools menu and choose the Performance menu item or click the down arrow on the Analyze button on the Database toolbar and click the Analyze Performance option.

Select the objects you wish the wizard to analyze.  By clicking on the All Object Types tab of the wizard dialog window you can view all of the objects in the database and select those you wish to analyze.  Once you have selected the desired objects, click the OK button to start the analysis.

When the analysis is complete, the wizard’s dialog window will display a list of recommended changes, suggestions or ideas which will help improve various aspects of the database.  To implement recommendations made by the wizard, select a displayed analysis result and click the Optimize button.

Notes:
None.

Section 10.4.3 – Understanding Replication

Concept:
Creating a design master and a single replica of a database

Method:
Prior to using replicated databases, a single design master database must be created.  Once completed, only the design master can accept design (structure) changes to the database, while both the design master and replicas can accept changes to the underlying data contained within.

To create a design master and a single replica database, open the database which will be converted into the design master.  Choose the Replication menu item from the Tools menu, and choose the Create Replica menu item.

Access will display a warning dialog box informing you that it must close the database prior to continuing.  Click the Yes button on the dialog to proceed.  Access prompts you to decide if you would like Access to make a backup copy of the database prior to creating the design master and the replica.  Click either the Yes or No buttons.  Finally, in the Location of New Replica dialog box, specify the directory folder location and filename of the first replica to be created from the Design Master and press the OK button.

Access has now modified the original database file to be a design master, created a single replica database, and (if instructed to) created a backup copy of your original database.

Notes:
None.

Section 10.4.4 – Creating and Synchronizing Replicas

Concept:
Creating replica databases

Method:
To create additional database replicas, open either the design master or an existing replica of the desired database.  Choose the Replication menu item from the Tools menu, and choose the Create Replica menu item.

In the Location of New Replica dialog window define the location and file name of the replica you are about to create.  Click the OK button to create the new replica. Access will display a warning message after the replica has been created, asking to close and reopen the database.  Click the Yes button to close and reopen the database, thereby updating the list of valid replicas.

Notes:
None.



Concept:
Synchronizing replica databases

Method:
To synchronize a replica database with another replica or the design master, choose the Replication menu item from the Tools menu, and choose the Synchronize Now menu item.

In the Synchronize Database dialog window provide the location of the replica (or design master) to synchronize with.  Provide the location of the synchronization target in the Directly with Replica: drop-down list box and click the OK button.  The two databases will then attempt synchronization automatically.

Notes:
If synchronization conflicts occur, use the Resolve Conflicts tool to help decide which update is valid.  To use the tool, choose the Replication menu item from the Tools menu, and choose the Resolve Conflicts menu item.

Section 10.4.5 – Using the Database Splitter

Concept:
Using the Database Splitter

Method:
The Database Splitter Wizard exports all of the table objects to a new database, deletes the tables from the current file, and then establishes links to the tables in the new “data only” database.  This is an effective solution when distributing your database to multiple users, in effect removing the data locally from the versions of the database they will use and enforcing a single database which only contains the data.

To use the Database Splitter Wizard, open the desired database and choose the Database Utilities menu item from the Tools menu, and choose the Database Splitter menu item.

In the Database Splitter dialog window click the Split Database button to proceed.  In the Create Back-end Database dialog window specify the directory folder location and filename of the new “data only” database.  Click the Split command button to begin moving the data tables to the new database.  A new database file is created that contains only the tables from the original database and an informational message displays stating that the split has been completed.

Notes:
None.

Section 10.5 – Implementing Database Security

This final section covers the various methods of implementing security for an Access database.  Included in this section are the setting of a database password, encrypting and decrypting a database file, and assigning permissions to a database.

Section 10.5.1 – Setting a Database Password

Concept:
Setting a database password

Method:
To set a password on a given database (so that a user without the password is unable to open the database and examine the contents within) open the desired database in Exclusive mode.  To open a database in Exclusive mode click the Open button on the Database toolbar and select the desired database file from the Open dialog box.  Rather than double-clicking on the desired database, click the down-arrow on the Open button in the dialog box, and choose the Open Exclusive item.

Choose the Security menu item from the Tools menu, and choose the Set Database Password menu item.  In the Set Database Password dialog box enter the new password twice (for verification and to prevent typing errors).  Click the OK button to set the password for the database.

Notes:
Once a database password is set, each time the database is opened, the user is asked to enter the password.  Only correct password entry permits access to the database.

Section 10.5.2 –Encrypting and Decrypting a Database 

Concept:
Encrypting and decrypting a database

Method:
Encrypting a password-controlled database provides another layer of protection for the database.  To encrypt a database, choose the Security menu item from the Tools menu and choose the Encode/Decode Database menu item.  In the Encode/Decode Database dialog window select the location and name of the new (encrypted) database file.  Click the Save button to save the database in a new file which is encrypted.

Notes:
None.

Section 10.5.3 – Assigning Permissions to a Database

Concept:
Creating user and group level control of a database

Method:
The Access Security Wizard can be used to assign permissions for accessing a database file.  Open the Security Wizard by choosing the Security menu item from the Tools menu, and choosing the User-Level Security Wizard menu item.

The Security Wizard dialog window will guide you through the process of creating the desired permissions.  The wizard’s steps are lengthy, so we will only briefly mention the sequence the wizard proceeds in.

First, a workgroup information file is created (or modified).  It is used to store user account names and passwords.  Next, the user selects which database objects the security settings are supplied, group security accounts are established, and users are created and added to accounts.

Once completed, the Security Wizard displays a report detailing the security settings imposed.

Notes:
None.
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	Chapter 10

	Extra Curricular Activities


Activity 1 Copy the AC0900 database to the file EXA10_1.  Ensure that the new database file is not read-only and that you can modify it.  Open the EXA10_1 database file and link in all of the tables from the AC0500 database (Courses, Instructors, and Students).  Save your changes to the EXA10_1 database.

Activity 2 While working with the EXA10_1 database, export the tblAdministrators table to an XML file named AdminsXML.  When selecting the export options, only choose to export the data and not the schema of the data or the presentation of the data (XSL file).  E-mail the AdminsXML file to your instructor for grading.
Activity 3 Open the EXA10_1 database file (created in Activity #1) and create a switchboard form.  Include in the form the ability to display or open the following database objects:

· frmAdministrator

· frmCourseInfo

· rptMainSection

· rptSyncMain

Apply a password (‘secureDB’) to the database and close the database file.  Copy the database to a floppy disk and submit it to your instructor for grading.  Your instructor should be able to open your database using the password listed above.
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Chapter 10 
Answers to End-of-Chapter Review Questions

Short Answer

1. The Office Links features enable you to share and exchange data with the other Microsoft Office XP applications and take advantage of these applications’ strengths. For example, Word is the best application choice for performing a mail merge, while Excel is the best choice for analyzing numerical table data. The Office Links features provide quick and easy access to these applications.

2. Depending on whether specific software programs exist on your computer, you may not be able to modify the data stored in linked databases. The limitation is that you may only be able to view the data.

3. A command button’s events are: On Enter, On Exit, On Got Focus, On Lost Focus, On Click, On Dbl Click, On Mouse Down, On Mouse Move, On Mouse Up, On Key Down, On Key Up, and On Key Press. 

4. An event is what happens to an object, such as clicking a button. An event procedure is the response to the event, such as opening a form or running a report when a button is clicked.

5. The following are the methods for executing a macro: (1) double-click the macro object in the Database window, (2), select the object and click the Run button ([image: image1.png]


) on the Database window toolbar, (3) click the Run button ([image: image2.png]


) on the Macro window toolbar, (4) attach the macro to an event for a control or object, (5) attach the macro to a toolbar button, (6) attach the macro to a menu command, and (7) choose the Tools, Macro, Run Macro command. 

6. A switchboard form provides menu items for automating and navigating a database. Since the switchboard must reference existing database objects (including macros), it is usually the last form created in the development process. Switchboards are used to polish the application before delivering it to the end user.

7. The Table Analyzer ensures that a particular table object is normalized and designed efficiently. If necessary, the Table Analyzer restructures the tables and relationships. The Performance Analyzer, on the other hand, ensures that all the objects in a database work efficiently together. The result is a list of recommendations, suggestions, and ideas for optimizing the performance of the database. Whereas the Table Analyzer is used during the database design stage, the Performance Analyzer is best used after the database is populated with objects.

8. A replica is a copy of a database that you use for manipulating data. As a member of a replica set, you can exchange and synchronize the data stored in a replica quickly and easily. You create a replica in order to make a database portable. In other words, you can store a replica on a local computer and then synchronize its contents with other replicas and the Design Master across a network connection.

9. The Microsoft Data Engine (MSDE) provides full SQL Server-compatibility. If you need to design a SQL Server database, use the MSDE as an intermediary developing and testing solution. When the application is finished, you may then upgrade to SQL Server. You can also use the MSDE when developing small-scale client/server applications using the new Access Data Projects format. 

10. The purpose of the Database Splitter is to separate the data or “back-end” components from the user interface (queries, forms, and reports) or “front-end” components of a database. An Access data project is a type of database file that supports this same objective. Access project files contain the forms, reports, macros, and modules that make up the front-end of an application. The data for an Access project is typically stored using a client/server solution such as Microsoft SQL Server. Both of these features help the developer make strides toward multi-user database access.
True/False

	1.
	T
	6.
	F

	2.
	T
	7.
	T

	3.
	F
	8.
	F

	4.
	T
	9.
	T

	5.
	T
	10.
	F


Multiple-Choice

	1.
	d
	6.
	d

	2.
	c
	7.
	c

	3.
	a
	8.
	b

	4.
	a
	9.
	a

	5.
	c
	10.
	b
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