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OVERVIEW
EES (pronounced ‘ease’) is an acronym for Engineering Equation Solver. The
basic function provided by EES is the numerical solution of non-linear alge-
braic and differential equations. In addition, EES provides built-in thermody-
namic and transport property functions for many fluids, including water, dry
and moist air, refrigerants, combustion gases, and others. Additional property
data can be added by the user. The combination of equation solving capability
and engineering property data makes EES a very powerful tool.

A license for EES is provided to departments of educational institutions that
adopt this McGraw-Hill text. If you need more information contact your local
McGraw-Hill representative, call 1–800–338–3987, or visit the McGraw-Hill
website at http://www.mhhe.com. A commercial or professional version of
EES can be obtained from:

F-Chart Software, LLC
Box 44042
Madison, WI 53744
http://fchart.com email: info@fchart.com

BACKGROUND INFORMATION
The EES program is probably installed on your departmental computer. In ad-
dition, the license agreement for use of EES allows students and faculty in a
participating educational department to copy the program for educational use
onto their personal computer systems. Ask your instructor for details.

To start EES, double-click on the EES program icon shown above or on
any file created by EES having the .EES filename extension. You can also

start EES from the Windows Run command in the Start menu by entering EES
clicking the OK button. EES begins by displaying a dialog window, which
shows registration information, the version number and other information.
Click the OK button to dismiss the dialog window.

Detailed help is available at any point in EES. Pressing the F1 key will
bring up a Help window relating to the foremost window. Clicking the Con-
tents button will present the Help index shown below. Clicking on an under-
lined word (shown in green on color monitors) will provide help relating to
that subject.

EES commands are distributed among ten pull-down menus shown above.
A brief summary of their functions follows.

The System menu is accessible by clicking on the EES icon above the
file menu. The System menu is not part of EES, but rather a feature of the
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Windows Operating System. It holds commands which allow window
moving, resizing, and switching to other applications.

The File menu provides commands for loading, merging and saving work
files and libraries, and printing. The Load Textbook command in this menu
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reads the problem disk developed for this text and creates a new menu to
the right of the Help menu for easy access to EES problems accompanying
this text.

The Edit menu provides the editing commands to cut, copy, and paste
information.

The Search menu provides Find and Replace commands for use in the
Equations window.

The Options menu provides commands for setting the guess values and
bounds of variables, the unit system, default information, and program
preferences. A command is also provided for displaying information on
built-in and user-supplied functions.

The Calculatemenu contains the commands to check, format and solve
the equation set. A command to check the units of the equations is also
provided.

The Tables menu contains commands to set up and alter the contents of
the Parametric and Lookup Tables and to do linear regression on the data in
these tables. The Parametric Table, which is similar to a spreadsheet, allows
the equation set to be solved repeatedly while varying the values of one or
more variables. The Lookup table holds user-supplied data which can be
interpolated and used in the solution of the equation set.

The Plot menu provides commands to prepare a new plot of data in the
Parametric, Lookup, Array or Integral tables or to modify an existing plot.
Curve-fitting capability and thermodynamic property plots are also
provided.

The Windows menu provides a convenient method of bringing any of the
EES windows to the front or to organize the windows.

The Help menu provides commands for accessing the online help docu-
mentation.

The Heat Transfer menu provides access to EES solutions to prob-
lems in this text.

A basic capability provided by EES is the solution of a set of non-linear
algebraic equations. To demonstrate this capability, start EES and enter this
simple example problem in the Equations window.
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Text is entered in the same manner as for any word processor. Formatting
rules are as follows:

1. Upper and lower case letters are not distinguished. EES will (optionally)
change the case of all variables to match the manner in which they first
appear.

2. Blank lines and spaces may be entered as desired since they are ignored.
3. Comments must enclosed within braces { } or within quote marks “ ”.

Comments may span as many lines as needed. Comments within braces
may be nested in which case only the outermost set of { } are recognized.
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Comments within quotes will also be displayed in the Formatted
Equations window.

4. Variable names must start with a letter and consist of any keyboard
characters except ( ) | * / � � ^ { } : ” or ;. Array variables are identified
with square braces around the array index or indices, e.g., X[5,3]. The
maximum variable length is 30 characters.

5. Multiple equations may be entered on one line if they are separated by a
semi-colon (;).

6. The caret symbol (^) or ** is used to indicate raising to a power.
7. The order in which the equations are entered does not matter.
8. The position of known and unknown variables in the equation does not

matter.

If you wish, you may view the equations in mathematical notation by se-
lecting the Formatted Equations command from the Windows
menu or from the Formatted Equations speed button located be-
low the menu bar or by pressing ctrl-F.

INTRODUCTION TO EES
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Select the Solve command from the Calculate menu or press F2.
A dialog window will appear indicating the progress of the solution. When the
calculations are completed, the button will change from Abort to Continue.

Click the Continue button. The solution to this equation set will then be
displayed.
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AN EXAMPLE PROBLEM
In this section, Problem 1–104 from the text is worked from start to finish il-
lustrating some of the capabilities of the EES program. EES is particularly ap-
propriate for this problem since a trial-and-error solution would be required if
the problem were done by hand. The problem to be solved is this.

The roof of a house consists of a 15-cm thick concrete slab (k � 2 W/m · �C)
that is 15 m wide and 20 m long. The emissivity of the outer surface of the
roof is 0.9, and the convection heat transfer coefficient on that surface is
estimated to be 15 W/m2 · �C. The inner surface of the roof is maintained at
15�C. On a clear winter night, the ambient air is reported to be at 10�C while
the night sky temperature for radiation heat transfer is 255 K. Considering
both radiation and convection heat transfer, determine the outer surface
temperature and the rate of heat transfer through the roof.

If the house is heated by a furnace burning natural gas with an efficiency
of 85 percent, and the unit cost of natural gas is $0.60/therm (1 therm �

105,500 kJ of energy content), determine the money lost through the roof
that night during a 14-hour period.

This problem involves conduction, convection and radiation. The problem
is facilitated by an energy flow diagram.
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To solve this problem, it is necessary to equate the conduction heat transfer
rate through the concrete roof to the combined convective and radiative heat
transfer rates from the roof surface.

Q
·

cont � kA(Tinner � Tsurface)/L
Q
·
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Q
·
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A � roof area (m2)
k � thermal conductivity (W/m · K)
h � convection coefficient (W/m2 · K)

Tinner � temperature of the inner surface of the roof (K)
Tsurface � temperature of the outer surface of the roof (K)
Tambient � temperature of the outdoor air (K)

Tsky � effective radiative temperature of the sky (K)
s� Stefan-Boltzman constant (5.67 � 10�8 W/m2 · K4)
e � emissivity of the roof surface
L � the thickness of the concrete slab (m)

There are a total of 13 variables in this problem. Of these, 9 (A, k, h, Tinner,
Tambient, L, Tsky, s, and e) are specified in the problem statement, leaving 4 un-
known variables. There are four equations relating these variables, so that the
problem is completely specified. However, the equations are nonlinear and as
a result, cumbersome to solve. This is where EES can help.

Start EES or select the New command from the File menu if you have
already been using the program. A blank Equations window will appear. Since
this problem does not require any of the thermophysical property functions
built into EES, it is not necessary to specify the unit system. However, it is
good practice to set the unit system at the start of a problem with the Unit
System command in the Options menu.
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The equations can now be entered into the Equations window. Formatting
rules were discussed earlier in this appendix. After entering the equations for
this problem and (optionally) checking the syntax using the Check/
Format command in the Calculate menu, the Equations window will ap-
pear as shown. Comments (within quotes) are normally displayed in blue on a
color monitor. Other formatting options are set with the Preferences
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command in the Options menu. Note that the $TabStops directive has
been used here to set tabs so that the comments are lined up.

Many of the variable names include an underscore. The underscore is a spe-
cial formatting character that indicates the start of a subscript. Using under-
scores is optional, but it improves the display of the Formatted Equations and
Solutions window. Note that the units of many of the numerical constants are
specified in square braces following the numerical value. The units of each
variable can also be specified in the Solution window and with the
Variable Information command in the Options menu.
Specifying the units of each variable is very important since it allows EES to
check the equations for unit consistency.

Two built-in functions have been used in this problem and they are
ConvertTemp and Convert functions. The Convert function should be able to
provide any unit conversions you encounter while ConvertTemp function is
used to convert temperature units. There are many other useful functions in
EES, including functions that provide thermodynamic and transport property
data. An easy way to enter functions, without needing to recall the format, is
to use the Function Information command in the Options
menu. This command will bring up the dialog window as shown. Click on the
“Fluid properties” radio button. The list of built-in fluid property function will
appear on the left with the list of substances on the right. Select the property
function by clicking on its name, using the scroll bar, if necessary, to bring it
into view. Select a substance in the same manner. An example of the function
showing the format will appear in the Example rectangle at the bottom. The
information in the rectangle may be changed, if needed. Clicking the Paste
button copies the Example into the Equations window at the cursor position.

It is usually a good idea to set the guess values and (possibly) the lower and
upper bounds for the variables before attempting to solve the equations. This is
done with the Variable Information command in the
Options menu. Before displaying the Variable Information dialog, EES
checks syntax and compiles newly entered and/or changed equations, and then
solves all equations with one unknown. The Variable Information dialog will
then appear.
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The Variable Information dialog contains a line for each
variable appearing in the Equations window. By default, each variable has a
guess value of 1.0 with lower and upper bounds of negative and positive in-
finity. (The lower and upper bounds are shown in italics if EES has previously
calculated the value of the variable. In this case, the Guess value column dis-
plays the calculated value. These italicized values can still be edited.)

INTRODUCTION TO EES
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With nonlinear equations, it is sometimes necessary to provide reasonable
guess values and bounds in order to determine the desired solution. (It is not
necessary for this problem.) The bounds of some variables are known from the
physics of the problem. In this example problem, the roof surface temperature
should be between 255 and 285 K. It would be a good practice to set the guess
value for T_surface to something reasonable, for example, 270 K.

The A in the Display options column indicates that EES will automatically
determine the display format for numerical value of the variable when it is
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displayed in the Solution window. In this case, EES will select an appropriate
number of digits, so the digits column to the right of the A is disabled. Auto-
matic formatting is the default. Alternative display options are F (for fixed num-
ber of digits to the right of the decimal point) and E (for exponential format).
The display and other defaults can easily be changed with the Default
information command in the Optionsmenu. The third Display op-
tions column controls the highlighting effects such as normal (default), bold,
and boxed. The Units column shows the units assigned to the variable. The units
that were specified in comments in the Equations window will appear here.
Units can be modified or entered. However, the units set with comments in the
Equations window will override the specifications made in the Variable Infor-
mation dialog. The units will be displayed with the variable in the Solution win-
dow and in the Parametric Table. EES does not automatically do unit
conversions but it does provide automatic unit consistency checking. Unit errors
are frequently the cause of an incorrect solution, so the unit-checking capability
is quite important. Variables can be designated as key variables by clicking in
the Key column. Key variables will display in a separate Solution window. The
final column provides an optional comment for each variable.

To solve the equation set, select the Solve command from the
Calculate menu and the Solution window will appear. The problem is
now completed since the values of T_surface, Q_dot_cond, and Cost are de-
termined. If the Check Units Automatically control in the Preferences
dialog (Options menu) is checked, EES also checks the unit consistency
of the equations as it solves them and reports the results in the Solution win-
dow. The units, in addition to format information such as the number of sig-
nificant figures that are displayed, can be entered by clicking the right mouse
button (or double-clicking the left mouse button) on the variable name in the
Solution Window. If units have not been set for a variable, EES will try to de-
termine the units and will display these units in purple in Solutions Window.

An interesting and unexpected result is evident in the solution. Because of
the low sky temperature, the radiant losses cause the roof surface temperature
to be lower than the ambient temperature and thus the roof is actually warmed
by the convection from the air.

One of the most useful features of EES is its ability to provide parametric
studies. For example, in this problem, it may be of interest to see how the heat-
ing cost varies with thermal conductivity of the roof material. A series of cal-
culations can be automated and plotted in EES.

Select the New Parametric Table command in the Tables
menu. A dialog will be displayed listing the variables appearing in the Equa-
tions window. In this case, we will construct a table containing the variables
k, Q_dot_cond, and Cost. Click on k from the variable list on the left. This
will cause k to be highlighted and the Add button will become active. Repeat
for Q_dot_cond and Cost, using the scroll bar to bring the variable into view
if necessary. As a short cut, you can double-click on the variable name in the
list on the left to move it to the list on the right. You can also select multiple
variables at one time. The table setup dialog should now appear as shown.
Click the Add button to move the selected variables into the list on the right
and then click the OK button to create the table.

The Parametric Table works much like a spreadsheet. You can type numbers
directly into the cells. Numbers that you enter are shown in black and produce
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the same effect as if you set the variable to that value with an equation in the
Equations window. Delete the k � 2 [W/m-K] equation currently in the Equa-
tions window or enclose it in comment brackets { }. This equation will not be
needed because the value of k will be set in the table. Now enter values of k in
the table for which Q_dot_cond and Cost are to be determined. Values of k be-
tween 2 to 0.2 have been chosen for this example. (The values could also be
automatically entered using Alter Values in the Tables menu or by using the
Alter Values control at the upper right of each table column header.) The
Parametric Table should now appear as shown.

INTRODUCTION TO EES
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Now, select Solve Table from the Calculatemenu. The Solve
Table dialog window will appear, allowing you to choose the runs for which
calculations will be done.

When the Update Guess Values control is selected, as shown, the solution for
the last run will provide guess values for the current run. Click the OK button.A
status window will be displayed, indicating the progress of the solution. When
the calculations are completed, the calculated values of Q_dot_cond and Cost
will be entered into the table. The values calculated by EES will be displayed in
blue, bold, or italic type depending on the setting made in the Screen Display tab
of thePreferencesdialog window in theOptionsmenu.

The relationship between variables such as Cost and k is now apparent, but
it can more clearly be seen with a plot. Select New Plot Window from
the Plot menu. The New Plot Setup dialog window shown will appear.
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Choose k to be the X-axis by clicking on k in the X-axis list. Click on Cost in
the Y-axis list. You may wish to adjust the scale limits or add grid lines. When
you click the OK button, the plot will be constructed and the plot window will
appear as shown.

Once created, there are a variety of ways in which the appearance of the plot
can be changed. Double-click the mouse in the plot rectangle or on the plot
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axis to see some of these options. For example, select the Spline Fit option to
smooth the curve.

USING THE TEXTBOOK MENU
A number of problems from this textbook have been solved using EES. These
examples are accessible from the Heat Transfer menu to the right
of the Help menu. As an example, select Chapter 1 from the Heat

Transfer menu. A dialog window will appear listing the problems in
Chapter 1. Select Problem 1–104. This problem is a modification of the prob-
lem you just entered. It provides a Diagram Window in which you can enter the
input variables. Enter values and then select the Solve command in the Calcu-
late menu to see their effect on the output properties.

At this point, you should explore. Try whatever you wish. You can’t hurt
anything. The online help (invoked by pressing F1) will provide details for the
EES commands. EES is a powerful tool that you will find very useful in your
studies.
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