
LESSON 8 Adding and Modifying Reports AC-1
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Concepts Review

True/False Questions
Each of the following statements is either true or false. Indicate your 
choice by circling T or F.

 1. The Field List pane appears in Design View.

 2. Use the Text Box button to add a calculated control to a report.

 3. Conditional formatting depends on criteria that you enter in the dialog box.

 4. Padding is the space between each section of a report.

 5. A Report Header prints at the top of every page.

 6. You cannot change the name of a control.

 7. An asterisk can be used in an aggregate function such as a count.

 8. Conditional formatting can be used to call attention to specific data in a 
report.

Short Answer Questions
Write the correct answer in the space provided.

 1. What section of a report displays the data from each record?

 2. When adding a field to a report in Layout View, what displays to allow 
you to select fields?

 3. What is the quickest way to create a grouped report?

 4. What is the name of the dialog box you use to select fields, common 
expressions, or arithmetic operators?

 5. What does the expression =Now() do?

 6. What tool should you use to add a calculated control to a report?

 7. Which line property changes the width of the line?

 8. What button on the toolbar copies the font and colors from one control 
to another?
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AC-2 UNIT 2 Designing and Managing Database Objects

Critical Thinking
Answer these questions on a separate page. There are no right or wrong 
answers. Support your answers with examples from your own experience, 
if possible.

 1. You used the Line tool in this lesson to add a design element to a report. 
What other tools might add good design ideas for a printed report?

 2. In this lesson, you learned how to change the size, position, and 
color of labels and text boxes using the Property Sheet. What are the 
advantages of using the Property Sheet instead of the mouse and 
toolbars?

Skills Review

Exercise 8-19
Create a label report. Modify the controls.

 1. Open a database by following these steps:

 a. Locate and open the Lesson 08 folder.

 b. Make a copy of CC08, and rename it [your initials]-CC08.

 c. Open and enable content for [your initials]-CC08.

 2. Create a label report by following these steps:

 a. In the Navigation pane, select the table qryCustomerContact.

 b.  From the Create tab, in the Reports group, click the Labels 
command .

 c.  In the Label Wizard dialog box, in the Filter by manufacturer section, 
choose Avery.

 d.  In the Unit of Measure section, choose English, and in the Label Type 
section, choose Sheet Feed.

 e. In the top list box, choose the Product number “5385.” Click Next.

 f.  Set the Font name to Times New Roman, the Font size to 16, the Font 
weight to Bold, and the Text color to black. Click Next.

 g. In the Available fields section, double-click CompanyName.

 h. Press  twice.

 i. In the Available fields section, double-click ContactName.

 j. Press .

 k. In the Available fields section, double-click PhoneNum.

 l. Click Next.

 m.  In the Available fields section, double-click CompanyName and click 
Next.
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AC-3LESSON 8 Adding and Modifying Reports

 n. Name the report 08-19-[your initials].

 o. Click Finish. In the warning dialog box, click OK.

 p. Close the Print Preview to switch to Design View.

 3. Modify controls by following these steps:

 a. Click the CompanyName text box.

 b.  From the Design tab, in the Font group, click the Center command .

 c.  From the Design tab, in the Font group, click the Font command’s 
drop-down arrow and choose Arial Black.

 d.  From the Arrange tab, in the Size group, click the To Fit command .

 e.  Move the CompanyName text box up until its bottom edge meets the 
top edge of the blank text box.

 f.  From the Quick Access toolbar, click the Save button .

 g. Print/Save the first page of the report.

 h. Right-click the form’s document tab and choose Close.

Exercise 8-20
Create and modify a report. Modify sections and controls.

 1. Create a report by following these steps:

 a. Open and enable content for [your initials]-CC08.

 b. In the Navigation Pane, select qryEmployeeDates.

 c.  From the Create tab, in the Reports group, click the Report command 
.

 d.  From the Quick Access toolbar, click the Save button . Key 
08-20-[your initials].

 2. Modify the control layout by following these steps:

 a.  With 08-20-[your initials] open, select the Hire Date control and press 
.

 b. Select the EndDate control and press .

 c.  Select the SSN control label, and click the Layout Selector 
command .

 d.  From the Arrange tab, in the Control Layout group, click the Stacked 
command .

 e. Click the Date of Birth control.

 f.  From the Arrange tab, in the Control Layout group, click the Stacked 
command .

 g. Drag the Date of Birth control to the open area to the right.

 h. While pressing , click the SSN control.

 i.  From the Arrange tab, in the Control Alignment group, click the Top 
command .
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AC-4 UNIT 2 Designing and Managing Database Objects

 3. Modify a report section by following these steps:

 a. Switch to Design View.

 b.  Drag the top of the Page Footer section until the Detail section is 1 
inch tall.

 c. Select the control in the Report Footer section, and press .

 d.  Drag the bottom of the Report Footer section up until no more white 
area is visible. You have closed the section.

 e.  In the Report Header section, select both the Date and the Time 
control. Drag the right edge to the 7-inch mark on the horizontal 
ruler.

 f.  In the Detail section, if needed, drag the right edge of the BirthDate 
control to the 7-inch mark on the horizontal ruler.

 g. Resize the report to 7 inches wide.

 4. Edit report labels by following these steps:

 a.  In the Report Header section, edit the label to read Employee Ages. 
Switch to Design View.

 b.  From the Design tab, in the Controls group, click the Label command 
.

 c.  Click in the far left of the Page Footer section, and key Prepared by: 
[your full name].

 5. Add a line control to a report by following these steps:

 a.  From the Design tab, in the Controls group, click the Line command 
. Click in the lower left corner of the Detail section and drag it to 

the 7-inch mark on the horizontal ruler.

 b.  From the Design tab, in the Tools group, click the Property Sheet 
command .

 c.  On the Format tab, click the Height property and, if necessary, change 
this property to 0.

 d. Close the Property Sheet.

 6. Add a new control to a report by following these steps:

 a. Switch to Design View.

 b.  From the Design tab, in the Controls group, click the Text Box 
command .

 c. Click under the Date of Birth control.

 d.  Add the new unbound control by dragging the new control up to the 
Date of Birth control until you see the insertion bar below the Date of 
Birth control.

 e. Edit the new control’s label to Age.

 7. Add an expression to a control by following these steps:

 a.  Double-click the new control’s text box. In the Property Sheet, on the 
Data tab, click in the Control Source property. Click the Ellipses 
button .

 b.  In the Expression Builder, in the left panel, double-click the folder 
Functions and then click Built-In Functions.

 c.  In the middle panel, click Date/Time. From the right panel, double-
click DateDiff.
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LESSON 8 Adding and Modifying Reports AC-5

 d. In the expression box, click <<Interval>> and key “yyyy”.

 e. In the expression box, click <<date1>>.

 f.  In the left panel, click 08-20-[your initials]. In the middle panel, click 
<Field List>, and in the right panel, double-click BirthDate.

 g. In the expression box, click <<date2>> and key now().

 h. In the expression box, click <<firstweekday>> and press Delete .

 i. In the expression box, click <<firstweek>> and press Delete .

 j. Delete the last two commas. Click OK.

 k. Print/Save the last page of the report.

 l. Close and save the report.

Exercise 8-21
Create a report using the Report Wizard. Add and modify sections and 
controls.

 1. Create a report with the Report Wizard by following these steps:

 a. Open and enable content for [your initials]-CC08.

 b. In the Navigation Pane, select qryEmployeeDates.

 c.  From the Create tab, in the Reports group, click the Report Wizard 
command .

 d. Add the following field names to the Selected Fields:

SSN
EmployeeID
HireDate

 e.  Click Next. Click the Remove One button  to remove the 
EmployeeID grouping. Click Next.

 f.  Click the drop-down arrow for the first sort level. Choose HireDate 
and click Next.

 g.  For the Layout, choose Tabular. For the Orientation, choose Portrait. 
Click Next.

 h. For the style, choose Apex. Click Next.

  i. Key 08-21-[your initials] as the title of the report.

  j. Select the option to preview the report. Click Finish.

  k. Close Print Preview.

 2. Add a group to a report by following these steps:

 a.  From the Design tab, in the Grouping & Totals group, click the Group 
& Sort command .

 b.  In the Group, Sort, and Total pane, click the Add a group button and 
choose HireDate. The section HireDate Header has been added.

 c.  Right-click the text box HireDate. From the menu, choose Layout and 
click Move up a Section.

NOTE

The Hire Date field is leftmost in the 
report because it is the sort field.
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AC-6 UNIT 2 Designing and Managing Database Objects

 d.  In the Group, Sort, and Total pane, click the Group on HireDate level, 
and click More.

 e.  In the by quarter option, click the drop-down arrow and choose year.

 f.   At the far right of the level, click the Promote button  to move the 
Grouping above the Sort level.

 g. In the HireDate Header section, click the HireDate text box.

 h.  From the Design tab, in the Tools group, click the Property Sheet 
command .

 i. On the Format tab, click the Format property and key yyyy.

 j.  Click the Hire Date label. In the Property Sheet, click the Caption 
property and key Year.

 3. Add a field to a report by following these steps:

 a.  From the Design tab, in the Tools group, click the Add Existing Fields 
command .

 b.  In the Field List, drag HireDate to the left side of the SSN text box in 
the Detail section.

 4. Format the controls by following these steps:

 a. Click the Year label.

 b.  From the Design tab, in the Font group, click the Center command .

 c.  From the Design tab, in the Font group, double-click the Format 
Painter command .

 d.  Click each of the labels in the Page Header section. Press Esc  to turn 
off the Format Painter.

 e. Click the HireDate text box in the HireDate Header section.

 f.  From the Design tab, in the Font group, click the Center command .

 g.  From the Design tab, in the Font group, double-click the Format 
Painter command .

 h.  Click the SSN and EmployeeID text boxes. Press Esc  to turn off the 
Format Painter.

 i. Save the report and preview it.

 j. Print/Save the first page of the report. Close the report.

Exercise 8-22
Create a report using the Report Wizard. Add and modify sections and 
controls.

 1. Create a report with the Report Wizard by following these steps:

 a. Open and enable content for [your initials]-CC08.

 b.  From the Create tab, in the Reports group, click the Report Wizard 
command .
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LESSON 8 Adding and Modifying Reports AC-7

c. For each table, add the following field names to the Selected Fields:

tblProductLines ProductLine
tblStuffedAnimals ProductName

UnitPrice
tblKitAssembly SKU

QTY

 d. Click Next. View the data by tblProductLines. Click Next.

 e. Double-click ProductName to add a group. Click Next.

 f.  Click the drop-down arrow for the first sort level. Choose SKU and 
click Next.

 g.  For the Layout, choose Stepped. For the Orientation, choose Portrait. 
Click Next.

 h. For the style, choose Solstice. Click Next.

 i. Key 08-22-[your initials] as the title for the report.

 j. Select the option to Preview the report. Click Finish.

 k. Close Print Preview.

 2. Modify controls by following these steps:

 a. Click anywhere in the Report Header to deselect the other controls.

 b.  In the ProductID Header, right-click the UnitPrice text box. From the 
menu, choose Layout and then Move Up a Section.

 c.  From the Design tab, in the Grouping & Totals group, click the Group 
& Sort command .

 d.  In the Group, Sort, and Total pane, click Group on ProductID. On the far 
right of this level, click the Delete button  to delete the grouping.

 e. Switch to Layout View.

 f.  From the Page Setup tab, in the Page Layout group, select the Margins 
arrow and select the Normal command .

 g. Rename the Name of Product Group label to Product Group.

 h. Resize the Product Group column to just fit its label.

 i. Resize the Unit Price column to just fit its label.

 j. Resize the Qty column to just fit its label.

 k. Resize the SKU column to just fit all data.

 l. Save and switch to Design View.

 3. Set group options and print/save by following these steps:

 a.  In the Group, Sort, and Total pane, click Group on ProductGroup and 
click More.

 b.  Click the drop-down arrow for do not keep together on one page and 
choose keep whole group together on one page.

 c. Save the report and preview it.

 d. Print/Save the first page of the report. Close the report.
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Exercise 8-23
Create a simple report. Add groups to a report. Apply Conditional 
Formatting

 1. Open and enable content for [your initials]-CC08.

 2. Create a simple report based on the qryLastOrder.

 3. Save the report as 08-23-[your initials].

 4. Resize the columns so that all data can be seen.

 5. Add a grouping for RegionName sorted in descending order.

 6. Modify the title label to Customer’s Last Order Report.

 7.  Delete the Time control in the Report Header section, and replace it with a 
label with the caption Prepared by: [your full name].

 8.  Use the Format Painter to copy the format from the new label in the 
Report Header section to the Date control.

 9.  Add Conditional Formatting for the Last Order Date text box in the Detail 
section. If the date is in the year 2006, use the format Bold with a purple 
Font Color.

 10.  Delete the page control in the Page Footer section, and close the section.

 11.  Make sure that all data and text can be seen.

 12.  Print/Save the report. Close the report.

Exercise 8-24
Create a multicolumn report. Size controls. Add a label.

 1.  Open and enable content for [your initials]-CC08, create a simple 
report for qryEmployeePhone.

 2. Delete the Employee ID control.

 3.  Resize the three controls in the Detail section so that the right edge of 
the HomePhone control is at the 31/2-inch mark.

 4. Save the report as 08-24-[your initials].

 5. Apply the AutoFormat Civic to the report.

Lesson Applications
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AC-9LESSON 8 Adding and Modifying Reports

 6.  Select the three labels in the Page Header section and make a copy. Place 
the copied labels to the right of the originals, starting at the 4-inch 
mark.

 7.  Change the report to use 2 columns that are 3.5 inches wide, with a 
column spacing of .45. The columns should run down and then across. 
The report must fit one page.

 8.  Select the three controls in the Detail section. Change their Top Margin 
property to .1 and their Height property to .30.

 9.  Delete the page number control. Add a label with the caption Prepared 
by: [your full name].

 10. Edit the label in the Report Header section to Employee Phone List.

 11.  Use the Group & Sort command to add a sort by Last Name and then by 
First Name. 

 12. Print/Save the report. Close the report.

Exercise 8-25
Create a group report based on a query. Modify controls and sections.

 1. Open and enable content for [your initials]-CC08.

 2. Use the Report Wizard to create a report for qryAnimalsByVender.

 3.  Use all fields. Group by ProductName and VenderName. Use the summary 
options to add the Sum function for LCost. Use a stepped layout and 
portrait orientation. Use the Urban style. Name the report 08-25-[your 

initials].

 4. Change the title label to Kit Costs by Vender.

 5. Resize each column so all data can be seen.

 6.  Delete the “Summary” controls in the VenderName Footer and 
ProductName Footer sections.

 7. Delete the controls in the Report Footer section.

 8.  Move the text box in the VenderName Footer to the right of the text box 
in the VenderName Header section.

 9. Delete the label in the VenderName Footer section, and close this section.

 10.  Move the text box in the ProductName Footer to the left to place it under 
the LCost controls in the other sections.

 11.  In the ProductName Footer move the “Sum” label to the left until it is 
next to its text box.

 12. Draw a straight line (2 pt) above the “Sum” label and text box.
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AC-10 UNIT 2 Designing and Managing Database Objects

 13.  Format the labels in the Page Header section to font size 14. Change 
LCost to Cost add spaces where needed in the other labels.

 14. Use the Hide Details command.

 15.  Add a label to right side of the Report Header with the caption Prepared 
by: [your full name].

 16. Print/Save the first page of the report. Save and close report.

Exercise 8-26  Challenge Yourself
Create a report using the Report Wizard. Add and modify controls. Sort 
and group records in a report. Add a calculated control for a group. Add a 
line.

 1. Open and enable content for [your initials]-CC08.

 2. Create a report using the Report Wizard.

 3.  From tblJobCodes, select JobTitle. From tblEmployees, select LastName 
and FirstName. From tblLeaveDays, select LeaveCategory and LeaveDate.

 4. You want to view the data by tblJobCode.

 5.  Add a group level for LastName and LeaveCategory. Choose the style 
Access 2007.

 6. Save the report as 08-26-[your initials].

 7.  Resize each control so all data can be seen. Double the width of the 
Job Title text box to better fit the data.

  8.  Move the FirstName text box up to the LastName Header 
group.

 9.  Change the EmployeeID group’s option to show the 
footer section, and hide the header section.

10.  Add a sort by JobTitle. Move Sort by JobTitle above 
Group on JobCode.

 11.  Add a text box to the LeaveCategory Header section. Drag the new 
text box until it has joined the control layout on the right side of the 
LeaveCategory control.

 12.  Set the unbound text box’s Control Source property to �Count(*) and set its 
label Caption property to Occurrences. Resize the control to fit the label.

 13. Center the content of this text box.

TIP

To move a Sort or Group up the list just 
click the Promote button .
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14.  In the EmployeeID Footer section, add a straight 
horizontal line starting at 1.5 inches and ending at 
5 inches. Move the line to the top of the section. Resize 
the section to leave just enough room for the line.

15.  Edit the title label to Employee Leave Breakdown.

16.  Add spaces where needed in the Page Header labels.

17.   Add a label in the far right of the Report Header 
section and key Prepared by: [your full name].

 18.  Print/Save the first page of the report. Save and close the report.

 19. Compact the database and close it.

On Your Own
In these exercises you work on your own, as you would in a real-life work 
environment. Use the skills you’ve learned to accomplish the task—and be 
creative.

Exercise 8-27
Review the design of the database that you modified in Exercise 7-31. On 
a sheet of paper, sketch three reports that will enhance the usability of this 
database. On each sketched report, describe who would use the report, the 
reason that the information in the report is valuable, and the frequency with 
which the report will be printed. Name each report and give it a title that 
best describes the purpose for the report. Write your name and Exercise 8-27 
on each sketch. Continue to Exercise 8-28.

Exercise 8-28
On the basis of the sketches you created in Exercise 8-27, create three 
reports. Select the style and layout most appropriate for each report. 
Arrange the controls as necessary. In the Page Footer, include your name 
and Exercise 8-28. In the Report Header, include the title of the report. Print 
a copy of each report. Continue to Exercise 8-29.

Exercise 8-29
Create a group for your report. Depending on your design, you may need 
to add a field to a table and enter appropriate data. Select the name, title, 
style, and layout most appropriate for the report. Arrange the controls as 
necessary. In the Page Footer, include your name and Exercise 8-29. Test 
your report in Print Preview. You may need to sort the records for the 
grouping to work appropriately. Print the report. Submit the copies of the 
sketches and reports that you printed in Exercises 8-27 through 8-29 to your 
instructor. Keep a copy of the database you modified in this exercise. You 
will use it for the On Your Own exercises in subsequent lessons.

REVIEW

The default Border Style property for a 
new line is transparent. You will need to 

change this property to see the line.
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