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Concepts Review

UNIT 2 Designing and Managing Database ObjectsAC-252

True/False Questions
Each of the following statements is either true or false. Indicate your 
choice by circling T or F.

1. As you move controls on a form, the tab order adjusts so controls are 
always in left-to-right and top-to-bottom order.

2. Every form contains a main section and a subsection.

3. A Multiple Items Form shows multiple items in a datasheet, displaying 
one record per row.

4. Control padding is the specified location of information inside a 
control.

5. Aligning a control is the same as aligning the text within a control.

6. The Page Header section of a form displays at the top of each printed 
page.

7. The top left selection handle is known as the Moving handle and is used 
to move the object without resizing it.

8. A label is associated with the data stored in the record source.

Short Answer Questions
Write the correct answer in the space provided.

1. What section on a form displays data for each record?

2. What type of information might be displayed in the Form Header section?

3. Which command do you use when adding a calculated control to a form?

4. What opens when you click the Build button  in a form?

5. What is the name of the Picture Size Mode setting that sizes an image to 
its original size?

6. What determines where the insertion pointer moves when you press Tab  
in a form?
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7. What command changes the text color in a label or a text box?

8. When you select a label, what appears around the object?

Critical Thinking
Answer these questions on a separate page. There are no right or wrong 
answers. Support your answers with examples from your own experience, 
if possible.

1. You can add, edit, delete, and search records through a datasheet of a 
table or query. When would it be more appropriate to use a form rather 
than a datasheet? When would it be more appropriate to use a datasheet?

2. In this lesson, you were introduced to some ideas about designing 
forms. What design principles should be followed when creating forms? 
How would the design differ from printed reports? Would the form 
design be different based upon the database user’s skill level and the 
confidentiality of the data?

Exercise 7-21
You have been asked to create a form that uses qryEmpDates to display, 
enter and edit employee information.

1. Open a database by following these steps:

a. Locate and open the Lesson 07 folder.

b. If you already have a copy of [your initials]-EcoMed-07, skip to step 1d.

c.  Make a copy of EcoMed-07 and rename it [your initials]-
EcoMed-07.

d. Open and enable content for [your initials]-EcoMed-07.

2. Create a multiple record form by following these steps:

a. In the Navigation Pane, select qryEmpDates.

b.  From the Create tab, in the Forms group, click More Forms  and 
choose Multiple Items .

c. From the Quick Access toolbar, click Save  to save the new form.

d. Name the new form frmEmpDates.

3. Format a form in Layout View by following these steps:

a. From the Design tab, in the Header/Footer group, click Title .

b. Replace the old title with EcoMed’s Employee Dates.

c. Click the first text box under the “Last Name” label.

Skills Review
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TIP

If the Select records option is not 
available, you are trying to create a PDF 

from Print Preview. This feature only 
works from the Save & Publish, Save 

Object As method.

07-21-A.pdf 
1 Page

d.  Hover your mouse over the bottom edge of the text box until you see 
a double-arrow. Click and drag up until you have reduced the height 
of the control by half.

e. Click the First Name label.

f.  From the Arrange tab, in the Rows & Columns group, click Insert 
Right .

g. Press Ctrl + S  to save the changes to the form.

4. Select multiple records in a form by following these steps:

a. Switch to Form View.

b.  Click the record selector for the first record and drag through the 
record for “Dyer.” You should have 8 records selected.

5. Save a form by following these steps:

 a.   Click the File tab and from the Save & Publish 
option, click Save Object As , then double-click 
PDF or XPS .

 b.   In the Publish as PDF or XPS dialog box, click the 
Option button. Select the Select records option and 
click OK.

  c.  Save the file as a PDF and name the file [your 
initials]-07-21-A.

  d. Click Publish.

  e. Save and close the form.

Assessment

-  According to your classroom procedure, turn in your database only when 
you have completed all assigned exercises.

- Depending on your class procedures, print or turn in the PDF file.

-OR-

- Depending on your class procedures, print or turn in the PDF file.

Exercise 7-22
Create a form to display, add, modify or delete employee job codes.

1. Create a single record form by following these steps:

a. Open and enable content for [your initials]-EcoMed-07.

b. In the Navigation Pane, select tblJobCodes.

c. From the Create tab, in the Forms group, click Form .

d. Press Ctrl + S . In the Save As dialog box, key frmJobCodes.
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TIP

Each section has its own vertical ruler that 
starts at 0 inches.

2. Modify the Title label by following these steps:

a. Switch to Design View.

b.  From the Design tab, in the Header/Footer group, click Title .

c. Key EcoMed’s Job Codes and press Enter .

d.  Right-click the Title label and select Size, then choose To Fit .

3. Modify controls in Design View by following these steps:

a.  Click the Job Code text box. Drag the right edge to the 
4-inch mark on the horizontal ruler.

b.  From the Arrange tab, in the Merge/Split group, click 
Split Horizontally .

c.  From the Arrange tab, in the Rows & Columns group, 
click Select Layout .

d. Click and drag the layout up to the top of the Detail section.

e.  Drag the top of the Form Footer bar up until there is only one row of 
dots showing below the JobTitle text box.

f.  Move your mouse above the top part of the JobCode text box until 
you see a down arrow. Click to select only the text boxes.

g.  Right-click the selected controls, select Special Effects , and choose 
Shadow effect (row 2, column 2).

4. Add a label by following these steps:

a. Drag the bottom of the Form Footer bar down ½ inch.

b. From the Design tab, in the Controls group, click Label .

c. Click in the Form Footer section.

d. Key Prepared by: [your full name]. Press Enter .

e. Drag the new label to the left part on the section.

f. Press Ctrl + S  to save the changes to the form.

Assessment

- Close the form.

-  According to your classroom procedure, turn in your database only when 
you have completed all assigned exercises.

-OR-

- Save a Form by following these steps:

 a. Click the File tab and from the Print option, click Print Preview .

 b. From the Print Preview tab, in the Data group, click PDF or XPS  to 
save the printout as a file.

 c. Save the file as a PDF and name the file [your initials]-07-22-A.

 d. Depending on your class procedures, print or turn in the PDF file.

 e. Close Print Preview and the form.

07-22-A.pdf 
1 Page
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Exercise 7-23
You have been asked to create a form based on qryVender that allows users 
to change vender information.

1. Create a single record form by following these steps:

a. Open and enable content for [your initials]-EcoMed-07.

b. In the Navigation Pane, select qryVender.

c.  From the Create tab, in the Forms group, click Form .

d. Press Ctrl + S . In the Save As dialog box, key frmVenInfo.

2. Modify controls by following these steps:

a.  Press PageDown  until you reach the record for Vender ID number “18.” 
This is the longest vender name.

b.  Drag the right edge of the Vender Name text box to reduce its width 
to just fit the content of the field.

c.  Click the City text box. From the Arrange tab, in the Rows & Columns
group, click Insert Right  twice.

d. Click on the State text box and drag it to the right of the City text box.

e. Click on the Zip text box and drag it to the right of the State text box.

f. Click the label for the City control and press Delete .

g. Click the label for the State control and press Delete .

h. Click the label for the Zip control and press Delete .

i. Click the blank cell above the Phone Number text box and press Delete .

j. Select the FAX label. While pressing Ctrl , click the FAX text box.

k. Drag the selected controls to the right of the Phone Number text box.

l. Click the blank cell below the FAX text box and press Delete .

m.  Click the FAX text box and drag its right edge to the right until you 
can see of the FAX number.

3. Add a label to a form by following these steps:

a. Switch to Design View.

b.  Drag the bottom edge of the Form Footer bar down to the ½-inch 
mark on the vertical ruler.

c.  From the Design tab, in the Controls group, click Label .

d. Click in the Form Footer section.

e. Key Prepared by: [your full name] and press Enter .

f. Drag the new label to the left part on the section.

4. Modify the Title label by following these steps:

a. From the Design tab, in the Header/Footer group, click Title .

b. Key Vender Contact Information and press Enter .

c. Right-click the Title label and select Size, then choose To Fit .

d. Save the form.
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Assessment

- Close the form.

-  According to your classroom procedure, turn in your database only when 
you have completed all assigned exercises.

-OR-

- Select a single record by following these steps:

 a. Switch to Form View.

 b. Press PageDown  until you reach Vender ID number “4.”

 c. Click the record selector.

- Save a single record by following these steps:

 a. Click the File tab and from the Save & Publish option, click Save Object 
As , then double-click PDF or XPS .

 b. In the Publish as PDF or XPS dialog box, click the Option button. Select 
the Select records option and click OK.

 c. Save the file as a PDF and name the file [your initials]-07-23-A.

 d. Depending on your class procedures, print or turn in the PDF file.

 e. Close Print Preview and the form.

Exercise 7-24
Create a form to display employee names and their ages.

1. Create a form using a wizard by following these steps:

a. Open and enable content for [your initials]-EcoMed-07.

b. From the Create tab, in the Forms group, click Form Wizard .

c. In the Tables/Queries drop-down box, choose Table: tblEmployees.

d.  In the Available Fields section, double-click LastName, FirstName, and 
DOB. Click Next.

e. Select Columnar. Click Next.

f. Name the form frmEmpAge. Click Finish.

2. Modify controls on a form by following these steps:

a. Switch to Design View.

b  Place your mouse pointer in the horizontal ruler at the 2-inch mark 
until it turns into a down arrow. Click to select the three text boxes in 
the Detail section.

c.  From the Arrange tab, in the Table group, click Stacked. Click the 
Detail to deselect the controls. 

d. Switch to Layout View.

e.  Click the Last Name text box. From the Arrange tab, in the Rows & 
Columns group, click Insert Right  twice.

07-23-A.pdf 
1 Page
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TIP

The final value in the Control Source 
property is =(Date()-[DOB])/365.25.

f.  Click the label for the DOB control. Press Ctrl  and click the DOB 
text box.

g. Drag the selected controls to the upper most right blank cell.

h. Click the blank cell below the First Name label and press Delete .

3. Add a calculation to a form by following these steps:

a.  From the Design tab, in the Controls group, click Text Box .

b. Click below the DOB text box.

c.  Switch to Design View. Double-click the unbound text box. In the 
Property Sheet, click the Data tab.

d.  Click in the Control Source property and click the Build button .

e. Key ( (left parentheses).

f.  In the Expression Elements panel, click Common Expressions.

g.  In the Expression Categories panel, double-click Current Date. This 
action adds the function Date(), which returns the current date.

h. In the top Expression window, key – (minus symbol).

i. In the Expression Elements panel, click frmEmpAge.

j. In the Expression Categories panel, click <Field List>.

k. In the Expression Values panel, double-click DOB.

l. In the top Expression window, key ) /365.25.

m. Click OK.

n.  In the Property Sheet, click the Format tab. In the Format property, 
choose Fixed.

o. Change the Decimal Places property to 0.

p. Click the calculated control’s label.

q. In the Property Sheet, click the Caption property and key Age.

4. Modify labels in a form by following these steps:

a.  Drag the bottom edge of the Form Footer bar down to the ½-inch 
mark on the vertical ruler.

b. From the Design tab, in the Controls group, click Label .

c. Click in the Form Footer section.

d. Key Prepared by: [your full name] and press Enter .

e. Drag the new label to the left part on the section.

f. In the Form Header, click the label “frmEmpAge” and press Delete .

g. From the Design tab, in the Header/Footer group, click Title .

h. Key EcoMed’s Employee Ages and press Enter .

i. Save the form.

Assessment

- Close the form.

-  According to your classroom procedure, turn in your database only when 
you have completed all assigned exercises.
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-OR-

- Select a single record by following these steps:

 a. Switch to Form View.

 b. Press PageDown  until you find the record for “May Lee.”

 c. Click the record selector.

- Save a single record by following these steps:

 a. Click the File tab and from the Save & Publish option, double-click Save 
Object As , then double-click PDF or XPS .

 b. In the Publish as PDF or XPS dialog box, click the Option button. Select 
the Select records option and click OK.

 c. Save the file as a PDF and name the file [your initials]-07-24-A.

 d. Depending on your class procedures, print or turn in the PDF file.

 e. Close the form.

- Create a Database Documenter report by following these steps:

 a. From the Database Tools tab, in the Analyze group, click Database 
Documenter .

 b. From the Documenter dialog box, click frmEmpAge check box.

 c. Click Options.

 d. For Form, do not include any options.

 e. For Include for Sections and Controls, select Name and Properties.

 f. Click OK twice to go to Print Preview.

- Save a Database Documenter report by following these steps:

 a. From the Print Preview tab, in the Data group, click PDF or XPS  to 
save the printout as a file.

 b. In the Publish as PDF or XPS dialog box, click the Option button. Select 
the Pages option. Print only page 10 and click OK.

 c. Save the file as a PDF and name the file [your initials]-07-24-B.

 d. Depending on your class procedures, print or turn in the PDF file.

 e. Close Print Preview and the form.

07-24-A.pdf 
1 Page

07-24-B.pdf 
1 Page
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Lesson Applications

07-25-A.pdf 
1 Page

Exercise 7-25
You have been asked to create a form to enter in the names and address of 
new interns.

1. Open and enable [your initials]-EcoMed-07.

2. Using the Form Wizard, create a Columnar form using the fields 
LastName, FirstName, Street, City, State, and ZipCode from tblInterns.

3. Save the form as frmInterAddress.

4. Delete the labels for Street, City, State, and ZipCode.

5. Move the State and ZipCode text boxes next to the City text box so that 
the address resembles the address on a mail label.

6. Delete the label that the wizard placed in the top of the form. Add a title 
control that reads EcoMed Intern’s Address.

7. Add a label on the left section of the Form Footer. Key Prepared by: 
[your full name].

8. Reduce the width of the State and ZipCode text box to fit the data. 
Reduce the width of the form to fit on one page.

9. Save the form as a PDF. Only show the record for intern “Ben Kyle.” 
Name the file [your initials]-07-25-A.

Assessment

- According to your class procedures, print or turn in the PDF file.

-  According to your classroom procedure, turn in your database only when 
you have completed all assigned exercises.

-OR-

- According to your class procedures, print or turn in the PDF file.

Exercise 7-26
Create a form to display the names of the management companies for 
each facility. Include the state in which the facility is located.

1. Using [your initials]-EcoMed-07, create a Multiple Items form based 
on qryManFac.

2. Save the form as frmManFac.
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3. Edit the title label to EcoMed’s Facilities by Management Corp.. Size the 
label to fit the title.

4. Make the width of the Manage Name and Facility Name text boxes 
3 inches and the State text box ½ inch.

5. Add Date and Time controls to the Form Header.

6. Add a label on the left section of the Page Footer. Key Prepared by: 
[your full name].

Assessment

-  According to your classroom procedure, turn in your database only when 
you have completed all assigned exercises.

-OR-

-  Save the form as a PDF. Only show the records that have the Manage 
Name “Health Alliance.” Name the file [your initials]-07-26-A.

- According to your class procedures, print or turn in the PDF file.

Exercise 7-27
Create a form that displays the names and address of all medical facilities.

 1. Create a new form for tblFacilities by using the Form command .

 2. Name the form frmFacData.

 3. Split the City text box into three cells. Move the State and ZIP text boxes 
to the blank cells next to the City text box.

 4. Delete the labels for City, State, and ZIP. Remove the blank row of cells.

 5. Widen the text boxes in the address so that all the data can be seen. Make 
sure that you do not make the Address text box wider than 3 inches.

 6. Apply a shadowed effect to all the text boxes.

 7. Delete both the Region text box and label.

 8. By adding cells to the right of the control layout, 
create two new columns of cells. Move the labels and 
text boxes for PhoneNum through ContactLastName 
into the new cells. The controls for FacilitiesID and 
PhoneNum should be on the same row.

 9. Delete all rows of blank cells in the form. Resize all 
labels and text boxes so that the data is visible without 
the form being wider than 10-inches.

 10. Edit the title label and key EcoMed’s Facility Data.

 11. Add a label to the lower left section of the Form Footer and key Prepared 
by: [your full name].

07-26-A.pdf 
1 Page

TIP

You will need to use Print Preview to set 
the page orientation but must use the 

Backstage to save the form with a 
selected record.
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07-27-A.pdf 
1 Page

NOTE

There are 365.25 days in a year.

Assessment

-  According to your classroom procedure, turn in your database only when 
you have completed all assigned exercises.

-OR-

-  Save the form in landscape orientation as a PDF. Only show the records 
the Facilities ID “43.” Name the file [your initials]-07-27-A.

- According to your class procedures, print or turn in the PDF file.

Exercise 7-28  Challenge Yourself
Create a form that displays an employee’s name, hire date, the date of his 
or her 5-year anniversary, the date of his or her 10-year anniversary, and 
the date of his or her 25-year anniversary.

 1. Create a simple form based on tblEmployees and save it as 
frmEmpAnniverDates.

 2. Delete all fields and labels except Last Name, First Name, and Hire Date.

 3. Clean up the layout by deleting all blank rows.

 4. Resize the width of the text boxes to 1.2 inches and their labels 
.9 inches wide.

 5. Add a new text box to the control layout, right of the Hire Date text box.

 6. Change the label to read 5 Years.

 7. Set the Control Source property for the unbound text 
box to show a date five years after an employee’s 
hire date.

 8. Set the Format property for the 5 Years text box to Short Date.

 9. Repeat steps 5 through 8 but change the label and equation to represent 
10 years. Place this new control to the right of the 5 Years control.

 10. Repeat steps 5 through 8 but change the label and equation to represent 
25 years. Place this new control to the right of the 10 Years control.

 11. Edit the title to EcoMed Employees’ Anniversary Dates.

 12. Add a label to the lower left section of the Page Footer and key Prepared 
by: [your full name].

 13. Resize controls to fit the width of a portrait layout page.

Assessment

-  According to your classroom procedure, turn in your database only when 
you have completed all assigned exercises.

-OR-

07-28-A.pdf 
1 Page
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-  Save the form as a PDF. Only print the first page. Name the file [your 
initials]-07-28-A.

- According to your class procedures, print or turn in the PDF file.

-  Create a Database Documenter report for frmEmpAnniverDates using the 
following settings:

• Include for Form: Nothing

• Include for Sections and Controls: Names and Properties

-  Save pages 17 through 20 of the Documenter report as a PDF file named 
[your initials]-07-28-B.

- According to your class procedures, print or turn in the PDF file.

- Compact and close your database. Exit Access.
07-28-B.pdf 

4 Pages

On Your Own

In these exercises, you work on your own, as you would in a real-life work 
environment. Use the skills you’ve learned to accomplish the task—and be 
creative.

Exercise 7-29
Using the Form Wizard, create a form for the main table of the database you 
modified in Exercise 6-32. Include all fields from the table in your form. On the 
form printout, sketch changes that will improve each form. Using the Form 
Wizard, create forms for each additional table in your database. Print a copy of 
each form. On each form printout, sketch changes that will improve each form. 
On each form, write your name and “Exercise 7-29.” Continue to Exercise 7-30.

Exercise 7-30
Modify your forms to incorporate the improvements you sketched. In the 
Form Footer of each form, include your name and Exercise 7-30. In the 
Form Header, include the name of the form and the current date. Print the 
data contained in each of your tables. Print a copy of each form. Test your 
redesigned forms by having another person enter the data. On each form 
printout, sketch changes that will improve your form. Continue to 
Exercise 7-31.

Exercise 7-31
Modify your forms appropriately. Analyze your database design. Determine 
if any additional forms might be required for queries or recordsets. Create 
any additional forms you might need. On each form, include your name and 
Exercise 7-31 in the Form Footer. Print a copy of each form. Submit the 
copies of the forms you printed in Exercises 7-29 through 7-31 to your 
instructor. Keep a copy of the database you modified in this exercise. You 
will use it for the On Your Own exercises in subsequent lessons.
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