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	Chapter 9
	Pre-Test / Post-Test Questions


Multiple Choice:

1. Goal seeking refers to which of the following?

a. calculating an input value based upon a form

b. calculating an input value required to yield a desired outcome result

c. calculating an output value required to produce a desired input

d. none of the above

2. To perform graphical goal seeking, you perform what operation on the marker at the top of chart’s column?

a. drag

b. double-click

c. Ctrl+click

d. none of the above

3. Which forecast function uses an exponential growth equation to predict future values based on existing or historical results?

a. forecast

b. growth

c. rsq

d. trend

4. If you add, modify, or delete records in a data source (usually a worksheet list), you must refresh the PivotTable report by clicking which button on the PivotTable toolbar?

a. Update data

b. Refresh data

c. Reload data

d. none of the above

5. You can spare yourself a lot of effort by saving the arrangement of workbooks in a special file known as a:

a. workfile

b. worksheet

c. workbook

d. workspace

6. Which of the following enables you to calculate the input value required to yield a desired outcome result?

a.
Tools, Goal Seek

b.
Insert, Goal Seek

c.
Format, Goal Seek

d.
Tools, Options, Goal Seek

e.
Data, Goal Seek

7. Which of the following symbols are used to indicate an array formula?

a.
( )

b.
{ }

c.
[ ]

d.
| |

e.
< >

8. In a _______________, a single input cell is replaced with a set of values for calculating one or more formulas.
a.
one-input data table

b.
two-input data table

c.
scenario manager

d.
both A and B are correct

e.
A, B and C are all correct

9. _______________ are useful for aggregating different points of view from your friends, associates, and coworkers.

a.
Scenarios

b.
PivotTables

c.
Forecasting

d.
Goal Seeking

e.
Goal Setting

10. A(n) _______________ summarizes how an outcome formula changes when you modify the values stored in two of its input cells.

a.
Goal Seek

b.
One-input data table

c.
Two-input data table

d.
Growth Forecasting

e.
Scenario Manager

11. Which forecast function returns a statistical measure that shows how closely a linear line approximates the existing data?

a. forecast

b. growth

c. rsq

d. trend

12. Which of the following components of PivotTable report is used to group and summarize data in a vertical orientation?

a. Column field

b. Row field

c. Data field

d. Page field

13. Some of the settings that you can store in a custom view include which of the following?

a. column widths

b. row heights

c. hidden columns

d. all of the above

14. Which of the following are summary reports created by Solver?

a. Answer

b. Sensitivity

c. Limits

d. A,B, and C

e. none of the above

15. Which of the following attempts to fit a straight line to a set of existing data in the hope of illustrating a relationship?

a. 
R-square analysis

b.
deviation analysis

c.
regression analysis

d.
x-y analysis

e.
curvilinear analysis

True / False:

16.
_
Excel’s most basic what-if tool is the worksheet formula itself.

17.

The statistical models used by the forecasting features are known as linear trends or linear regression analysis.

18.

A two-input data table summarizes how an outcome formula changes when you modify the values stored in two of its formulas.

19.

A PivotChart report enables you to view the data summarized in a PivotTable textually.

20.

You can only print one worksheet at a time from Excel.

21.

 The Solver can be used to calculate shift schedules for manufacturing, ingredient combinations in pharmaceutical research, and economic order quantities for purchasing.

22.

A gridline is simply a calculated regression line that you add to a chart in order to show a trend in an existing data series.

23.

A PivotTable report may be formatted, customized, refreshed, printed, plotted in a chart, or saved as a Web Page.

24.

By default, the PivotTable and PivotChart wizard does not use all of the data in a worksheet list when creating a PivotTable report.

25.

There are two methods for creating a Web-based PivotTable

Fill in the blanks:

26.
A _____-_____ analysis is a worksheet model that lets you calculate possible outcomes for a given set of assumptions.

27.
Assumptions are also known as _____ cells or variables, and are typically grouped together to speed data entry.

28.
A scenario is a set of _____.

29.
A PivotTable report is an interactive but static table that _____ and displays summarized data in a worksheet.

30.
To many people a _____ refers to a hard copy printout.

31.
The Solver add-in program evaluates the most efficient solutions for problems with multiple input values and _____.

32.
_____ analysis attempts to fit a straight line to a set of existing data in the hope of illustrating a relationship.

33.
In a _____-_____ data table, a single input cell is replaced with a set of values for calculating one or more formulas.

34.
You can view a PivotTable’s results graphically using a _____ report or publish a PivotTable to the Web.

35.
A _____ _____ is a combination of display and print options to which you can give a name and save along with a workbook.

	Chapter 9

	Pre-Test / Post-Test Answer Key


Multiple choice:


1. B (9.1.1:9-3)

2. A (9.1.1:9-4)

3. B (9.2.1:9-24)

4. B (9.4.2:9-57)

5. D (9.5.3:9-75)

6. A (9.1.1:9-4)

7. B (9.3.1:9-45)

8. B (9.3.1:9-40)

9. A (9.1.4:9-22)

10. C (9.3.2:9-46)

11. C (9.1.2:9-9)

12. C (9.1.3:9-17)

13. C (9.2.1:9-24)

14. A (9.4:9-46)

15. D (9.5.2:9-72)

True / False:

16. T (9.1:9-3)

17. T (9.2.1:9-23)

18. F (9.3.2:9-43)

19. F (9.4.4:9-60)

20. F (9.5.1:9-69)

21. T (9.1.1:9-9)

22. F (9.2.2:9-31)

23. T (9.4.1:9-47)

24. F (9.4.1:9-51)

25. T (9.4.5:9-63)

Fill in the blanks

26. what-if (9.1:9-3)

27. input (9.1:9-3)

28. assumptions (9.1.3:9-16)

29. formats (9.4:9-46)

30. report (9.5:9-69)

31. constraints (9.1.1:9-9)

32. Regression (9.2.1:9-23)

33. one-input (9.3:9-37)

34. PivotChart (9.4:9-46)

35. custom view (9.5.2:9-72)
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	Chapter 9
	Decision-Making Using Excel


Overview

Chapter 9 presents a variety of features and tools which can be used in decision making from within Excel.  As well, presentation tools and features are highlighted in this chapter.  This chapter covers such topics as the support for what-if analysis from within Excel by using such features as goal seeking, the solver add-in, and scenario management.  Trend analysis and forecasting is also covered by introducing a variety of statistical functions and the creation of trendlines on graphs.

Additionally, Chapter 9 provides instruction and direction on the use of one- and two-input data tables, PivotTables, PivotCharts, exporting PivotTables to a HTML page, as well as the creation of custom views and workbooks.

Tips and Teaching Strategies

When discussing the use of custom views and printing of multiple worksheets, it’s a good time to revisit the notion of the use of multiple worksheets in a workbook.  Many students rely only on one worksheet to analyze and organize their data.  However, they should get accustomed to the notion of using multiple worksheets, with inter-related data and formulas.  It’s very common to see workbooks in commercial and professional environments which take advantage of the ability to organize and relate data across multiple worksheets in Excel.  

Section 9.1 – Performing What-If Analysis

Section 9.1 introduces the various tools and features in Excel which allow for What-If analysis of data in the worksheets.  These include the goal seeking features (simple and graphical), the Solver Add-In, and the Scenario Management features.

Section 9.1.1 – Using Goal Seeking

Concept:
Using Goal Seeking

Method:
To use goal seeking in a worksheet, choose the Goal seek menu item from the Tools menu.  Then, in the Goal Seek dialog box that appears, enter the reference of the cell to modify in the Set cell text box, the value to change the cell to in the To value text box, and the cell to change in the By changing cell text box.  Then, click the OK button.

Excel will automatically rework the cell to change (specified by the 3rd text box) to change the value of the 1st text box to the value specified in the 2nd text box.

Notes:
None.

Concept:
Graphical Goal Seeking

Method:
To perform goal seeking on an Excel graph, create and display the desired graph.  Then, select the data column from the graph you wish to adjust.  You may need to first select the data series, and then the column, resulting in two select actions, not a double-click.  Once the column is selected, drag the column marker to the desired value and the Goal Seek dialog box will appear with the first two text boxes filled in.

Complete the third text box by selecting the input cell to adjust and click the OK button to complete the Goal Seeking operation.

Notes:
None.

Section 9.1.2 – Using Solver

Concept:
Using the Solver Add-in

Method:
To use the Solver Add-in with an Excel spreadsheet, choose the Solver menu item from the Tools menu.  Then, in the resulting dialog box that appears, check the Solver Add-in check box and click the OK button.

The Solver dialog box will appear, and you can then provide the control parameters for the solver.  The dialog box is a complex interface, thus we won’t attempt to detail every aspect of its use here.  You can set the outcome cell (containing the formula to optimize) by using the Set Target Cell text box, and provide guidance for its result in the Equal To: region of the dialog box.

Clicking the Add button will result in the display of the Add Constraint dialog box, which permits users to add additional formula constraints to the Solver.  Click the OK button after adding a constraint to return to the Solver dialog box.

Click the Solve button on the Solver dialog box to initiate the solver’s execution.  When a solution is found, a results dialog box will be displayed, allowing you to accept or reject the solution.  After reaching a solution, Solver lets you create three summary reports.
Notes:
Since Solver is an Add-in feature of Excel 2003, make sure that it is installed on the computer in a lab environment.
Section 9.1.3 – Using Scenario Manager

Concept:
Adding a scenario

Method:
To add one or more scenarios to a worksheet, choose the Scenarios menu item from the Tools menu.  Then, click the Add button to display the Add Scenario dialog box.  Enter a name for the scenario in the Scenario name text area, specify the required input cells in the Changing cells text box, and add a comment in the appropriate text region.  Click the OK button to proceed to the Scenario Values dialog box where you can enter updated values for each of the input cells specified in the Add Scenario dialog box.  Click the OK button to return to the Scenario Manager dialog box.  You can add, edit, or delete scenarios from this dialog box as needed.

Notes:
None.

Concept:
Displaying a scenario

Method:
To display a single scenario, display the Scenario Manager dialog box by choosing the Scenarios menu item from the Tools menu.  Then, select the desired scenario to display from the Scenarios list box and click the Show button.

A summary of all scenarios can be displayed by clicking the Summary command button in the Scenario Manager dialog box.

Notes:
None.

Section 9.1.4 – Manipulating Scenarios

Concept:
Manipulating Scenarios

Method:
Scenario Manager allows you to edit, delete, or merge different scenarios.


To edit or delete an existing scenario, select the desired scenario from the Scenarios option of the Tools menu.  Then, select the edit or delete command button.

To merge a scenario, you must first open the workbook that contains the scenario and then select the merge command button.  Next, select the workbook, worksheet, and scenarios you want to merge.

Notes:
None.

Section 9.2 – Finding Trends and Forecasting Results

Section 9.2 introduces four statistical functions used to predict trends and future values.  These include the forecast, growth, rsq, and trend functions.  Additionally, this section covers the application of trendlines to existing Excel graphs.

Section 9.2.1 – Statistical Forecasting Functions

Concept:
Forecasting functions in Excel

Method:
Excel contains several functions used for statistical forecasting.  The functions covered by section (and their purpose) are as follows:

· Forecast function – uses a linear trend equation to predict future values.  Syntax: =forecast(new-x, y-set, x-set), where new-x is the corresponding x-value for which the y-value will be predicted, based upon the existing data from the y-set and x-sets.
· Growth function – uses an exponential growth equation to predict future values.  Syntax: =growth(y-set, x-set, new-x), where new-x is the corresponding x-value for which the y-value will be predicted, based upon the existing data from the y-set and x-sets.

· RSQ function – returns the statistical r-square value based upon the x-set and y-set provided.  Syntax: =rsq(y-set, x-set), where x-set and y-set are the existing data ranges the r-square value is based on.

· Trend function – uses a linear trend equation to find a fit for a straight line through existing results.  Syntax: =trend(y-set, x-set, new-x), where y-set and x-set represent the existing results, and new-x is the corresponding x-value for which the y-value will be predicted. 

Notes:
None.

Section 9.2.2 – Calculating Trendlines

Concept:
Adding trendlines to charts

Method:
You can add a trendline to a graphical chart in Excel to highlight a trend in an existing data series.  To do so, select the data series in the plot area for which you want to calculate and display the trendline.  Then, choose the Add Trendline menu item from the Chart menu.  Next, select the type of trendline to add to the chart, and select the number of periods (if desired) to predict (via the Options tab).  Finally, click the OK button to add the trendline to the chart.

Notes:
You may want to state that Excel 2003 provides an add-in program called Analysis ToolPak for advanced data analysis.

Section 9.3 – Working with Data Tables

Section 9.3 walks through the use and creation of one- and two-input data tables in a worksheet.  Data tables are used to summarize (in a separate area) the effects of changes to a formula, given changes to one or two variables.

Section 9.3.1 – Creating a One-Input Data Table

Concept:
Using a one-input data table to summarize changes to a single value

Method:
You can use a one-input data table to summarize the changes in a worksheet to a single value.  To create the table, select a cell range which encompasses the set of input values, the desired formula(s) to calculate, and the output area for the table.  Then, choose the Table menu item from the Data menu.  In the Table dialog box that appears, specify the input cell for which the substitution will occur for the set of input values.  Then click the OK button and the table will be created in the previously selected output area.

Notes:
None.

Section 9.3.2 – Creating a Two-Input Data Table

Concept:
Using a two-input table to summarize changes to a single value

Method:
To create a two-input data table to summarize the changes in a worksheet against two values, create two sets of input values used to substitute into a desired formula.  The sets should be created in a row and column format.

Then, enter the desired formula in the cell which intersects the row and column (generally the cell in the upper-left corner of the region that contains the row and column sets).  Select the entire region, thereby selecting the input sets, the output area, and the formula specified and choose the Table menu item from the Data menu.  In the Table dialog box that appears, specify the input cells for which to substitute the two sets of input values and click the OK button.  The table will then be created in the previously selected output area.

Notes:
None.

Section 9.4 – Working with PivotTables and PivotCharts

Section 9.4 introduces the use of PivotTables and PivotCharts as another feature which can be used for data analysis and representation.  The section covers the creation of both PivotTables and PivotCharts, as well and the applying of formatting style, modifying the layout, and the printing of a PivotTable.  Instructions are also provided for exporting a PivotTable as an interactive and non-interactive web page.

Section 9.4.1 – Creating a PivotTable Report

Concept:
Creating a PivotTable

Method:
PivotTables can be used to summarize and analyze data in a worksheet, especially those containing large amounts of data.  To create a PivotTable from existing data, select any cell from the worksheet containing the desired data, and choose the PivotTable and PivotChart Report menu item from the Data menu.  Then, in the resulting wizard dialog box that appears, select the source of the desired data and click the PivotTable option button followed by the Next > button.

In the second page of the wizard, provide the range of the data (if you are using data from an Excel worksheet), and click the Next > button.  Finally, in the last page, choose to place the table in a new or existing worksheet and click the Finish button.

The table will be added to the selected worksheet, where you can then drag the existing data fields (displayed in a field list) into the outline of the table, organizing it as desired.

Notes:
It is important to know that the PivotTable Wizard uses all of the data in a worksheet when creating a PivotTable report.  If a filtered data is desired then the data must be filtered first, before creating a PivotTable report.

Section 9.4.2 – Customizing a PivotTable Report

Concept:
Customizing a PivotTable

Method:
To customize a PivotTable, you can drag the fields contained in the report to a new position in the report, thereby reorganizing and restructuring the report as needed.

Notes:
None.

Concept:
Applying AutoFormatting to a PivotTable

Method:
To apply an AutoFormat style to a PivotTable, right-click on a cell from the PivotTable, click the PivotTable button on the PivotTable toolbar and choose the Format Report menu item.  In the AutoFormat dialog box that appears, select a report format and click the OK button to apply the desired format to the PivotTable.

Notes:
None.

Section 9.4.3 – Printing a PivotTable Report

Concept:
Print a PivotTable report

Method:
To print a PivotTable report, preview the report by clicking the Print Preview button on the Standard toolbar and then clicking the Print button, or by clicking the Print button on the Standard toolbar.

Section 9.4.3 includes a description of setting various print options for the PivotTable by accessing the PivotTable Options dialog box via the PivotTable button on the PivotTable toolbar.

Notes:
None.

Section 9.4.4 – Creating a PivotChart Report

Concept:
Creating a PivotChart report

Method:
To create a graphical report which is also a PivotChart, start by selecting any cell from an existing worksheet and choose the PivotTable and PivotChart menu item from the Data menu.  Then, in the PivotTable and PivotChart wizard dialog box that appears, select the data source and type of report to create (PivotChart report) and click the Next > button.

On the second page of the wizard, provide the range of cells which contain the report’s data, and click the Next > button.  Finally, on the last page of the wizard, specify where the report output is to be created (on a new worksheet or on an existing worksheet) and click the Finish button.

In the graph that is created by the wizard, drag and drop fields from the PivotTable field list into the various report areas, creating the graphical report from the data.

Notes:
None.

Section 9.4.5 – Creating a Web-Based PivotTable

Concept:
Saving a PivotTable as a non-interactive HTML (Web) page

Method:
To save a PivotTable as a non-interactive HTML table, select the PivotTable to publish and choose the Save as Web Page menu item from the File menu.  Then, in the Save region, select the Selection: sheet option button and enter a web page name in the File name text box.  Click the Save button to complete the creation of the page. 

Notes:
None.

Concept:
Saving a PivotTable as an interactive HTML (Web) page

Method:
To save a PivotTable as an interactive HTML page, select the table and choose the Save as Web Page menu item as detailed above.  Then, click the Publish button to open the Publish as Web Page dialog box.

Once displayed, select the PivotTable item from the Item to publish list area, and select the Add interactivity with checkbox in the Viewing options area.  Select the PivotTable functionality from the drop-down list box (in the Viewing options area) and provide a web page name in the File name text box.  Click the Publish command button to complete the operation.

Notes:
None.

Section 9.5 – Managing and Reporting Results

This section covers advanced display features such as the printing of multiple worksheets from a workbook.  In addition, the creation and use of workbook custom views are discussed, as well as the creation of an Excel workbook (used to record which workbooks and worksheets are currently being utilized).

Section 9.5.1 – Printing Multiple Worksheets

Concept:
Printing an entire workbook

Method:
To print an entire workbook (containing multiple worksheets), choose the Print… menu item from the File menu.  Then, click the Entire workbook option in the Print what area of the Print dialog box that appears.  Finally, click the OK button to send the entire workbook to the specified printer.

Notes:
None.

Concept:
Printing selected worksheets of an Excel workbook

Method:
To print only selected worksheets of a workbook, first hold the CTRL key down and click on the tabs of the desired worksheets you wish to print.  As you select each sheet, the tabs will turn white in color, indicating that they have been selected.   Next, choose the Print…menu item from the File menu, displaying the Print dialog box.  Note that the Active sheet(s) option has been selected in the Print what area of the dialog box.  To complete the printing of the selected sheets, click the OK button to send the worksheets to the specified printer.

Notes:
None.

Section 9.5.2 – Creating Custom Views

Concept:
Creating and using a custom view

Method:
Users can create custom views of a workbook, controlling what is displayed and printed.  Custom views can be created by setting all characteristics of display and printing and then choosing the Custom Views menu item from the View menu.  In the Custom View dialog box which then appears, click the Add… button to display the Add View dialog box.

Next, provide a name for the view and select what to store with this view (print settings and/or hidden rows, columns and filter settings).  Then click the OK button to record the view.

Notes:
None.

Concept:
Changing a view

Method:
To change the display to a custom view, choose the Custom Views menu item from the View menu.  Then, select a view from the Views list in the Custom Views dialog box that appears.  Finally, click the Show button to display the view.  Once displayed, the view can be printed, applying the settings saved in the view.

Notes:
None.

Section 9.5.3 – Creating a Workspace

Concept:
Creating an Excel workspace

Method:
Workspace files can be created and saved, storing the information about which workbooks and worksheets were displayed.  Workspaces don’t contain the actual workbooks and worksheets, but rather record the display state of the workbooks and worksheets.

To create a workspace, choose the Save Workspace… menu item from the File menu.  In the Save Workspace dialog box that appears, provide a location and name for the workspace file, and click the Save button.

Notes:
None
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Chapter 9 
Answers to End-Of-Chapter Review Questions

Short Answer

1.
List three tools for performing what-if analysis. The what-if analysis tools include: Goal Seek, Solver, Data Tables, forecasting functions (TREND, FORECAST, etc.), trendlines, and Scenario Manager.
2.
In what way do Goal Seek and Solver work backwards when performing what-if analysis? With both Goal Seek and Solver, the user defines the desired target value (end result) and then uses these tools to determine what the input values (starting points) must be.
3.
What are the three options in Solver for optimizing an outcome formula? The outcome formula can be defined as the maximum value, the minimum value, or as a specified value.
4.
What is a constraint? Provide an example. A constraint is a limitation placed on the values that Solver must return to the user.  Example: In solving for the number of hours an employee must work to produce a certain sales volume, a constraint may be that the number of hours worked per week does not exceed 40.
5.
List the three types of reports that you can produce using Solver. 

· Answer - Lists the target cell and the adjustable cells with their original and final values, constraints, and information about the constraints

· Sensitivity - Provides information about how sensitive the solution is to small changes made to the formula or to the constraints

· Limits - Lists the target cell and the adjustable cells with their respective values, lower and upper limits, and target values

6.
When might you want to use Scenario Manager to perform a what-if analysis? You use the Scenario Manager to examine and compare the calculated outcomes of several different models based on different assumptions and input values.
7.
What are the types of trendlines that you can add to a chart? On the Type tab of the Add Trendline dialog box, you can select from Linear, Logarithmic, Polynomial, Power, Exponential, and Moving Average. 
8.
In what way is a two-input data table more limiting than a one-input data table? A two-input table can only display a single set of results whereas a one-input table can be used to calculate sets of results for several calculations.
9.
What is the purpose of a page field in a PivotTable report? The page field allows the user to filter the data summarized in the data area.

10.
What is saved in a custom view? In the Add View dialog box, you can choose to save the print (Print settings check box) and/or the display (Hidden rows, columns, and filter settings check box) settings. 
True/False

	1.
	T
	6.
	F

	2.
	F
	7.
	T

	3.
	T
	8.
	F

	4.
	T
	9.
	F

	5.
	T
	10.
	T


Multiple-Choice

	1.
	a
	6.
	c

	2.
	a
	7.
	a

	3.
	d
	8.
	b

	4.
	b
	9.
	c

	5.
	d
	10.
	b
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